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Abstract 
Building Information Modeling (BIM) is currently one of the fastest 

developing building design methods. Creation of a building using this 
technology involves the whole investment process, from the concept, through 
the design and evaluation process, to the execution and delivery of the building 
into operation. The main premise of the BIM technology is to design an object in 
3D and then on the basis of a three–dimensional model created–generation of all 
design documentation. 

In this monograph, the authors concluded a comprehensive review of the 
literature on the use of the BIM technology in construction industry. The basic 
assumptions and concepts related to the BIM are explained in the introduction. 
The design methodology was discussed, starting with the rules for creating 
objects in the BIM environment, the classification rules for these objects, and the 
tools that are used in a 3D design. The characteristics of the BIM environment, 
the topic of a model’s parameters management, and the subject of a drawing 
documentation were discussed. The systems of cooperation of the BIM programs 
with a family of CAD programs, or programs used to carry out calculations of 
the structural load bearing capacity of a building were described. It was 
discussed how each participant in the investment process can make use of BIM 
technology for its needs and what benefits it brings. The study part ends with a 
case study, in which examples of building investments using BIM technology 
were given. 

The second part of the work is a description of the practical application of 
BIM technology–the designer’s workshop, using Tekla Structures software. The 
authors at the outset discuss the program environment, demonstrate how to build 
grids and analyze graphical interface. It was showed how to create steel elements 
with connections in nodes, concrete and reinforced concrete elements. Issues 
related to the model control, drawing and executive documentation were 
discussed. The monograph is ended with presentation of the Tekla BIMSight 
software as a universal environment for inter–model viewing and the clashes 
detection. 
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Streszczenie 
Technologia BIM (ang. Building Information Modeling) jest obecnie jedną  

z najszybciej rozwijających się metod projektowania budynków. Kreowanie 
obiektu budowlanego z wykorzystaniem tej technologii obejmuje cały proces 
inwestycyjny, poczynając od koncepcji, przez proces projektowania i ewaluacji, 
wykonawstwo, aż do oddania obiektu do użytku. Głównym założeniem 
technologii BIM jest projektowanie obiektu w 3D, a następnie na podstawie 
stworzonego trójwymiarowego modelu – generacja całej dokumentacji 
projektowej. 

W pracy autorzy zawarli obszerny przegląd literatury z zakresu 
wykorzystania technologii BIM w budownictwie. We wstępie wyjaśniono 
podstawowe założenia i koncepcje związane z BIM. Omówiono metodykę 
projektowania, począwszy od zasad tworzenia obiektów w środowisku BIM, 
zasady klasyfikacji tych obiektów, oraz narzędzia jakie są wykorzystywane 
podczas projektowania 3D. Przedstawiono charakterystykę środowiska BIM, 
omówiono tematykę zarządzania parametrami modelu, i problematykę tworzenia 
dokumentacji rysunkowej. Opisano systemy współpracy programów BIM  
z rodziną programów typu CAD, czy programami służącymi do 
przeprowadzenia obliczeń nośności elementów konstrukcyjnych obiektu 
budowlanego. Omówiono w jaki sposób każdy uczestnik procesu 
inwestycyjnego może wykorzystać na swoje potrzeby technologię BIM i jakie 
niesie to za sobą korzyści. Część studialną kończy studium przypadku, gdzie 
podano przykłady inwestycji budowlanych, w których użyto technologię BIM. 

Drugą część pracy stanowi opis praktycznego zastosowania technologii BIM 
– warsztat projektanta, z zastosowaniem oprogramowania Tekla Structures. 
Autorzy na wstępie omawiają środowisko programu, pokazują w jaki sposób 
tworzyć siatki konstrukcyjne i analizują interfejs graficzny. Pokazano sposoby 
tworzenia elementów stalowych z połączeniami w węzłach, elementów 
betonowych i żelbetowych. Omówiono zagadnienia związane z kontrolą 
modelu, tworzeniem dokumentacji rysunkowej i zestawieniowej. Prace 
zakończono przedstawieniem programu Tekla BIMSight jako uniwersalnego 
środowiska do przeglądania międzybranżowych modeli i wykrywania między 
nimi kolizji. 
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1. Introduction 
BIM – Building Information Modeling is a modeling information about 

buildings and structures using the digital data. The basis of the method is the use 
of computer software to produce three–dimensional building model divided to 
components, e.g. walls, ceilings, columns, beams, foundations [Azhar (2011), 
Eastman et al. (2011), Garber (2014), Kensek and Noble (2014), Krygiel and 
Bradley (2008), Volk et al. (2014)]. In the initial stages of project execution a 
parametric model is created, which contains materials, geometrical elements, 
their location in the model and interconnection, relationships and dependencies. 
The whole model is saved in the form of files that at any time can be edited 
using computer software in order to make any changes, acceptance of other 
solutions or total changes of initially adopted schemas. 

From a historical perspective, BIM is a new concept and its origins are dated 
to the early 80s of the 20th century. It relates to the appearance of computers 
capable to support design and parametric modeling. Today BIM is one of the 
fastest growing methodology for working on building projects. Method is not 
completely based on a new solutions, but the way in which known procedures 
for development of construction projects are used, is innovative. 
The degree of progress of the work associated with the building’s model 
preparation, at the very beginning determines the perception of BIM not as a 
distinct methodology, but the total process consisting of multiple methods. It 
should be noted that this process is characterized by a significant degree of 
variability. It is based solely on using computer software and so–called the 
parametric modeling, which is a fundamental BIM feature – distinctive from 
other design concepts. 

The main goal of BIM is total elimination of serial or independent 
development of specific parts of the construction project for the participants of 
the implementation, erection and operation of the building i.e. investor, designer, 
contractor, manufacturer of building materials, manager, supervisor, users, 
conservator, etc. The execution of such projects is the traditional approach (Fig. 
1.1), which carries the risk of multiple errors caused by a separate preparation of 
specific parts of the overall design by individuals. The main cause of these errors 
is most commonly a lack of adequate communication between the participants of 
the process. Example: if two designers engaged in separate calculations that 
contain separate material solutions, in the absence of communication between 
them and the arrangements for specific solutions of design details, two separate 
parts of the project are get, which interconnection becomes the responsibility of 
the contractor. The situation becomes more precarious, when the designer or 
contractor changes one or more aspects of his part of the project without 
consulting with the other members of the whole team. 
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Fig. 1.1. The traditional scheme of construction project development 
(own elaboration) 

 
The drawback are copies of a draft often reproduced, containing amendments 

and corrections – the more files and documents the easier it is to make mistake 
resulting simply from information overload, which mostly are not properly 
ordered. It is a very big obstacle in the case of large, complex structures, where 
the number of individual items and details is significant and requires very good 
organization of work between all participants of the construction process. If the 
need for cooperation of professionals from various sectors (construction, 
electricity, sanitation) will be added, who are involved in the formation of both 
the project and the object itself, further conflicts arising from the need to agree 
on a common optimal version of the project can be also expected. The result are 
the implementing errors, which presence is considered only after completion of 
the investment. Their repair or removal carries a cost, which although is not 
foreseen in the initial estimate, and can significantly increase the cost of the 
whole construction. Consequently, the natural course of things is the search for 
effective methods to eliminate all arising problems in this way. 

BIM is a revolutionary solution in this regard and significantly different from 
the traditional way of the development of construction projects. The primary 
difference, which can be seen even without being an experienced user is a way 
of developing building documentation [Geodert and Meadati (2008)]. The 
starting point is the preparation of a virtual 3D model of the building (Fig. 1.2), 
which will be concerned with the way the overall investment process. Working 
in the virtual space of BIM means that the focus is not only on the preparation of 
drawings and details, as it is in the case of computer–based assistance programs 
from CAD’s family [Suchorab and Łagód (2013), Suchorab et al. (2010)]. There 
much more options and functions are available, the purpose of which is to have 
full control over the entire investment process. 
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Fig. 1.2. BIM scheme of the building performance 
 (own elaboration) 

. 
BIM software developers (in the case of BIM there is only the work on the 

computer, it is eliminated the need to create a paper–based documentation, 
although it is possible to obtain such one) realized from the very beginning of 
the existence of a huge amount of data on the work as well as the necessity of 
their mutual correlations and the creation of a suitable, relatively easy–to–use 
management schema. Having prepared a 3D model, in accordance with the 
ideology of BIM, there is ability to control everything that is connected with the 
creation of the object, in fact, from the moment of bringing the first lines to the 
moment of transfer of the object into operation, and even, indirectly, at the time 
of its use. The focus is not, therefore, only on the drawing, but on selection of 
the appropriate elements, connections, geometry, details, deployment 
components, their interactions and dependencies, the selection of materials in 
terms of physico–mechanical properties, implementation schedules, inventories, 
and by providing relevant data on the development of estimates, schedule of 
work, the supply of materials to the construction site, the selection of suppliers 
and contractors. This makes it possible to effectively control the entire 
investment process associated with the creation of a building or object. This 
makes it possible to effectively control the entire investment process associated 
with the creation of a building or object. BIM family programs are characterized 
by an extremely complex structure through which it is possible to control 
literally every, even the smallest element of the building. In this connection, it 
would seem that their operation is complicated and requires a pure knowledge, 
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however, this is a misconception. Ability to use BIM applications does not 
release, of course, of having a wide range of knowledge and experience in the 
construction industry, however, the creators of the software itself are largely 
focused on how the easiest–to–use these tools to reach out to a wide range of 
potential recipients. 

The most important feature of BIM is the complete elimination of the 
traditional model of development in which, as mentioned above, each participant 
of the construction process has to complete a separate job. In BIM the basic 
building’s model is used to work for all – both investor, designers and 
contractors in any industry, suppliers of materials and services, manufacturers of 
prefabricated elements, developers of schedules and estimates. Because all 
entered changes by a lot of people take place using one model, it is not necessary 
to mutual transmission of data in order to their reconciliation or consultation –
introduced changes can be immediately traced by all contributors of the project. 
BIM family programs have the advantage that working on the project may lead 
all at the same time. This is particularly important in the case of the need for the 
development of cross–industry projects –a model common to all convenient, 
because it gives great freedom in the case of making changes or selecting new 
materials, construction, technology, etc. A significant advantage is the fact of 
AutoSave of all changes, e.g. single column or detail on all the other drawings 
included in the project. The same concerns, e.g. tables of steel elements – if an 
additional beam is introduced, this component is automatically taken into 
account in statements’ update. In this respect, the BIM is characterized by the 
accuracy of the data, the fast process of their record and correlate, integrity with 
many areas of the construction industry, ranging from design through 
implementation and operation of the building. 

Another important feature of the BIM is the ability to parameterize and 
optimize all processes associated with the erection of the building. It should be 
noted that parameterization and optimization concerns each model’s element, 
relations and cooperation of elements, objects in the design, load transfer, 
determination the effective cross–sections of elements, materials efficiency, their 
order for construction site, preparation and delivery of prefabricated, deadlines 
for individual stages of the design, construction stages and later building’s 
usage. Consequently, the period in which stages of "building life cycle" are 
planned, it is extended to the operation stage. This is a factor that increasingly is 
already taken into account at the design stage, with a very large impact on the 
sustainability and rational land use. This is of particular importance in the 
context of the reduction of the costs of investment, which allows for the 
multivariate consideration of the issue, while working on the one model by all 
participants of the process it is eliminated the possibility of the emergence of 
regulatory errors resulting from the absence of an adequate level of 
communication between them. An example of an object developed in 
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accordance with the BIM’s principles is Aviva Stadium in Dublin, Ireland 
(Fig. 1.3). 
 

 
 

Fig. 1.3. Aviva Stadium in Dublin, Ireland 
 [www.avivastadium.ie] 

 
Today BIM wins a very large popularity, but it is justified by all of the 

alternatives and options that these programs offer. Wide audience of software 
appreciate above all very high functionality and performance of the software. 
The most common use of these programs is still the traditional approach 
focusing on generating drawings and schedules, however, due to the progress of 
this trend the use of BIM in each process will be pushed. Of course, it should be 
noted that the multifunctionality of the BIM’s applications can cause the 
possibility of difficulties arise in their use, especially for novice users. This is a 
problem concerning many computer programs, not just belonging to the BIM’s 
family, resulting from the practical impossibility of preservation multi–tasking 
and ease of use. Therefore, in order to properly navigate into the "BIM’s 
environment" it is necessary to a thorough knowledge of both theory 
(foundations and assumptions of the methodology), as well as the ability to use 
the application and use of shared capabilities by it. To facilitate the handling and 
access to software functions is also an element of optimization. Because the 
possibility of BIM are still being discovered and implemented in the 
construction industry, should be assumed, that this will be one of the fastest 
growing branch in the construction industry. 

What are the opportunities for further development of BIM? The target 
situation, which seek the authors, creators and users of BIM’s family programs 
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is total elimination of design documentation in the traditional form, the 
development of projects in the way that it is possible to completely control the 
investment and operation of object [Azhar (2011)]. An important aspect is also 
the optimization in the use of the computer as the primary working tool. The 
BIM’s applications are so developed that retained a large number of available 
possibilities, its operation does not require substantial costs associated with the 
processing power of computers. To this end, it will be necessary to use the 
Internet as a tool to contact between the creators of the project, material 
suppliers, to optimize schedules and estimates on the basis of precise and 
comprehensive databases. The works are also carried out to support the files and 
settings from other applications by BIM software, which will be a high level of 
management of all data concerning the building. 
 

2. BIM – Building Information Modeling 

2.1. Parametric modeling – methodology and opportunities 
The BIM’s methodology is based on different terms than the commonly 

known CAD (Computer Aided Designing) systems. Creating a database object 
on the basis of generated 3D model is not on describing directly the geometry 
and properties of the building and its composition. The entire process of 
formation of the documentation is based on the definition of the object using the 
parameters and principles of mutual interactions of the components that make up 
the whole. All parameters can be predefined in the program, entered manually 
from scratch, extensively amended, modified, extended with external directories 
data, combined with other previously produced models or taken from other 
programs. It is possible to create predefined templates that parameterization is 
then adjusted to the needs of the project. Very large selection of options opens 
the way for designers to develop complex connections, often unusual in terms of 
the geometry and shapes.  

To properly move in BIM environment the structure of applications that 
support design should be carefully read. Keep in mind that BIM is based on 
computer modeling, which largely determines the capabilities of all links in the 
object model. The primary means are the tools through which the user is able to 
edit the properties of each parameter, make changes, and give importance by 
interacting with others, predefined elements. The tools also allow for defining 
new model’s elements by all users in an interactive way with the previously 
entered parameters of the model. The parent unit is the platform, which is a 
powerful group of tools to create and manage group projects (models), in which 
the parameterization is done using the appropriate commands. Each platform 
provide the access to all parameters and object’s database with the option of 
changing them, and support for files saved in various formats. 
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As already mentioned, the BIM programs are based on three–dimensional 
building model manufactured in the virtual space. This does not mean, that you 
cannot use, for example 2D detail – by appropriate modification of such 
elements they can be transformed to 3D objects, which often are used in 
programs in the field of architecture. The BIM’s applications are somewhat 
derived from the previously developed solutions in the field of computer design, 
the next step in the development of these methods. Their creators are based both 
on the previous achievements in this field, as well as on new ideas resulting not 
only from the experience of graphic designers and computer scientists but also 
people related mainly to the construction industry and architecture. All these 
activities perfectly fit in the general trend of minimizing of object’s 
implementation time, mainly by reducing the design stage, eliminating the need 
for errors repair arising during the design and implementation phase. However, 
to edit the same model and its parameterization, you should be familiar with 
basic principles of its creation. 

2.1.1.  The objects in the virtual space of BIM 
Introduction of computers in the second half of the twentieth century with a 

suitable computing power allowed to conduct the research with a range of 3D 
image editing. Initially, the most advanced works in this direction were leading 
by game developers and digital graphics, would then be used in other areas of 
the economy. The primary issue that was the subject of the study was to create 
three–dimensional shapes and their interconnection. As a result of the work, two 
basic methods of obtaining a fully 3–dimensional images were created. First of 
them it is so–called B–rep (boundary representation approach). Picture/model in 
this method consists of a closed, oriented in space blocks representing simple 
shapes, e.g.: cube, cone, sphere, of a specified size (Fig. 1.4). It is also possible 
to obtain more complex shapes by e.g.: rotation around axis, draw along the line. 
From simple shapes more complicated shapes are obtained by operations, which 
involve pulling on, multiplications, cutting, connecting or disconnecting of 
elements. Finally a full three–dimensional model of the object is obtained. The 
second method is called CSG (Constructive Solid Geometry). Three–
dimensional image obtained by combining basic solids using the commands 
based on algorithms saved as algebra, also using boolean operations. Unlike the 
B–rep method editing the properties of a particular item is not directly, but using 
appropriate commands entered at the command prompt. Currently, BIM’s 
programs use a combination of these methods – editing properties and 
parameters of the components is done using CSG procedures, however, 
visualization, creating a model, its check for irregularities and other non–
editable properties is done by operations carried out on the premises of the B–
rep [Eastman et al. (2011)]. 
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Having developed ways to receive shapes, the next problem appears, namely 
the connection made, e.g. of different materials, where each of them is treated as 
a separate entity. To this end, the concept of "feature" was introduced, which 
describes the connection point as a property of the root element, the parameters 
can be changed by editing the properties pane. This is one of the most important 
achievements of the BIM in terms of the possibility of parameterization more 
sensitive places such as contacts of the two materials. Currently programs treat 
such connections as so–called components (e.g. Tekla Structures) that can be 
edited as a ready–made templates or created manually and added to the library. 
 

 
 

Fig. 2.1. Examples of basic 3D solids and boolean operations effects 
 (own elaboration) 

 
Work on a 3D BIM’s model essentially differs from the known from CAD’s 

applications, which is covering mainly the operations performed on a flat views 
(some CAD’s applications introduces the possibility of drawing and editing 
solids and 3D models, but for a much different terms than in BIM). Despite 
some convergence on used functions in applications, resulting also from the two 
methods of solid editing mentioned above, support for 3D model is much more 
developed. As already mentioned, the BIM’s methodology is based on many 
assumptions including the experiences and practices from other methodologies 
based on vector graphics. In this respect, the BIM is the next stage in the 
development of computer graphics. 

In the virtual space building’s model should have a limited frame of 
reference. To this end, the mesh is used, so that each element is oriented in 
space. The grid can interbreed, penetrate and connect. It represent reference 
systems, assist in the location of individual objects, as well as in the CAD’s 
family programs. The user has the ability to change the mesh density; it is also 
possible to enter circular grids, with a corresponding angle. Their points of 
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contacts are subject to the parameterization, because they are connections of 
building’s elements at the same time, for instance beam and column in the 
design of the framework. Changing the position of a point, the potential change 
of the shape of the elements, which are drawn on two levels should be also 
included. Programs running in BIM’s environment are parametrizing both the 
objects shape and optimum connections, e.g. bolts, rivets, pins. An important 
advantage in this case is the ability to edit the properties of multiple parameters 
at the same time and their application in relation to the entire object. In this case, 
the principle of reciprocity take effect – the global characteristics of the object 
are transferred to the local properties of the elements. Changing the parameters 
of the constituent elements there is an impact on the final shape and appearance 
of a building’s 3D model, in accordance with the rules of interaction. Thanks to 
the possibility of obtaining any shape, e.g. partition and large room to maneuver 
when it comes to controlling the object’s geometry, the picture is get almost 
identical with its subsequent appearance in reality. 

In the process of developing a building’s 3D model using BIM’s family 
software, ready–made solutions as regards the shape, dimensions and materials 
of which they are made can be used – the most commonly used are ready 
database, that user can extend to his own solutions. There is also an option for 
manual modelling elements, in which there is a high accuracy in the matter of 
the location of openings, chamfer angles, reinforcement of concrete elements, 
and use of custom components. 

Mesh modeling system usually depends on the object’s geometry, the angles 
between the compartments, as well as a repeatability of the section, e.g. in the 
case of industrial halls. Connection, as already mentioned, can be taken as 
ready–made, standard solutions which is subjected to the database then it is 
parameterized or can be taken as own handmade schemas, which 
parametrization rules are identical to those ready–made components. 

In the process of creating a model, in addition to knowledge of tools and 
parameterization features, classes of individual elements, the properties of the 
virtual space, in which a designer is working cannot be forgotten. The space, 
which occupies the building, is limited by the walls (vertical surfaces), ceilings 
(horizontal surfaces), roofs (mostly sloping surfaces, inclined to horizontal 
plane) and the intersections of these elements. In older applications the default 
virtual space had to be manually defined and expanded when the building’s 
dimensions were increasing. Currently, most programs have the ability to 
automatically adapt the size of the operational space in accordance to the size of 
the object. 

Automation of many functions, including track changes and rapid adaptation 
to the characteristics of the model is the main feature of the BIM’s software, 
which development makes modeling quick and easy. To achieve this state of 
affairs is possible thanks to total computerization and digitization of all the 
features contained in the programs. 
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2.1.2. 3D object modeling – elements, classes, general rules 
Modeling 3D objects in BIM’s programs e.g.Autodesk Revit® Architecture 

and Structure, Graphisoft ArchiCAD®, Gehry Technology’s Digital Project™, 
Nematschek Vectorworks, Tekla Structures, SDS/2, or Structureworks [Eastman 
et a.(2011)], its origins owes of development of applications to support design, 
mainly from the scope of the mechanics and Finite Element Methods. Starting 
with the creation of model usually a hierarchy of elements is assumed, from 
which it will be made. This hierarchy includes all planned objects. Typically 
used gradation is to start from drawing of the biggest elements, primarily 
structural, i.e. floors, walls, columns, beams and balconies. Their mutual 
arrangement and setting in the model to the greatest extent affects the final 
geometry of the building. The next step is to draw elements of lesser importance 
for the bearing capacity of the whole structure–non–structural elements (walls, 
chimneys, railings, stairs) patios, finishing elements (façade elements, interior 
finishing). In the architectural programs also the often available option is placing 
elements of landscape architecture, i.e. trees, monuments, stones, rails; 
equipment of the rooms, e.g. furniture, sanitary appliances, suspended ceilings, 
plants. Also an interesting option e.g. in Revit is the ability to installation routing 
with drawing all the essential elements of a network, e.g. ventilation, air 
conditioning or waterworks. Together with drawing elements it is possible to 
their exact parameterizing. One way to classify items is their division into 
classes, which will be discussed later in the monograph. However, parametric 
design differs from the classical design approaches of selected items. Each 
newly drawn element, within the preliminary determination of its location in the 
virtual space (obtained for example by using meshes) at the outset must has a 
defined membership of a particular group, family or class. Matter in which the 
element is classified depends on its type, for example whether it is a pillar, a 
beam, a plate; from what material is made, what parameters of geometric 
features it has such as length, thickness, height, angle and its location in the 
virtual space, relative to the rest of the objects in the form of commands (if the 
item is to be moved, inclined to horizontal plane, rotated relative to the axis). 
Despite the large number of parameters to be determined for each item the 
process of defining them is simple, because for this purpose the properties pane 
are used, e.g. in Tekla Structures drawing is to give an approximate location of 
the item, while all the details about it are selected by automatic editing of its 
parameters. The geometry of the elements is parametrized in the first place – 
section dimensions, shapes and profiles, thickness and width; the length and 
height of elements are bound to adopt the reference system at the beginning. 
Making changes in the geometry properties pane is relied on entry the values – 
based on it, special algorithms move saved changes automatically to the model’s 
view in the virtual space. In this way, the user has the possibility of continuous 
monitoring of changes. Subsequently, the material data are parametrized.  



19 

This option is particularly useful if you need to define a new material, which is 
not saved in the program. The BIM’s programs allow for the introduction of a 
very large number of material data i.e. modules of elasticity, Poisson’s 
coefficients, strength and physical parameters. After the choice of materials, the 
next very important from the point of view of the further work of the structure, 
stage of the parameterization is an appropriate choice of connection type 
between elements, especially between construction elements. In Tekla 
Structures, you can shape it by hand or use a ready–made components base, 
which means sets of connections, reinforcement, armaments, strengthen or 
certain additional elements like stairs and ladders. Components consisting of 
many individual items are subject to the same parameterization conditions– the 
primary way is to change the numeric values relating to the geometry of the 
component, bolts spacing, types of welds, the diameter of the rods, etc. This 
policy distinguishes BIM’s programs by application with 3D CAD’s family, 
where all the parameters, especially geometric must be defined manually. A 
large number of options make it easy to specify mutual elements interaction 
without the use of complex procedures. More advanced partitions as the walls or 
ceilings can be parameterized by giving them thickness, taking into account the 
presence of extra layers i.e. as insulation, facades; the arrangement of openings 
and window joints, gaps, joints in corners, contacts with ceilings, roofs, landing 
plates. There is also the possibility to drawn up the straight or curved wall. Must 
be noted that individual items and baffles are parameterized, regardless of 
combined elements and changes a single element with defined connection with 
others, through its tracking mechanism causes changes in adjacent elements. 

As already mentioned, to the object modeling and editing its properties 
suitable tools can be used. Their nature and function largely depends on the 
nature of the proposed construction, installation system, the estimated 
implementation technology. Designers usually assume a specific set of tools 
with which they are able to develop a specific model. BIM’s applications are 
based on the architectural style of objects drawing, which in contrast to 
simplified schemas of mechanical programs allows to obtain the exact visual and 
parametric model. There are several methods of parametrization depending on 
used tools [Eastman et al. (2011)]:  
 the basic method consists of describing elements’ shapes using several fixed 

parameters; the definition of the whole layout is achieved by a gradual 
change in the parameters of the individual components of the model,  

 more developed method is automatic change of the parameters of a single 
element, taking into account changes in other elements at the same time, 
which are adjacent to it (in this case, the amendments also leads to changes in 
the parameters of the connection between them), 

 the most advanced procedure of parameterization is creating of relationship’s 
network between elements on the basis of e.g. their shape or material–this 
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method automatically takes into account the creation of an element in a 
variety of ways; extensive network facilitates the automatic management of 
model using a specific set of tools. 
Currently, programs and applications from BIM’s family work on the basis of 

the extensive library containing classes and groups of elements. The criteria for 
their establishment and distribution are very different – the type of element, the 
material, the role in construction (carrier element, connector, finishing element, 
decorative). The physico–mechanical characteristics of materials are also 
classified i.e. specific weight, density, humidity, durability and loads which may 
occur in the construction (continuous, focused). All libraries are also divided 
with regard to industry, which deals with the person working on the project. The 
user has the option to extend these directories for new items by creating them 
from scratch or from existing and predefined solutions. An additional advantage 
is libraries’ compatibility between different programs, in accordance with the 
concept of BIM the object’s model should be editable using a variety of 
applications. This is particularly important in the case of the development of one 
project by more than one subcontractor where each company is using another 
program.  

By highlighting a class any other criterion may be taken into account, which 
is using tools in BIM’s applications. The first, most important class includes all 
these elements, which parameters influence critically at look and work of the 
object. To this class belong all load–bearing elements, along with their 
connections. Changes in their parameters significantly affect the properties of 
the object model. 

The second class are complementary elements of fundamental elements i.e. 
doors, windows, room equipment, finishing items. They are most commonly 
available in libraries, they have default parameters and properties. The third 
class includes those elements whose presence is dictated by the specific system’s 
solutions, special types of partitioning, installation. The type of these items often 
depends on the industry, for which a model is being developed. Of course it is 
not stiff division and any user can propose different classifications depending on 
individual needs. 
 

2.1.3. BIM’s application tools 
It is already know what BIM gives in the field of construction projects’ 

development. As a tool it is understand the application’ task or a group of tasks, 
through which the model is generated and all the changes are managed. The 
result of the tools are separate results, for instance virtual model or drawings, or 
data that can be processed by other applications. In standard software tools can 
be divided into several groups, due to their function and role in the 
parameterization of building components, namely [Garber (2014)]: 
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 The first group are the tools that every computer user should know perfectly 
from other programs, which means project management functions as a file. In 
addition to the standard ability to create new projects, open, save, or create a 
hyperlink, project can be also exported, saved in the appropriate formats to 
other applications, e.g., for the stress calculation; there is also the ability to 
import similar files in order to their further "treatment" in the application 
which at the moment is used. This is one of the most important features for 
the possibility of use of files from CAD’s family. 

 The second group are the tools used to operate in the virtual space and the 
management of it – create meshes and auxiliary systems, extending (manual 
or automatic) the space to be occupied by a model, move, rotate the view, 
changing the object’s view at different levels – both the default used by the 
program as well as user-defined, zoom in and zoom out of the image. 

 The third group are the tools for direct operations on the created elements i.e. 
draw, arrange, move, rotate, copy, extending and shortening, boolean 
operations, connecting elements, cutting, chamfering and rounding corners, 
expanding; drawing items is based on their immediate deployment in virtual 
spaces, taking into account the material and shape of what may be.  

 The fourth group are the tools to support the management of the created 
elements, selecting specific items or their parts (e.g. end-, central points), 
surfaces, planes, lines, all elements and their groups, components, details; in 
this case, very helpful is the use of the filters through which appropriate 
criteria for selection may be defined; to this group can also be included 
ancillary tools, e.g. to check the distance and angles of inclination. 

 The fifth group are the tools to edit the connection properties, so–called 
components; they are based on predefined solutions, e.g. the connection of 
the column and bolt, which the designer can then parameterize according to 
specific situation; as mentioned earlier these directories can be expanded by 
own templates and suggested solutions; with that tools it is possible to edit 
and change the properties of a rivet, screw and welded connections, 
reinforcement of concrete, parameterization of elements made of various 
materials; the other option is to manual crate connections, by arranging 
pieces of connectors along with a selection of their properties – this is 
particularly important when it is necessary to design custom solutions, it is 
also used in prefabrication – individual approach to the project problem gives 
the ability to optimize the connections while maintaining a balance between 
durability, cost and functionality of the solution. 

 The sixth group are the special tools that support designing of the model to 
use in other programs, e.g. creating loadings, FEM meshes, as well as for 
checking the model for the occurrence of irregularities and conflicts between 
elements [Zhang et al. (2013)], estimating the cost of the building (after the 
introduction of the materials databases and their prices), prefabricates 
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optimization; to this group also must be included tools which support data 
saved in other formats than the default BIM format. 

 The seventh group are the powerful tools to perform, edit, change and for 
final preparation of drawings; the basic tools of this kind are used to select a 
building or part of it, which designer wants to put and describe in the 
drawings, it is possible to decide on the accuracy scale of the drawing, lines 
templates, information about the items (depending on requirements); each 
program gives you the ability to determine the type of a drawing (general, 
construction, sketch, cross section, detail of a single item or group); the most 
important feature of BIM’s application is a smart tracking of changes on the 
drawings – where changes are made in the model, it is no need to perform 
drawings from beginning, because all changes are automatically applied to 
the drawings, the changes are also included in the report, such as listings of 
bolts, rebar quantity, the type of welds; the use of these tools also allows to 
combine multiple drawings, complementing the information industry. Fig. 
2.2 shows the main platform of Tekla Structures with selected groups of 
tools. 

 

 
 

Fig. 2.2. Tekla Structures tools 
 (own elaboration on the basis of the Tekla Structures software) 

 
Looking at the information shown above, it seems to be that operation of 

BIM’s software is difficult and requires many hours of training and 
implementation of models [Sacks and Barak (2010)].However, this is not true, 
because the main goal of the BIM’s methodology is to simplify the procedures 
of executing the project in such way as to retain the maximum accuracy when it 
comes to the content placed in the projects. This is the main policy that defines 
the way in which the individual applications have been and are still being 
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developed. Design based on object’s properties parameterization is much easier 
than executing similar projects in CAD’s programs. However, BIM’s software 
developers during the creation of the methodology’s basics had to repeatedly 
refer to the CAD’s technology, because in it for the first time 2D and 3D 
modeling was used. BIM’s applications are the extensions of originally 
developed methods with an indication of the considerable improvement of their 
activities and mutual correlation. There are programs that are a combination of 
these two methodologies – based on the CAD’s principles in terms of the work 
on objects with built–in network’s functions in the form of "trees"; however, 
they are not included in the programs in its entirety based on the procedures of 
BIM. 

For the novice user each BIM’s program can be complicated. Problems 
handling can be even greater, if you do not know the basic assumptions of the 
methodology. A very common problem is the use of many features – each 
structure, in addition to the classic ones, repeating design schemes in several 
projects have special items that require an individual approach. In such cases, 
the problem may be the use of selected options in applications. It is no secret 
that the correct understanding of the software requires training and courses – 
self–learning of BIM’s programs is possible, but time– and labor–intensive. 

2.1.4. BIM’s environment 
What is the execution of the model using the BIM methodology? When 

opening a BIM’s program, e.g. Tekla Structures [Tekla manual (2012)] access to 
the platform working in the so–called BIM environment is obtained. The term 
"environment" in this case must be understood as an organized collection of 
tools and platforms for the proper management of the model and related 
databases, and presentation of the information contained therein. It is important 
that the environment in which the user moves was well developed and advanced 
in terms of all of the available features. This gives the ability to obtain the best 
result with a building mapping at the stage of development of the model. The 
accuracy of this is an extremely important aspect, which is the important issue 
both in programs for modeling as well as to perform strength calculations. The 
platform is equipped with a number of tools listed in the previous chapter. What 
tools the designer will use depends on the type of building, which will be 
modeled and the individual user’s preferences. A characteristic feature of the 
applications, in many cases is the ability to get the some effect, e.g. placing steel 
beams on the roof of the hall in several different ways, using different 
commands. Experienced designers have their own defined sets of commands and 
orders that help them working and move around the environment. 

When opening a new model no revolution is made. All the steps that will be 
performed in the course of work on the project are the result of a properly used 
knowledge. Even the best design program is useless, if designer do not have the 
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relevant experience and expertise for e.g. the type of the structure. This is 
especially true for steel and reinforced concrete structures, which are the most 
common among newly built buildings and for which the prevailing theory is the 
most comprehensive. The designer has to be prepared for the emergence of new 
solutions, but development of BIM’s software take into account these changes, 
which is reflected in virtual materials’ databases, profiles, precast, etc. 

The first step which should be taken is the space in which the model will be 
placed. Knowing the general dimensions of the building designer is able to 
determine the size of the mesh base. Supporting grids that may occur in the later 
stages of the project will be placed in the virtual space while retaining the 
reference to the basic coordinate system – offset or slope. Usually the default 
“xy” axis system is assumed as a basic grid, and the “z” axis is used to determine 
the height, e.g. a column. 

Having defined the grids layout, which can be several depending on 
requirements, the designer can proceed to deploy within the basic elements, such 
as the columns, beams, slabs – most often these will be as structural elements. In 
this case a few rules are applied, which will greatly help in further manipulate of 
the model, e.g. placing columns at the points of intersection of the grids. At this 
point the main difference between the parametric design and other forms of 
design appears. The object – e.g. beam – in the virtual space requires the 
definition of the material from which it is made, the cross section and the basic 
dimension – in this case the length. All these data mean the behavior of the 
element in the virtual space [Eastman et al. (2011); Ghang et al. (2006)]. It is 
introduced at the stage of drawing the element, as it is in the case of CAD’s 
systems, but by using the edit pane. An example of the properties pane, from the 
Tekla Structures is shown in (Fig. 2.3). The behavior of the elements and objects 
is also a part of the whole BIM’s environment. The parameters are introduced in 
a number of ways – by accepting material and cross section, which is based 
mostly on databases, geometric dimensions are defined by using the typed 
numbers; the following parameters are specified on a select or deselect, (that is, 
the determination of their presence or absence). In Tekla Structures also appears 
the edit window of the element’s location, e.g. displacement or rotation in the 
terms of the center point adopted by program. At the time of drawing, the 
programs immediately accept the default partition elements into classes, which 
are included graphically by their different colors. Edited can be both single and 
group of items with the same target properties in the model. 
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Fig. 2.3. Properties window of steel element in the Tekla Structures 
(own elaboration on the basis of the Tekla Structures software) 

 
Parameterization of connections is performed on the same basis. From the 

database a specific solution that is predefined is selected (e.g. has a default value 
of the screws’ deployment), the items that user want to connect are selected and 
then in the properties pane of the component, the layout of its components so as 
to obtain the required effect can be freely changed. When manual designing the 
parameterization is more detailed, but give the possibility of greater field to 
maneuver when determining the dimensions and ways of connection. All 
manually entered data by the user can be saved and used in future projects. 
Similarly, in case of other components of the object’s model – all operations can 
be carried out either manually or automatically. The properties window in many 
cases is very detailed, which gives the designer great leeway. Each change is 
quickly and automatically entered in the model’s space. Very important in this 
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case is the changes track feature – described previously the default tool that 
translates all the changes of the parameters to change in the behavior of the 
individual elements. In the case of complex 3D models it is a very valuable and 
necessary function. 

Unfortunately, despite the significant degree of sophistication and accuracy 
of BIM’s application, not all objects can be currently inscribed on the basis of 
the databases. The development of materials’ engineering and buildings’ 
technologies necessitates the use of new solutions, the use of which is justified 
for the sake of usability, durability, aesthetics or costs. In the case of new 
materials the method is simple, because it boils down to the definition of the 
parameters from the scratch and adds them to an already existing libraries (the 
more physico–mechanical parameters are known then better). This way of 
defining new materials is the same as for endurance calculation software (Robot, 
Algor). The second option is to broaden the existing libraries with new, external 
directories, e.g. downloaded from the manufacturer. 

Slightly different is situation when new technological solutions, e.g. 
windows, façade cladding, welded profiles or custom shapes profiles are defined 
[Eastman et al. (2011)]. In this case, it is possible to add new product’s catalogs, 
but more often the user faces the need to draw the elements using the tools of the 
2, 3, 4, 5 group. Useful are also tools of the sixth group for validation of made 
items and their connections with elements existing earlier in the program. How 
to define a new solution depends on its difficulty degree and execution 
capabilities in the program. There are several ways to enter a new item to the 
model. One option is to define a new object by using another application, e.g. 
BIM or CAD and import element to be incorporated in the model. In the case of 
objects which are prepared by using the CAD’s application it must be specified 
as closed polygons, drawn by 2D or 3D polyline. After the introduction of this 
element to the target BIM’s application it is subjected to further parameterization 
using existing tools in it. The second way is most commonly used and it is 
manual creation of new solutions through transformations of elements already 
existing in the program. The advantage of this method is that the properties of 
the resulting object will be compatible with the object’s model, because a new 
shape is created using a previously known parameters. The third option is the 
introduction a new class of elements, along with their parameters, which do not 
come from other, already existing object’s classes. The new class should has the 
ability to update its properties through the introduction of new data to the 
program. However, the last way is to extend the parameters and properties of 
existing elements by broadcasting them to new, previously not used function 
(that is, the new object’s behavior). 

If the new object is derived from an external application, the problem may be 
its integration with elements already built into the model. BIM’s applications are 
compatible with most traditional design programs, however, e.g. in the case of 
object’s import derived from CAD’s applications an item without any 
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parameters is received. Giving the role and significance to the new element in 
the design is a task for the user – the more parameters will be able to enter, the 
greater the chance that it will be incorporated into existing directories as a new 
BIM’s element. The most sensitive places are the connections of existing 
elements with the new ones – they have many parameters to optimize and they 
decide about the final shape and durability of the structure. This is particularly 
applicable in the case of prefabricated elements, which by the strictly defined 
dimensions can be immediately introduced into the model, without the need of 
changes. 

Connect with each other elements’ classes has its application in cross–
industry models. In the case where each participant is preparing his part of the 
model using various applications, their mutual compatibility is extremely 
important and in accordance with the BIM’s methodology it must be ensured. 
This effect is obtained by the parametric modeling – that tools can be used for 
different needs and applications. The parameter can refer to a few of the items 
that designer want to connect, which translates to a very wide range of 
possibilities in the field of design. 

2.1.5. The management of model’s parameters 
Each element of the model has specific parameters and properties. The ability 

to manage them properly is the main task of the BIM’s user. The number and 
type of parameters that an item has strictly depends on its function in the object. 
The basis for the adoption of these properties are the mutual relationships and 
interactions between the different elements. On the basis of own knowledge and 
the features available in the BIM’s application the designer is able to find 
optimal solutions to meet the required conditions of stability, strength, or 
serviceability of the structure. Each introduced element or change affects 
tentatively to adopted relationships. The easiest way to observe this process is by 
the example of geometry changes e.g. the supporting beam and its connection 
with the column. The geometry changes tracking tool is based on the topology of 
the system, and selection of the type of connection between 2 components 
determines the type of relationship between them (welded, bolted, riveted etc.). 
If model of the building is considered as a whole composed of individual parts, 
theirs relationships and characteristics can be determined. 

However, the designer should be aware that in the case of high–tech facilities 
the number of parameters, which must be managed is very large, as a result, 
some patterns and methods of their organization should be developed. 

One of the ways to manage those elements is their grouping. This is nothing 
more than adopting certain criteria for properties’ classification, to share items 
on the components and their parts or on the contrary, merge into larger 
components, bearing in mind the relationship (the elements assemblies). Thanks 
to that it is possible, e.g. to edit the properties of one assembly and apply 



28 

changes to the other assemblies as they occur in the model.  
Grouping can be subjected to all the model’s components, from the elements and 
their parts (and acting loads on it) to connections. User can choose grouping 
criteria by defining suitable filters as well as take the default criteria. In the 
independent criteria selection, a designer need to have knowledge of what 
elements and how they can be combined, what are the properties of the 
relationship, and what are the consequences of changes. They will also depend 
on the environment in which the model will be developed: individual industries 
e.g. architectural, construction or installation – each of them require to pay 
special attention to the separate model’s parts, which form a whole in the form 
of the final project. 

The basic properties of the elements, resulting from their geometry and the 
material of which they are made are only a part of the broad parameters of what 
the designer has to define in order to use the model in other applications, e.g. to 
calculate strength, making estimates, schedules. A way to group properties and 
the relationship is to take into account the "life cycle" of the building through a 
breakdown of the stages – design, implementation, and operation. In each of 
these stages, the team members, who are working on the model (divided by 
industries) may pay attention to other aspects of parameters and relationships, 
such as statics, mechanics, thermals, electronics installations. 

When choosing the properties user does not use their individually – usually 
they occur in some groups that define the general behavior of the elements. 
Therefore, BIM’s applications have properties’ library which the simplest 
examples are material’s catalogues. The use of libraries, supports properties’ 
management, because it allows to a complete changes. As already mentioned, 
libraries can be expanded by setting up their items from scratch or by attaching 
the external directories, e.g. from manufacturers, tables, summaries prepared by 
using other applications (Excel). Introduction of new data to libraries enables to 
obtain comprehensive databases and adequate preparation the BIM’s 
environment on the used platform. Developed databases would greatly 
contribute to the maximum simplification of the management of the 3D model’s 
properties. 

Users working on BIM’s applications continuously improve methods of 
organization and management of the objects’ properties. In large part this is due 
to the need for the maximum simplification of the process of creating a 
building’s project. Not without significance it is the skillful use of computers as 
tools to improve the work and to ensure the correct flow of data between all 
participants of the project. The problem of large databases can be lack of their 
compatibility between users, which results from the usage e.g. various units, 
however, experienced designers always carefully examine available databases in 
this manner. 
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2.1.6. Drawings 
The drawings are an integral part of any construction project which is a 

graphical representation of all information that is contained in the BIM’s model. 
Even the best parametrized design turns out to be useless without properly 
developed drawing documentation (on paper or electronically). Feature of 
drawings is the ease in reading information from them. In this connection, it is 
important that all the images contained therein, dimension lines and descriptions 
have been carefully formatted. BIM’s applications allow to develop a very 
accurate drawings, as well as the accompanying descriptions and summaries. 
Each program comes with a number of tools, so that the preparation of the 
drawing documentation is much easier. Characteristic is the fact that all 
drawings are generated after appropriate preparation of the 3D model. Any of 
the implemented changes are automatically reflected by tracing the changes and 
saved on a regular basis to the previously prepared sketches, plans, details, etc. 
In this way, it eliminates the possibility of errors during manual modifications’ 
application, which is one of the main problems of CAD’s systems, especially in 
the case of 2D drawings. 

Each program has a specific algorithm, according to which the drawing 
documentation is produced on the basis of the model. Tools that are used to 
generate drawings have defined formatting rules according to contained in them 
information i.e. thickness and types of lines, scales, annotations, descriptions, 
dimensions, reference lines. This is particularly applicable in cross–industry 
projects, e.g. the type of line, depending on the industry, can provide several 
types of elements. BIM application’s tools usually apply their own, unified set of 
lines and descriptions, so that it is possible to correct presentation of all elements 
listed in the drawing. 

What information will be placed in the drawing is determined in several 
ways. The primary criterion is the kind of drawing, and which model’s element 
is supposed to represent. The properties of the elements i.e. the name, type, 
material, geometric data, defined at the stage of modeling are placed on the 
drawings automatically. The user can execute a drawing by using the templates 
included in the program, and then supplement it for additional information by 
selecting the appropriate item in the drawing’s properties. It is possible to add 
dimensions, resize the drawings, add descriptions and additional information, 
previously undefined in the model. In the case of general drawings, after 
applying the proper program’s tools, a designer obtain summary tables of the 
data relating to the number and type of each element (useful when creating 
estimates). In a similar way sections of elements and design details are created. 
The number of available templates of drawings depend on the program, user can 
also make own compilation of the drawing’s documentation. Important is also 
the option to hide and show individual elements e.g. to exclude elements of the 
façade where the subject of the drawing is reinforcement of concrete walls. 
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The drawings are generated on the basis of a combination of elements 
modeled in 2D and 3D. Depending on the degree of sophistication, there are 
several levels of drawings formation: 
 The easiest way to create a drawing rely on excision of the specific section of 

the 3D model and manually defining of its parameters i.e. dimensions and 
descriptions; entered information is then passed on to all identical sections in 
the model; the drawing is the type of a report generated from a model that 
can be subjected to further processing with the use of other applications. 

 The second way is to use the predefined templates, in which a user provides 
information regarding e.g. the formatting of the line or how to describe 
elements; this method accelerates the process of generating drawings, 
however, has some disadvantages – changes to drawings are not transferred 
to the changes into the model, they must be placed in the object’s view on the 
basis of its manual regeneration. 

 The most advanced way, which is to generate drawings based on the 
templates that can be modified by the user; important are also bidirectional 
actions – all changes in the model are automatically saved and placed on the 
drawings with showing to the user the list of them, and vice versa – changes 
declared in the drawings are automatically applied in the model on the same 
principle; this is the fastest way and it allows to create any type and number 
of drawings. 
Similarly, the designer can create a drawing of any element of the building. 
Methodology for preparation of drawings used in BIM leads slowly to 

abandon standard “paper” approaches of the design documentation. Combining 
2D and 3D section gives the opportunity to make full use of the drawings for the 
preparation of estimates and schedules, which prevents the use of 2D templates 
only. However, tools for the preparation of the drawings are still being 
developed and the main direction of their development is the total automation of 
the process. 
 

2.1.7. Scalability 
The scalability of the model in the virtual BIM’s space is the ability of the 

program to build the model, its deployment and optimization, while working on 
the object does not cause a slowdown of work, e.g. the computer hardware. Such 
problems may arise in the case of complex models’ object with significant 
geometrical dimensions or having a large number of elements, where all of them 
are defined separately. In the virtual model of the current principle is to preserve 
the relationship between the properties and characteristics, e.g. other elements. It 
is also important to preserve detailed information about the elements, especially 
for large models. Relationships depend on the scale and complexity of the 
connections, the accuracy of the defined object. Their increasing number is 
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associated with the need to control and manage them through the use of various 
tools. All the operations carried out on the objects occupy specific amount of the 
computer's memory, which is limited. As a consequence, it appears that the size 
of the project must also be limited by hardware’s capabilities. The solution to 
this problem is to introduce the possibility of propagation of design changes 
contained in a single file in other files. One of the solutions, “memory–based” 
systems use a virtual memory to store superfluous data; their disadvantage is the 
possibility of slowing down of hardware. However, in the “file–based” systems 
the principle of their work involve the simultaneous launching of the band files 
and performing multiple operations on it at the same time. These systems are 
characterized by relatively slow time working for small projects, which increases 
with progress of the object. 

Described problems will fade with the development of computers and 
increase the speed of their work, however, the ability of the system to scale will 
be the main issue on a number of projects, especially high–tech objects. It is 
important in this case, the use of new formats of files that can significantly 
reduce their size and therefore the memory requirements. 

2.1.8. Database management 
When using BIM it is possible to create a virtual model of any building 

object. A restriction is not in this case knowledge and imagination, but 
computing power and capabilities of the hardware on which it runs. Described in 
section 2.2.7. methods for scalability are not the only ways to simplify work on 
complex models that require significant disk’s capacity and memory’s resources 
of the computer. In the case of projects of significant size, it is necessary to 
divide them into smaller files. The problem is also the change management, 
mainly based on their manual implementation and generating the model. It is 
essential that all changes were properly correlated with the model as well as with 
external applications based on the model, e.g. in the field of performance of 
estimates, schedules. An attention to the flow of data between the various 
participants of the project should also be payed – sending via the Internet whole 
models can be cumbersome due to the limited possibilities of the link. One way 
to solve this problem on BIM is so–called incremental update, which means 
upload and import only those items and objects belonging to the model that have 
been changed and updated into the model with new parameters. The size of the 
transmitted data is reduced, but it need to pay attention to control the model and 
changes introduced by users. 

Parameters of the model can be changed using external software. Their 
simple use change the parameters and control the geometric layout of the model, 
which are entered to the worksheet. Each dimension is defined by a different 
variable, it is possible to save the relationship and dependencies between the 
geometric dimensions using formulas. The data in spreadsheets are then 
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correlated with the BIM’s application operation. Thanks to that the number of 
necessary to carry out operations in the model completely falls, since 
parameterization of object geometry represents the majority of the total number 
of operations. The spreadsheets are also used as external data storage, e.g., 
catalogues of materials or profiles. In this way, it is not necessary to add new 
libraries to the default statements; new data are retrieved from the sheets. 
A development of this method is the direct linking of BIM’s applications with 
external directories using the links, e.g. with the manufacturers of specific 
solutions and systems. External data management through support for files that 
are saved in different formats is one of the direction of the further development 
of the many BIM’s programs, it is also an integral part of the BIM’s software 
training, which, despite the systematic growth, continues to be a small [Sacks 
and Barak (2010)]. 

2.2. The data exchange between applications – interoperability 
Design and construction of buildings as teamwork often is assisted by 

computer software. Interoperability is the ability to transfer data between 
applications to contribute for the success of the performed project. This 
eliminates the need to manual copying the data that has been created in another 
application and creates new possibilities in automation. There are several ways 
for the exchange of information [Eastman et al. (2011)]. 

The most practical form of exchange is this between the BIM’s platform and 
set of tools that this platform can handle (e.g. analytical tools, such as the design, 
thermal analysis, and a tool for scheduling). In this exchange there are defined 
the necessary data on the platform (so–called model’s view) and placed in the 
required format by the receiving tool, then it is possible to supplement these data 
with other information in the tool. The results obtained using BIM’s platform 
inform user of platform from which data has been sent, that the original model 
can be updated. Sometimes this exchange can be complicated. Extract from the 
model’s element such as rod and node in order to carry out structural analysis or 
definition of the loads is not yet fully automated, because there is required 
human knowledge and assessment of the problem. Similarly, energy analysis, 
which can be performed only on the model adopted to this, but it is not possible 
to use for this purpose a structural model that would be more convenient for 
designers. 

A simpler way is the exchange between tools (tool–to–tool). This solution is 
limited by data that are available only in the sending tool. One example is the 
translation of data "quantity takeoff” (QTO) to costing, where QTO gets the data 
collected in the BIM for costing, purchase and tracking of materials, by 
associating those data with schedule. In such an exchange, the geometric 
browser (geometric viewer) can be used as a tool for BIM, e.g. Autodesk Design 
Review (using the DWF format) or Adobe’s 3D viewer (using PDF format). 
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These tools use own structures for viewing, which can be used in other tools in 
certain purposes, e.g. collision detection. It is essential that such browsers cannot 
make changes in the project and cannot update the model in the platform – the 
information flow is one–way. 

The exchange between platforms (platform–to–platform) are the main 
challenge of interoperability. This applies to design platforms such as Revit, 
ArchiCad and materials modeling platform such as Tekla, SDS/2 Structureworks 
and StruCad. The platform, in addition to the rich data resource has clarified the 
rules for managing the integrity of objects designed by the architectural firm of 
rich experience. It is easy to share a model of the building with another 
application, however, the transfer of an editable version of the model would 
require the transfer of special standards embedded in spreadsheets (according to 
which model has been created), to the receiving platform. For example, the 
installation of the wall in some BIM’s platforms relies on performing certain 
acts referred to specific rules, which in another platform are not defined. In such 
cases, the exchange platform–to–platform is not possible. However, the 
exchange of objects with a constant shape as well as some simple profiles is not 
a problem. 

The increase of interoperability can occur through the manager, which allows 
to multiple projects application in different platforms and tools. In addition to 
the translation, e.g. architectural model of building to another format you need to 
modify or broaden the information about this model so that it will be suitable for 
other uses. Translation of physical construction’s model of a building to the 
analysis model requires knowledge about tools, e.g. knowledge of standards, 
details – depth of beams in support, the behavior of nodes or loading conditions. 
The model generally represents the behavior of the structure, connections, 
external load and the requirements of the standards in order to solve the load 
layout. Some of the detailed parts of the structure, due to their geometry or the 
load complexity may be presented in the form of a 3D FEM mesh. 

It is important that changes are made into one model, and consistency with 
other models require verification and update if necessary. Unfortunately most of 
these updates are done manually, which is time consuming. 
Interoperability refers to imitate of the specific information model, which was 
defined for one application, so as to create a logical, consistent information in 
another application. Then change of the meaning of the data is not needed, and 
manual translation according to the requested requirements is not necessary. 

Until the mid–1980s, almost all data exchange in all areas of the design and 
engineering was carried out on different file formats – e.g., DXF, IGES. They 
ensure effective exchange of formats for 2D and 3D geometry [Eastman et al. 
(2011)]. 

If data exchange concerns complex models, along with their geometry, 
attributes and relationships, any permanent file formats quickly became too 
complex, causing difficulties in their interpretation. New approaches and 
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technologies to cope with advanced data exchanges were developed. One of the 
main products of ISO–STEP was the EXPRESS language, which has become 
the central mechanism to support modeling of products in a wide range of 
industries. It also includes a rich library of features, geometry, classification, 
measurements. It supports both the metric and the British system. All ISO–STEP 
information are public. 
 
ISO–STEP in building construction 

Up to now, the following product models related to buildings have been 
developed, all based on the ISO–STEP technology and defined in the EXPRESS 
language [Kensek and Noble (2014)]: 
 AP 225 – Building Elements Using Explicit Shape Representation: the only 

completed building–oriented product data model developed and approved. It 
deals with the exchange of building geometry. AP 225 is used in Europe, 
mostly in Germany, as an alternative to DXF. Only a few CAD applications 
support it. 

 IFC – Industry Foundation Classes: an industry–developed product data 
model for the design and full lifecycle of buildings, supported by building 
SMART. It has broad support by most software companies; it is weakened by 
varied no consistent implementations. 

 CIS/2 – CimSteel Integration Standard, Version 2: is an industry developed 
standard for structural steel design, analysis, and fabrication, supported by 
the American Institute of Steel Construction and the Construction Steel 
Institute in the United Kingdom. CIS/2 is widely used and deployed in the 
North American structural steel engineering and fabrication industry. 

 AP 241 – Generic Model for Life Cycle Support of AEC Facilities: addresses 
industrial facilities, and overlaps with IFC functionality; proposed in 2006 by 
the German National Committee; and is under review as a new AP. The 
Korean building SMART chapter is also involved. The purpose of AP 241 is 
to develop a product data model for factories and their components in a fully 
ISO–STEP–compatible format. 

 ISO 15926 – A STEP standard for industrial automation systems and 
integration: integration of life–cycle data for process plants including oil and 
gas production facilities. It addresses the whole lifecycle, from planning and 
design to maintenance and operation. Because a process plant is continuously 
maintained, objects are naturally 4D. 
There are multiple building product data models with overlapping 

functionality, all using the EXPRESS language. They vary in the AEC 
information they represent and their intended use, but with overlaps. IFC can 
represent building geometry, as can AP 225 and ISO 15926. There is overlap 
between CIS/2 and IFC in the design of structural steel. 
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ISO 15926 overlaps IFC in the piping and mechanical equipment areas. 
These largely separate efforts will need to be harmonized. Harmonization efforts 
are being discussed between 15926 with IFC, especially in the mechanical 
equipment area, but no steps have been undertaken. 
 
Data exchange between applications 

It can be done in three different ways: 
 Direct links – it uses the Application Programming Interface (API) of one 

system to extract data from that application and write the data using the 
receiving application’s API. Some may write a temporary file in the 
exchange between two independent applications, others may rely on real–
time exchanges calling one application from the other. 

 A proprietary exchange format – it is a file or streaming interface developed 
by a commercial organization for interfacing with that company’s 
application. The specification for the schema may be published or 
confidential. A well–known proprietary exchange format in the AEC area is 
DXF defined by Autodesk. Other proprietary exchange formats include SAT, 
STL for stereo–lithography, and 3DS for 3D–StudioEach of these has their 
own purpose, dealing with different kinds of geometry. 

 The public product data model exchange formats – It involves using an open 
and publicly managed schema and language, such as XML or text file. Some 
product models support both XML and text file exchange. 

 
Common Exchange Formats in AEC Applications 

The most often used formats in AEC Applications are the following: 
 Image (Raster) Formats: JPG, GIF, TIF, BMP, PNG, RAW, RLE. Raster 

formats vary in terms of compactness, number of possible colors per pixel, 
transparency, compression with or without data loss. 

 2D Vector Formats: DXF, DWG, AI, CGM, EMF, IGS, WMF, DGN, PDF, 
ODF, SVG, SWF. Vector formats vary regarding compactness, line 
formatting, color, layering and types of curves supported; some are file–
based and others use XML. 

 3D Surface and Shape Formats: 3DS, WRL, STL, IGS, SAT, DXF, DWG, 
OBJ, DGN, U3D PDF (3D), PTS, DWF. 3D surface and shape formats vary 
according to the types of surfaces and edges represented, whether they 
represent surfaces and/or solids, material properties of the shape (color, 
image bitmap, and texture map), or viewpoint information. Some have both 
ASCII and binary encodings. Some include lighting, camera, and other 
viewing controls; some are file formats and others XML. 

 3D Object Exchange Formats:  STP, EXP, CIS/2, IFC. Product data model 
formats represent geometry according to the 2D or 3D types represented; 
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they also carry object type data and relevant properties and relations between 
objects. They are the richest in information content. 

 3D Object Exchange Formats:  AecXML, Obix, AEX, bcXML, AGCxml. 
XML schemas developed for the exchange of building data; they vary 
according to the information exchanged and the workflows supported. 

 3D Object Exchange Formats: V3D, X, U, GOF, FACT, COLLADA. A wide 
variety of game file formats vary according to the types of surfaces, whether 
they carry hierarchical structure, types of material properties, texture and 
bump map parameters, animation, and skinning. 

 3D Object Exchange Formats: SHP, SHX, DBF, TIGER, JSON, GML. 
Geographical information system formats vary in terms of 2D or 3D, data 
links supported, file formats and XML. 

 
Examples of cooperation between BIM applications 

Tekla interoperability Autodesk Revit products: 
Revit and Tekla Users can coordinate their building information models to 

gain greater insight and certainty. As a Tekla user can work and communicate 
with Revit users effectively by providing them specifically compatible IFC files. 
The main features are the following: 
 fail–safe model import, 
 maintained Revit unique ID, 
 optimized family creation. 

Tekla Extension Export to Software includes intelligent interoperability with 
Revit.  
 

Tekla Structures to Autodesk Revit: 
There are two options of collaboration between Tekla Structures and Revit. 
Option 1: Tekla Structures to Autodesk Revit for Collaboration using 

Autodesk approved IFC files to see if everything fits but for some reason are not 
using Navisworks or TeklaBIMsight (which is free) for this purpose. The 
procedure is as follows: 
 Export from Tekla Structures to Revit using an IFC file (Autodesk fully 

support IFC import and export since Revit 2013): 
1. (Tekla>Export>IFC) from Tekla Structures, 
2. Simply Import into Revit. From Revit 2015 and above, you can Insert > 

IFC directly in the same way you insert a Link or DWG. 
 BIM can be used to coordinate the Structural file with the Architectural/MEP 

project in Revit. 
IFC is an excellent way to see if everything fits and also IFC carries much 

more information than a DGN or DWG file about profile types, phase, material 
etc. 70% of Tekla models are LOD400 and above. Revit can only handle up to 
LOD 300. 
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General collaboration is best done on a neutral platform built for that purpose 
e.g. Autodesk Navisworks or Tekla BIMsight which is dedicated collaboration 
software with clash checking and reporting. 
 

Option 2: Tekla Structures geometry re–used in Revit drawings/schedules – 
beware of LOD300 limitations of Revit.  

Autodesk Revit to Tekla Structures for drawing/schedule creation in Revit 
using plug in links (Tekla creates a TCZIP file which Revit reads). If you wish 
to re–use of structural information in the architects/MEP Engineers drawings, 
then use the Tekla Structures Extension + Autodesk Revit Add–In. The Tekla 
Structures users should perform the following steps:  
 Export to Software (Tekla Structures 19.1 and below) from the Tekla 

Warehouse. 
 Export to Revit for drawings (Tekla Structures 20.0 and above) from the 

Tekla Warehouse. 
Autodesk Revit Architectural / MEP users (Revit 2014 and above) should 

perform the import from Tekla Structures Add–In (free) from the Tekla website. 
Only use these TEK2REVIT application links to reuse structural geometry from 
Tekla in Autodesk Revit ARCH/MEP drawings. Set up model filter/organizer 
category in Tekla Structures, make sure that is send only what the Revit (LOD 
300 software) user actually needs (i.e. probably not rebar, bolts, washers, 
concrete embeds etc.). Procedure in Tekla Structures (LOD 400 software) is as 
follows: 
 Set up building levels and project base point in Export to Software/Revit tool. 
 Export TCZIP file. 
 If you are sending an update to an already sent file, the procedure is the same. 

Updates of parts are handled by the Revit Import from Tekla Add–In. 
Procedure in Autodesk Revit (LOD 300 software) is as follows: 

 Import TCZIP file using Import from Tekla Structures Add–In into a 
blank structural template project and save. 

 Link structural project to architectural project or MEP project. 
 Linked structural project can be updated by reimporting an updated TCZIP at 

any time into the structural project. Only changed elements will be updated. 
Revit ID's will be maintained. 

 
Benefits to the Revit user of using the Export to Revit/Import from Tekla 

Structures are only for those who wish to reuse structural geometry. Examples 
are given below: 
 The Autodesk Revit Unique ID on objects is retained between subsequent 

updates. Information in the Revit project therefore is not lost but is updated 
as new structural information is imported. This is good for drawing 
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production e.g. drawing overrides such as hatching/line work are maintained 
between structural updates. 

 Autodesk Revit dimensions, Revit materials and Revit notation attached to 
structural parts therefore are not lost between updates, but are retained and 
adjusted (e.g. dimensions change) as the structure changes. 

 Autodesk Revit Families are optimized to reduce the number which are used 
to generate the structural model. 

 Autodesk Revit levels and location concepts are supported (e.g. ground floor, 
first floor, project base point)  

 Autodesk Revit phases are supported (e.g. demolition phase, construction 
phase). 
If user want to take 3D geometry from Autodesk Revit 2014 and above into 

Tekla Structures, this is done by using the Autodesk approved IFC file format 
(an intelligent format) or a 3D DWG format (a 'dumb' format). The procedure is 
as follows: 
 Export from Revit using the existing Export to IFC command in Revit 2014 

or above. Autodesk also have a current project that improves this existing 
IFC export. 

 This geometry file can then be used in the BIM coordination process as a 
reference file by Tekla Structures. 

 Where the situation exists where the reference file has geometry that is 
actually useful to the structural team, those parts (correctly dimensioned slabs 
and columns etc.) can be converted to be native Tekla Structures parts and 
reused and updated at a later time by reimporting the IFC file as part of the 
time–saving IFC Change Management tools in Tekla Structures. 

2.3. The use of BIM in the design and execution of construction 
works 

Each of the participants in the investment process has its own objectives and 
associated risks, and benefits resulting from the use of BIM to the 
implementation of the project. The real beneficiaries of the BIM are the investor, 
designer and general contractor. They have a chance with the right tools to save 
large sums, optimize their performance and limit the damage in the realization 
process. The hardest thing is to get this knowledge to the investor and to 
convince him to engage it in the process of design, planning and implementation 
of investments, not from the controller but co–responsible participant of the 
process. The main benefits of the use of BIM’s systems in investments are 
primarily a reduction in unnecessary expenditure as a result of carrying out a 
virtual analysis of possible conflicts in the area of the structure’s geometry, 
proposed and existing installations. Besides – improvement of the efficiency of 
cooperation by speeding up the decision–making process in the area of the entire 
project and all designers, contractors and future users. Investment can be 
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improved by visualizing all processes and better planning for the construction 
site’s organization [Miecznikowski (2014)]. 

When the architect and the designer are working alone and they 
communicate, but they do not work and do not consult with the general 
contractor, then execution of investment is difficult. Cooperation would lead to 
the integration of all the functions in one process, which would greatly facilitate 
the work. The purpose of the investor is to build an object in accordance with the 
established deadline and cost. Separate hiring an architect, designer, and later the 
contractor initiates at the very beginning the risk that any of them, in carrying 
out its work, will have other purposes and its own visions, usually contradictory. 
The architect will aim to use the well–known technologies and materials, which 
may not be suitable for the proposed building, but in this way he will reduce the 
amount of effort, he will perform a project in a short period of time and increase 
own profit. However, the contractor hired by the traditional rules will care about 
his interests, using a replacement materials given in the project and not pay 
attention to the quality of work, especially those whose effects are not seen, 
because the most important will be to stick to a schedule, and not to pay interest 
for delay. 

To create a truly integrated team of architects, designers and contractors, they 
should be given common responsibility and share in the risks and cost, but 
mainly in profits of the whole enterprise. It is significant that in the most 
important stage of planning and the concept development, and features of 
investment’s targets were all participants of the project. This gives the 
opportunity to use a unique knowledge of all members, and thus optimize the 
execution process – brainstorm may result in creation of best practices. All 
participants of the project should be in proportion to bear the costs of BIM’s 
implementation, because they receive benefits – the purpose and intention of an 
investor is understand, they gaining resources needed to achieve higher quality 
and profitability, and thus they carry out the investment of greater value for the 
investor, the process is more efficient, unnecessary expenses are reduced, higher 
quality results in a cheaper operation and lower expenditure on renovation, and 
repair throughout the life cycle of building [AGC of America (2010)]. 

Fig. 2.4 shows the differences in approach to the planning, design and 
implementation of investments in the process of traditional and integrated. In the 
process based on cooperation of all project’s participants are engaged in an 
activity before, but traditional approach results in piling up problems before the 
moment of implementation start as well as the duration of the construction work 
on the basic state. This can be prevented by applying the principles of integrated 
process based on the BIM’s techniques. The most important differences between 
this two approaches are a mutual understanding of the project’s objective, the 
intention of the investor and the transfer of that to all participants. Thanks to the 
cooperation of the process’s participants, knowledge sharing, defining of 
common goal, understanding can be achieved easily and quickly. 
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Fig. 2.4. The differences between the traditional and the integrated process of design 

planning and implementation of investment 
[Miecznikowski (2014)]. 

 
 

Fig. 2.5 shows an example of the investment cycle – from invitation to tender 
after finishing of investment. The cooperation between participants of the 
investment process was showed and indicated were the benefits of the 
implementation of the BIM’s system into that cycle (added values). 

After receiving the tender’s materials designers draw up a 3D object’s model 
that combines architecture and structure. Having the architectural and structural 
documentation automatically is checked their mutual compatibility and captured 
are contradictions or omissions – in the model is very easily to notice the 
shortcomings of a component parameters’ definition, and this information 
appears automatically. The model can be built by many people using multiuser 
mode, which accelerates the work. In this way user can see what has been 
inserted by anyone, so there is no danger that some element will be skipped or 
missed, if this happens user will be informed. Full structure model allows to 
define the finishing layers, equipment, etc. in amounts perfectly corresponding 
to the surface. Also can be found out how many more plaster will be needed if 
volume of the building increase with some value. A closed model allows to 
generate reports for all quantitative investments with high accuracy. 
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Fig. 2.5. An example of the investment cycle – from a tender to end of investment 

[Orlińska–Dejer (2013)]. 
 

Based on the take–off the offer is created. It goes to the investor, who may 
have suggestions about optimization and design changes. Incorporate changes in 
the 3D model and generate reports is much easier than the conversion of the new 
quantities of traditional method and minimizes the risk of error. Then the 
contractor gets the task and selects the team responsible for the preparation of 
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the construction. Thanks to the model, it is no longer needed to check the 
dimensions, allowing to save time and focus on negotiations with 
subcontractors. On the stage of execution, model is a large source of knowledge 
e.g. is not needed to count the amount of built–in materials, generation a 
corresponding report for a given item is enough – these amounts are the same as 
the recoveries amounts of invoices from subcontractors and suppliers. Thanks to 
retain the vast majority of errors, collisions and confusion of the documentation 
at the stage of building the model, contractor can protect himself from 
discovering them on construction site. Interesting is also working with 
subcontractors. An example: wooden construction documentation was 
transferred to the contractors in the form of a 3D model, and then supplemented 
by the necessary workshop’s information (details) and directed to the 
production. This greatly speeds up the work and the possibility of checking the 
solutions proposed by the contractors on the 3D model, which allows to avoid 
subsequent complications. Also worth mentioning is that the development of the 
workshop’s documentation using an existing model transfers to the order’s 
savings of 10 to 20% of the time and money, assuming that it gets a company 
responsible for coordinating the model. 

During construction minor problems and misunderstandings may occur, but 
such problems BIM is not able to solve. The most important thing, that as a 
general, there are no compatibility issues with schedule and also in excess of the 
planned budget. After finishing of project the model can be transferred to the 
investor and thanks to the free tools (BIM Vision, Tekla BIMSight etc.) may 
serve as a source of knowledge, while manage the investment or management of 
energy in the building is continued. 

2.3.1. BIM for investors 
Investors are the people who initiate and finance the building’s project. They 

take strategic decisions in the process of the object’s implementation by the 
selection of service and processes providers, which they use. An informed 
investor is interested in not only beneficial agreement or to negotiate a low price 
for the design and completion of the construction project, but above all is 
interested in high quality of investment, while keeping market prices. This is 
what the BIM provides [Miecznikowski (2014)]. 

Investors may get a lot of benefit in projects using the tools and processes of 
BIM e.g. streamline of implementation by providing buildings of higher quality. 
BIM facilitates cooperation between the participants of the project, allows to 
avoid or reduce errors, it leads to a more efficient and reliable process of 
execution, which reduces the time and cost. Investors can use the BIM 
techniques to [Eastman et al. (2011)]: 
 improve the properties of the building thanks to the analysis, e.g. energy–

based model of BIM, 
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 reduce the financial risks connected with the project by getting the estimated 
costs and better team collaboration, and to identify possible errors – to avoid 
a situation in which only on the construction site errors will be revealed, 

 shortening the project schedule from approval to implementation in order to 
ensure better coordination and using prefabrication projects, which requires 
less working time, 

 obtain reliable and accurate estimates by the automatic determination of the 
number and types of works taken from the building’s model, providing 
feedback to the project, when important decisions are taken, 

 ensure compliance and topicality of the project by the current analysis of the 
building’s model in accordance with local standards, 

 optimization of facility management and maintenance by exporting relevant 
post–completion information (about building and equipment), in order to 
introduce systems that will be used throughout the life cycle of the object. 
Created, upgraded, post–completed model can be used as a database, which 
informs about the site. People who are managing a building in a remote way 
are able to schedule any maintenance works or renovations, and can analyze 
the state of the building in the context of the existing model. 
BIM’s tools widely increase opportunities for CAD design regarding links 

design data with business processes, such as sales forecasts and actions. These 
tools support the cooperation which builds trust and common goals, as opposed 
to the competitive relationships, where each team member is trying to maximize 
its individual goals. 

In contrast to the processes based on drawing operations, the analysis must be 
made regardless of information about construction project, often requiring a 
duplicate, and besides, these are laborious due to data input. A lot of mistakes 
can be made, as well as increase of effort by creating accurate information about 
project. Using BIM an investor can potentially get a bigger return from 
investment as a result of the implementation of the integrated design process. 

BIM has proven to be crucial for teams using IPD solutions (Fig. 2.6) – the 
new integrated implementation project, aimed at the formation of a close 
cooperation between members of the project team. Instead many contracts, one 
is contained, which binds the key participants of the investment. In the contract 
information exchange’s protocols are contained and shared both risks and 
benefits for each unit. The investor's role in initiating and sustaining such a 
project is crucial. In IPD each team member has its own assigned tools, by the 
BIM’s server information are updated, which were entered by each of the 
members, creating a project as a whole. In the IPD, the investor plays an active 
role throughout the period of project implementation, by participating in the 
decision–making process at all levels. BIM tools are important for investors to 
understand the intentions of the designers and contractors who make up the team 
of IPD. 
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Fig. 2.6. IPD model, contractor and investor involved a single contract 

(own elaboration) 
 

The company, which represents investors point out that investors often act 
rashly and reckless, by making frequent design changes, resulting in cost 
increases, changes in the schedule and ultimately badly affects the quality of the 
project.BIM can solve these problems, what is the benefit to the investor. BIM’s 
applications can create competitive advantage and enable businesses to better 
respond to market needs and investor could get a better return on capital 
investment. If the service provider keeps implementation of the BIM – they are 
looking for their own competitive advantages, and the investor after hearing can 
make better use of the knowledge of the design team. 
 
Examples of BIM tools intended for investors 

Tools for estimate 
Investors estimate to determine the level of the project’s cost and execution 

of the contract or different analyses. Often these estimates are made at the 
beginning of the project, only when the team creates a detailed model. The most 
commonly used estimate software is MS Excel. In 2007, software for estimating 
for investors, the US Cost provided to its customers functional draw up of 
a large amount of information from the building model created in Autodesk 
Revit. Another software targeted to investors is Exactal's CostX®, which 
imports buildings’ models and allows users to perform automatic or manual 
estimate. 
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Tools for objects and assets managing 
Most existing tools to manage an object consist of both information from 2D 

model to describe the space as well as on the numeric data entered in the 
spreadsheet. Usually management of objects and assets does not require 
information from the 3D model, but 3D models based on the components may 
be an additional value in the object’s management. Models of buildings bring 
significant benefits in the initial phase of the implementation of the object 
information and interactions between these information. Thanks to BIM’s 
technicians, investors can use the "space" of elements that make up the 3D 
space, which significantly shortens the time needed to create an object database, 
because the traditional method involves manually creating space, after the 
project will be complete. 

Currently, there are a few tools that use the spatial elements of BIM and other 
object’s elements representing the permanent assets. The following are examples 
of tools currently available: 
 ActiveFacility (www.activefacility.com), 
 ArchiFM (www.graphisoft.co.uk/products/archifm), 
 ONUMA Planning System™ (www.onuma.com), 
 Vizelia suite of FACILITY management products (www.vizelia.com). 

The use of BIM to facility management support is at the stage of diagnosis 
and tools are recently available on the market. Investors should work with 
management organizations to determine whether the current management tools 
can handle BIM data or whether is required the transition to management tools 
based on the BIM techniques. 
 

Operation Simulation tools 
These include tools for crowd behavior simulation, such as Legion Studio, 

ViCrowd eRena and Crowd Behavior. Many of them are provided by companies 
that also offer services to perform simulation and add the necessary information. 
In all cases, tools require additional information input in order to perform 
simulation; and, in some cases they are able to extract only the geometric 
properties of the building information model. 

Most common simulation tools does not require specialized simulation, but 
using the visualization in real time or tools that use building information as 
input. 

Investors do not have to be conversant only in the type of BIM tools available 
to them, also they should understand the scope and level of detail that is needed 
in the building model for own project. To take advantage of BIM applications, 
investors must work closely with service providers in order to ensure that the 
building’s model provides the appropriate scope, level of detail and information 
in accordance with its intended purpose. Often, each service provider determines 
the scope and level of detail required for their work. Investor can impose the 
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scope and degree of detail required for use after the implementation of the 
model. For example, at the stage of feasibility study, spaces are sufficient for 
most BIM uses for conceptual design. If the owner requires a larger integration 
of BIM application, both the level of integration in the model and the level of 
detail are increased in order to produce the model. 

2.3.2. BIM for designers 
The design is a team activity. Exchange of information determines the quality 

of the communication. In the process of exchange of information, there are three 
basic stages. They are: recording, transfer, read (interpretation). Standard of 
information recording should be accepted by all members of the project team 
(drawing, indications, which shall be governed by the law, the digital format). 
Tools shall specify the type of transfer (paper, digital file, data). It is 
distinguished by its method and the time it takes for the transfer. Read and 
adaptation of information also depends on recording techniques. 
Selection of the design method is the architects’ decision. Currently, there are a 
lot of opportunities from traditional ink sketches that start the project after the 
advanced design techniques. BIM in this context serves as a neutral platform for 
storage and exchange of information. The source of data for all elements of the 
building, which can be processed according to the needs and specific conditions 
[Bujak (2011)]. 

The most important industries collaborating on the design documentation that 
is architecture, design, installation, by using the BIM’s model may effectively 
exchange design information, using the coordination tools. Coordination of 
documentation prevents the effect of inconsistent and most importantly 
incorrectly made project. The advantage of BIM – integration of building 
information gives architects, designers the ability to make the right design 
decisions based on the results of the analysis and simulation of the properties of 
building components (e.g. thermals, construction). 

BIM’s technology significantly reduces the time required for the preparation 
of construction documents, by automatization of detailed work, which also 
ensures compliance with the deadlines for the implementation of the design 
works. Software meeting the standards of BIM e.g. Autodesk Revit, 
automatically identifies and eliminates obvious errors – e.g. part of the wall 
inside the window. Of course, for the knowledge and consent of the user. In the 
event of such an error, the program prompts the user for the correctness of the 
adopted solution. Thanks to that the designer has a complete and permanent 
control of the proposed building. 

In the BIM’s application an user does not need to focus on the drawings as in 
traditional techniques. The designer can focus entirely on designing, analyzing 
the correctness of the adopted solutions, at their variants whether the 
optimization of the whole project, instead of thinking of how many and what 
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drawings must perform. Technical documentation in the form of prints, e.g. is 
made for the approval of the office, is a derivative of the model created by 
designers. All the projections, cross sections, views, elevations and all kinds of 
listings are derived directly from the BIM’s model of proposed object 
[Mackiewicz (2014)]. 
 

 
Fig. 2.7. The relationship between the work and the time required for the execution of the 

project in the traditional and integrated process 
[Eastman et al. (2011)] 

 
Fig. 2.7 presents a diagram that shows the general relationship between the 

effort of the designer and time needed to complete the project. Line no. 3 
indicates the distribution of effort on traditional design and line no. 4 is the 
same, but in the case of BIM. Line no. 2 shows the increase of costs, which are 
the result of changes throughout the duration of the project, while line no. 1 – 
influence on cost and functionality. The diagram shows how important are the 
decisions taken earlier by the design team, in terms of overall performance, costs 
and benefits of a construction project. In BIM seeks to take important decisions 
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already at the stage of conception rather than at the stage of documentation 
creating. Integrated design process significantly reduces the time that is required 
to draw up the construction documentation. 

In the design stage, stands out 3 kinds of projects in terms of development 
level. Their role and the design process are different. The following are the 
characteristics of such projects. 

Conceptual design – it determines the basic parts of the project to be 
developed at a later stage, in terms of structure, spatial layout, environmental 
and local conditions and also it serves the basic functional and economic 
assessment of cost–effectiveness. This is the most creative part of the project 
activities. It includes all aspects of the project, in terms of its features, costs, 
construction methods and materials, the impact on the environment, 
construction, cultural and aesthetic practices. Architects sometimes have a stake 
in developing building’s program but more often they are involved in the initial 
phase, where the program requires elaboration. After the program development, 
the skeleton of a conceptual design of the basic building’s layout is generated – 
floor plan, the general appearance, orientation, position and it is determined how 
the project will implement a basic construction program. 

Some architects argue that BIM does not fully supports the conceptual 
design, due to its complexity and need for cognitive operations. Most BIM 
design’s applications requires too much practice to move seamlessly in the 
software, program’s operations depend on the different situations. Work is 
limited due to the interface – in contrast to the paper and pencil that in this 
respect there is no limits. 

The main BIM’s tools to drafting this concept are SketchUp®, Rhinoceros 
and Bonzai3D. They focused on a fast 3d sketching and generation of various 
forms. Those applications facilitate communication in terms of spatial and visual 
in the design team. These programs do not operate the building’s types and do 
not retain object’s type, so the geometry actions are applied to all shapes, which 
is less complicated for the user. Some of them limits their surfaces for irregular 
shapes, which may be a very wide range of surfaces, including flat and spherical. 
Reasonable complexity is a trump of the proposed object and quick information 
for intuitive visual assessment. 

Other software tools to support the creation of a conceptual design are 
focused on a particular theme, such as spatial programming or energy 
consumption, financial opportunities. The company supplying the BIM’s 
platforms are also aware of the perceived limitations of their tools and bring 
opportunities to create a conceptual design that can compete with the drawing 
tools in this area of the market. 

BIM for design and analysis of construction systems – analysis can rely on 
measuring the volatility of physical parameters, which can be expected in the 
real building. The analysis includes e.g. temperature control, ventilation, 
lighting, pedestrian traffic, acoustics, distribution and consumption of energy, 
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water supply and sewage. Simulation and evaluation shall be carried out by 
specialists from the design team, using precise analysis’ models. Essential here it 
is the cooperation of people of different professions, based on analytical 
software, suitable for the given field. Cooperation shall cover activity from the 
final design concepts for modeling at the level of the structure. As far as the 
progress of the project, in the last stages of conceptual design, systems require a 
detailed specification. Mechanical systems require extensions and construction 
systems must be designed. These tasks are usually undertaken in cooperation 
with specialists of engineering. In contrast to the tasks at the stage of concept in 
this stage tasks are specific, complex, and usually supported by experts of the 
technical areas. These are mainly tools, not platforms. 

The development of information on the level of construction – the main 
product manufactured by means of the used tools is the construction 
documentation. Software for modeling of buildings at the level of construction 
has features that can speed up the generation of documentation, which also 
improves project’s the quality. In the future, a model of the building will serve 
as a legal basis for documentation. This process involves the integration of the 
project with the construction, which facilitates the rapid and efficient 
construction directly after the execution of the project or in parallel with it. 

Designers can participate in this stage in 3 ways [Eastman et al. (2011)]: 
 Building’s model is precise project with the intentions of both the designer 

and the client. Here it is expected that the contractor shall draw up its own 
independent design model (with technology) and documentation from 
scratch. This solution is most used by architects and designers because it is 
safe for them – is associated with the elimination of liability for construction 
issues because that information are not provided to construction site and only 
serve the project’s objectives. This is evident in the drawings, in which it is 
written that the responsibility for validation is transferred to the contractor. 
So technically, the contractor must enter his systems from the basics to 
deliver on responsibilities, taking into account the intentions of the designer. 

 The model of the building is considered to be partly detailed and will be 
further developed in detail so that it can be applied in all areas of building 
construction, planning and production. 

 The design team can work with contractors and producers since the 
beginning of the investment – they are informed about production issues, 
how to model in this angle. The way provides the emergence of a model that 
includes expertise (materials, technologies), together with the design 
assumptions – a comprehensive development is created. 
Both the second and the third way, are providing information about the 

model to the designers and producers, which allows them to develop the 
information needed to design, but also to maintain accepted design assumptions 
of the project. 
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BIM is also important for the industry designers, e.g. installation. Engineer 
may encounter an obstacle in the form of beams when designing ventilation. 
Installation designer gets the model, to use it to assess how in unobstructed way 
carry out the wires in a place where there is a beam. If his decision will change 
an element, through the exchange of information constructor becomes aware of 
it, and updated model inform him about new elements of installation and if 
existing beam must be adjusted. Information associated with the beam grows, 
e.g. data about the size of the hangers from the bottom welded to the beam to 
hang wires [Doliński (2013)]. 
 
The realization of major projects – failure analysis  

The overrun costs and deadlines is a characteristic feature of large projects 
and tasks that make up the project. The most common causes are: inadequate 
coordination of projects, weak cooperation in project teams and conflicts related 
between clients and suppliers. The failure rate of major projects in the world is 
around 60–75%, 30–35% concerns costs and 100% for schedule overruns are not 
uncommon. On the basis of a study carried out by Independent Project Analysis 
Institute, it was found that the failure rate of major projects in the world is 60% 
in terms of the implementation of the budgetary targets and schedules 
[www.cadsoft.pl]. 

In Tab. 2.1. shows a brief analysis of the historical data from around the 
world for the implementation of large projects. 
 

Tab. 2.1. Global failure factors for the implementation of large projects 
[www.cadsoft.pl] 

 
Infrastructure projects Construction projects 

 Cost overrun/the difference: 

 10–50%. 

 Exceeding the schedule/difference: 

30–120%. 

 About 2/3 of the projects exceeded 

the budget and schedule. 

 Cost overrun/the difference:  

10–15%. For the most projects 

overrun was in the range  

of 5–20%. 

 Exceeding the schedule/difference: 

50%. For the most projects 

overrun was in the range  

of 30–120%. 

 About 2/3 of the projects exceeded 

the budget and schedule. 
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The cost of BIM 
Autodesk has conducted in recent years the BIM implementations in many 

large scale projects. Analysis of results leads to several conclusions 
[www.cadsoft.pl]: 
 in 80% of the analyzed projects a significant modification of the 

configuration of the project was needed, which cost approximately $19,000 
for a project, 

 100% of the projects, which have not been amended misconfigured models 
brought about $24,000 costs on further stages of implementation (on average 
in the five–member design team), 

 a lot of design options is unavoidable; in a large infrastructure project 
$90,000 of savings were achieved in the production phase, while in the large 
project related to health $30,000 was saved as a result of the implementation 
of the ten design options. These savings would be nullified by the lost 
productivity, if the best BIM modeling standards has not been adopted. 

2.3.3. BIM for contractors 
General contractors are looking for investors, with which they can work 

together from the beginning of design work – only in this case, they are able to 
prepare a better deal, which meets the expectations of the customer. When the 
contractor joins at later stage of the work, there is no longer time to analyze the 
design for meeting the investor’s expectations. The biggest BIM’s beneficiaries 
in the whole process of investment are the contractor and the investor. The 
quality of the project is so important, because it translates to its value. The 
notion of an investor to better project should not be difficult for a team realizing 
the investment [Mackiewicz (2014)]. 

Larger contractors generally use computer systems that are based on their 
most important work’s systems. They support themselves by creating estimates, 
schedules, controlling costs, the implementation of the procurement and 
selection of suppliers, etc. In traditional techniques, usually at the beginning the 
contractor should perform take–off to have a basis to draw up an accurate 
costing and schedule of works – it is a time–consuming and error–prone process, 
so that these tasks are not well prepared in detail before proceeding with the 
works. Often the contractor does not participate in the design process and thus 
its comments cannot be indicated, which could be valuable in the course of the 
work, it could reduce costs without affecting the decrease in quality. 

This methodology begins to change, and developers are increasingly 
recognizing the value of BIM for teamwork and project management. Using 
BIM architects can manipulate the model in time of public procurement, thus the 
contractor can use this model for valuing, coordinating, planning, construction, 
production, procurement and other features. The contractor may use this model, 
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but also can quickly add detailed information from his site and indicate his 
suggestions on the basis of his experience. 

Building BIM’s model can provide contractors the following relevant 
information [Mackiewicz (2014)]: 
 graphic preview on different parts of the building, comparable to a typical 

construction drawing; from a model detailed information about each item can 
be received, 

 temporary items such as formwork and others, which have a significant 
impact on the planning of the works on the construction site, 

 text link to the specification for each element of the construction from the 
project that the contractor must order or execute, 

 analytical data on e.g. construction loading, nods, the maximum moments, 
thermal loads, etc., 

 tracking the progress of the implementation of the works through the visible 
status of the project and execution of each component; data are updated in the 
model by the contractor. 
Even when project’s teams work together from the beginning of the project, 

each participant can use various tools to create his building’s model. At the 
present time, with a single model, the fulfilment of all these functions is 
impossible. Completeness of the exact model is needed that includes all of the 
above information to the contractor to handle his key processes. It is important 
that when a new process by the contractor is applied, he may then enter 
information about that into the model. 

When designers do not form the BIM’s model, contractors often take it upon 
themselves. But even if they make use of architecture model they must enter 
specialized information about construction techniques that model was fully 
useful for them. As a result, many leading performers creates their own 
buildings’ models from scratch in order to have better control, collision 
detection, etc. 

Note that sometimes, the contractor is building the 3D model, which is the 
only visual representation of the project. Does not include the respectively 
defined parametric components or the relationship between them. Developers 
can also build a hybrid 3D parametric model that includes several BIM’s 
components, which allow a certain amount of coordination. When the 
performers produce a full model of the building, they can use it for many 
purposes. 

Another case is where the design team works on a 3D model, e.g., BIM or a 
hybrid environment that is practical for them. Alternatively, if anyone from the 
team works in 2D, the contractor can convert 2D to 3D/BIM, so that their work 
can be entered into the common model. Usually the contractor manages the 
integration of these different models that have been developed independently by 
various project team’s members, but then they were combined in a common 
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model. Common 3D model becomes the foundation of any construction activity 
and allows for much greater accuracy than 2D drawings. However, such an 
approach entails the risk that changes made outside of the common model will 
not be visible in this model. Therefore, all must be carefully monitored. 

Developing projects for homes, BIM can provide quick information on the 
quantity and cost of the consequences of design changes. When the buyer 
requires structural changes, they can be done in the model, to quickly reach an 
agreement between the investor and the designer. This type of rapid response to 
customer needs has a great value, especially for construction companies, which 
provide custom building options on the basis of the practice of systematic 
construction methods. 

2.3.4. BIM for manufacturers and subcontractors 
Contractors and manufacturers are performing wide range of specialized 

construction tasks. Thanks to the simulation and BIM implementation process, it 
is possible to plan and optimize the work of the subcontractors working’s teams 
and equipment used by them. Type of project allows to specify the way in which 
they can make use of BIM. Contractors are often the manufacturers of materials 
or prefabricated building’s elements, who are also employed when assembly is 
made. Construction elements can be classified as [Mackiewicz (2014)]: 
 made in a standard, e.g. plasterboards, 
 made to order, e.g. the selected window from the catalogue, but not produced 

on masse, 
 designed–to–order (ETO) elements, e.g. precast concrete products tailored to 

the individual building. 
The first two are designed for general use. Such providers are rarely involved 

in the installation or assembly on site, so they do not take part in the process of 
design and implementation. However, manufacturers of materials, often decide 
to prepare libraries of their products that are compatible with BIM, which 
increase the chances of use of their range in the implementation. They form 
overlays for the programs, e.g. Revit with all its products, allowing designers to 
automatic selection for e.g. hollow bricks in the project. After the selection they 
can immediately see it into the model. At the same time, manufacturers often 
provide a quantitative analysis of the materials used and their prices. At any 
time, a cost estimate can be generated and submit an order for the purchase of 
materials to the appropriate distribution points. The libraries, e.g. wall materials, 
often allow designers to select the optimal material – the best thickness of load–
bearing wall or facade that carried assumed loads, or comply with the relevant 
thermal requirements [www.xella.pl]. 

The other thing with the third type of materials, formed on request according 
to the project. Here, the manufacturer should work with the design team on the 
basis of BIM. The manufacturer may be a subcontractor in terms of 
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manufacture, delivery and installation of an item but also may order installation 
to another independent company. 

The ETO process consists of three main parts: the acquisition of the project 
(preliminary design and tender), detailed design (engineering and coordination) 
and execution (including supply and installation). Process includes cycles that 
allows to modify a project proposal, repeatedly if necessary. This is usually 
made at the stage of detailed project, in which the contractor is obligated to 
obtain opinions and consent of the designers of the building. 

A few problems in this process can be encountered – is time consuming, 
production requires a lot of work and documents’ update. Sets of drawings and 
other documents are inaccurate and inconsistent, which often cannot be 
interpreted until the product will be mounted on the site. Flow’s cycles of 
entered information in the computer are long. 

Using BIM process can be improved in several ways. BIM improves 
drawings process in 2D CAD –it eliminates the need to manual maintain 
consistency in many drawing’s files. BIM can greatly reduce the time and make 
the process of building a more flexible and all costs incurred will be reasonable 
and well thought out. Here are some of the advantages of BIM techniques in this 
regard [Eastman et al. (2011)]. 

Marketing and tenders – to win the project with a profit, precision and 
attention to detail is needed, the ability to develop the competence of the team in 
the event of a claim for some distinctive technical solution. Not all deals are 
effective, and companies are obliged to estimate more projects than those that 
will be carried out, by which a large part of the cost of the tender shall be 
debited to the company. BIM’s technology helps in the development of many 
alternatives, specifying a reasonable solution. Its capacity to adapt, changing 
projects and better use of engineering knowledge allows to faster development 
of the project and meet the needs of the customers. 

Reduction of production times cycle – the use of BIM cuts time to prepare 
workshop’s drawings and material’s contracts. This is done in 3 ways [Eastman 
et al. (2011)]: 
 Often design changes are necessary, even at the last minute. One change in 

the drawing can affect on change in many assembly drawings or components 
that are connected with it. When the amendment concerns the construction 
system, which has been used by many subcontractors that coordination will 
be more complicated and time consuming. From BIM’s platform workshop’s 
drawings are updated automatically, in which changes have been made, 
which is a big saving of time and effort. 

 In this way the workshop’s drawings are done in the latter, the most 
appropriate moment, when the introduction of the changes is the least likely. 
Preparing drawings is driven by production. This involves cycles – drawing–
production –production–drawing. 
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 A third way refers to precast. BIM’s technology allows to shorten the 
duration of the project – precast, which require a long lead–time may be 
ordered in advance, so as not to delay construction. Often the contractor shall 
designate the deadlines of each works a lot shorter than those which are 
necessary for the execution of precast element, which is difficult to fit within 
the time limits set out in the schedule. 
Error of coordination project reduction – a common problem in a complex 

design are collisions. A hard collision is when two of the element should be 
located in the same place, but soft when the elements are too close to each other 
(e.g. bars in reinforced concrete beam) making difficult to correct placement of 
the concrete mix. When project coordination is inappropriate a collision of 
elements can be seen only when mounting the second element, which involves 
delay and additional costs. 

BIM offers numerous technical advantages that improve coordination at all 
stages of the project. A common tool for conflict detection is Autodesk 
Navisworks Manage, which imports models from a variety of platforms in a 
single environment to identify conflicts. They are identified automatically and 
reported to the users of the software. 

Best practice to avoid conflicts of project’s coordination, in the case of 
specific projects is to perform it in parallel with the cooperating parties, with the 
participation of all sectors of production. BIM enables to reduce the direct 
technical costs of 3 ways [Eastman et al. (2011)]: 
 by increasing the automation of the design and application of software for 

analysis, 
 through full automation of creating drawings, 
 reduction of the amendments through increased design’s coordination and 

quality control. 
Preprocessing of data for software for a variety of analyses can be performed 

directly from the BIM or in BIM’s platform. For example, most BIM’s platforms 
used in structural systems allows to the definition of the loads, load cases, 
support conditions, characteristics of the materials and all other data needed for 
analysis. 

BIM’s systems could allow designers to adopt the concept of the 
development of the entire project, where appropriate software provides taking 
into account the implications of design decisions, based on the components. For 
example, the minor details of the elements constituting a structure, to fit into 
each other in the nodes can be designed on the basis of predefined custom 
elements. With automation time can be saved, which can be used to the 
laborious execution of details and workshop drawings. 

Many BIM’s systems creates reports that include drawings and material’s 
bills fully automatically. Many of them can maintain consistency between the 
model and the set of drawings without any significant impact of the program’s 
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user. It is a large facility for engineers, who have so far spent a lot of time on the 
tedious process of creating drawings. 

The use of prefabricates become popular due to the precision and small risk 
of errors, because it is limited to the assembly. By significantly reducing the 
workload on the production of drawings in BIM, they became economically 
attractive for companies producing semi–finished products, as well as on 
developing projects for additional details. Automatic maintenance of the 
geometric integrity means that the amendment of the standard element in the 
design and manufacture of specialized workshop’s drawing costs relatively little 
effort. 

2.4. Case study 
The following chapter describes five examples of BIM usage in investment 

process. In the Aviva Stadium in Dublin, BIM has been used to parametric 
modeling and optimization of atypical stadium shell, which is a horseshoe 
shaped with sections of varying geometry. BIM’s technology has been used 
since the development concept to the erection phase of the building. In the case 
of 100 11th Avenue Apartments in New York BIM’s technology was used for 
the design of curtain wall system. BIM’s programs have been used as the basis 
for the execution of the static analysis of the façade, and in the process of 
performing prefabricates. On example on One Island East Office Tower in Hong 
Kong BIM’s application in order to support the project management process and 
the coordination of the project’s team was showed. In addition, the BIM was 
used in order to create a schedule of building erection. In the Music Center in 
Helsinki BIM was used as a tool for advanced environmental assessment and 
sustainable design. The examples mentioned above are discussed in detail, but 
the last case study (the Crossrail in London) is in the form of a brief review. 

Below are described steps in the construction investment process, covered by 
each case study: 
 concept development – Aviva Stadium in Dublin, Ireland; 100 11th Avenue 

Apartments in New York City; Music Center in Helsinki, Finland, 
 design development, design documents, pre–construction – Aviva Stadium in 

Dublin, Ireland; 100 11th Avenue Apartments in New York City; One Island 
East Office Tower in Hong Kong; Music Center in Helsinki, Finland, 

 construction – Aviva Stadium in Dublin, Ireland; Music Center in Helsinki, 
Finland. 
Below are listed the participants of the construction investment process for 

each case study, who participated in the implementation of BIM technology in 
the project: 
 owner/developer, engineer, contractor – Aviva Stadium in Dublin, Ireland; 

One Island East Office Tower in Hong Kong; Music Center in Helsinki, 
Finland, 
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 architect, subcontractor/fabricator – Aviva Stadium in Dublin, Ireland; 100 
11th Avenue Apartments in New York City; One Island East Office Tower in 
Hong Kong; Music Center in Helsinki, Finland, 

 facility operations/end users – Music Center in Helsinki, Finland 
The software used during the construction investment process for each case 

study: 
 Bentley Architecture, Bentley Generative Components, Rhino, Excel, 

Navisworks – Aviva Stadium in Dublin; Ireland, 
 AutoCAD – Aviva Stadium in Dublin, Ireland; 100 11th Avenue Apartments 

in New York City; One Island East Office Tower in Hong Kong; Music 
Center in Helsinki, Finland, 

 Rhino, Robot Millennium, SolidWorks – Aviva Stadium in Dublin, Ireland; 
100 11th Avenue Apartments in New York City, 

 Digital Project – 100 11th Avenue Apartments in New York City; One Island 
East Office Tower in Hong Kong, 

 CATIA, Strand – 100 11th Avenue Apartments in New York City, 
 Tekla Structures, MagicCAD, Autodesk Architecture, Vico Cost Estimation, 

Solibri – Music Center in Helsinki, Finland. 

2.4.1. Aviva Stadium, Dublin 
The new Aviva Stadium (Fig. 2.8) has been designed to replace the old 

structure – Lansdowne Road Stadium in Dublin, Ireland, providing a state–of–
the–art venue with a capacity of 50,000 spectators (after modification). 
Originally from 1876, it was the first international rugby stadium in the world. 
Later, during the 1970s the stadium started to host football matches as well. The 
original Lansdowne Road Stadium had a capacity of 49,000 spectators for rugby 
and 36,000 spectators for football games. However, over the years there has 
been a development of the residential areas around the stadium. In connection 
with the stadium no longer meets the requirements for playing games on the 
international level, in terms of both rugby and football. The redevelopment of 
the stadium was necessary. The name of the new stadium was taken from the 
name of the insurance company – Aviva Group, who signed with the owners of 
the stadium, a 10–year contract for the name’s right. On the rebuild stadium still 
can be played matches in both the rugby and football, just as it was in the old 
one. 

The author of the overall design is Populous, it is one of the world's leaders in 
architectural design of sports facilities. Co–author of the project was also Scott 
Tallon Walker company. The original client for this project was the Lansdowne 
Road Stadium Development Company (LRSDC). In order to fulfill an agreement 
made with the Irish Government for the construction and management of the 
new stadium in 2004 Irish Rugby Football Union and the Football Association 
of Ireland created LRSDC.  
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Fig. 2.8. A view of the finished stadium (up), a view from stadium’s seats (down) 
 [www.e–architect.co.uk, www.entertainment–today.net] 

 
All organizations and companies involved into the project are listed below: 

 client – Aviva Stadium (previously LRSDC), 
 project director – Michael Greene, 
 stadium director – Michael Murphy, 
 project management – Project Management Ltd., 
 quantity surveyors – Keogh McConnell Spence/Franklin Sports Ltd., 
 architects – Populous and Scott Tallon Walker, 
 structural, civil and façade engineers – Buro Hapold, 
 services engineers – M–E Engineers Ltd., 
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 landscape designer – Gross Max, 
 catering designers – Smart Design Group & QA Design, 
 pitch design – The Sports Turf Research Institute (STRI), 
 planning consultant – Tom Philips Associates, 
 fire consultancy – Michael Slattery Associates, 
 communications – WHPR, 
 main contractor – John Sisk and Son Ltd., 
 demolition & rail corridor – McNamara Construction, 
 substructure subcontractor – BAM, 
 structural steel subcontractor – SIAC/Cimolai JV, 
 mechanical subcontractor – Mercury, 
 electrical subcontractor – Kentz, 
 roofing and cladding – Williaam Cox.  

The new stadium and the main pitch (playing field) are oriented North–
South, generally in the same orientation as the old stadium. The most 
characteristic feature of the new stadium is a half–transparent shell, which is 
entirely above the seating tiers. This solution allowed for use for maximum 
natural light for both the pitch and the surrounding residential areas. 

The primary purpose of the project of the new Aviva Stadium was the 
construction of the stadium for at least 50,000 seating places, but the problem 
was a small area of land available for the construction due to the presence in the 
neighborhood large residential areas. In addition, the project had to meet a 
number of environmental requirements in terms of the stadium’s erection and 
later its use. A number of these requirements imposed on the project team use an 
innovative architectural and construction solutions. 

The construction of the Aviva Stadium began on May, 2007 and it is finished 
now. The case study shows the use of BIM to create and realize an innovative 
freeform design by the development of a parametric model that supported the 
definition of the stadium’s skin and structure, and how the model was used to 
manage their fabrication and erection. 

The project cost is an estimated $530 million. The design consists of a 
continuous curvilinear–shaped envelope enclosing all four sides of the stadium 
bowl and the roof. It reaches a height of just under 50 meters, where on the three 
sides are four tiers of seating for spectators. In order to minimize the impact over 
the residential neighborhood, the north stand has only one seating tier. 

During the conceptual analysis many different combinations in terms of the 
shape of the stadium and its orientation in relation to the world’s directions was 
analyzed. The leading idea was to wrap the stadium with a smooth “shingled” 
organic skin, with a seamless continuity between façade and roof. To do this 
architects used Rhino software and created a three–dimensional model of the 
stadium’s shell in order to consider the best options. It was necessary to meet 4 
criteria: 
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 to ensure the required number of seating places and their distribution in 
relation to the pitch in order to meet the requirements for playing games on 
the international level both in rugby and football, 

 to maximize the access of the Sun to the pitch to natural grass growth on the 
playing field, 

 to minimize the shading of adjacent residential areas, 
 to provide additional space for service and training facilities on the East side 

of the stadium. 
The team analyzed alternatives through several studies which included glare, 

transportation, accessibility, and emergency evacuation. Extensive daylight 
studies were done based on both north–south and east–west orientations. In 
order to reduce shading on the north side of the stadium architects decided to 
limit the stadium’s height and recommended the construction on this side one 
sector of seats, and on three other sides (Eastern, Western and Southern) – four 
tiers. This configuration has resulted in a very innovative solution of a stadium 
shape and gave new architectural quality to the whole city. In addition, the above 
mentioned solution made the viewers sitting on the southern side of the pitch 
have an amazing view of the Centre of Dublin. 

The most innovative and complicated aspect of this project was the design of 
the roof’s structure, developed by Buro Happold. The base was a primary 
“horseshoe” steel truss that spans around the east, south and west tiers of the 
stadium. This horseshoe truss is supported at the north by a pair of tapering 
concrete super columns and by a series of secondary spur–trusses that connect 
the primary truss to an outer/ring truss that runs around the perimeter of the 
stadium. Tertiary trusses then span radially between the primary truss and the 
ring truss, and then cantilever up to 15 meters beyond the primary truss to create 
the internal leading edge of the roof. The shape, depth, and number of 
components needed to be calculated not only for the sake of meeting the bearing 
conditions, but also because of the functional conditions. For example, sight 
lines at the top–level seat could be blocked if the bottom of the primary truss 
was too low. In addition, the height of each truss segments could not exceed 4.4 
m due to the possibility of transport of such item on the construction site from 
prefabrication plant. Due to the non–symmetry shape of the stadium’s shell 
every roof truss had to be designed and tested individually in terms of load 
capacity. 

Work on the project took place on two parallel tracks. The first was the 
“core” of the stadium – bowl, pitch, internal spaces and facilities. The second 
was the stadium’s cladding envelope. Due to complexity of the envelope design 
and the need for constant adjustments in its constraints, the work of the team 
were centered on parametric models using Bentley’s Generative Components 
(GC) software. Parametric approach meant that the geometry of the stadium was 
controlled numerically, as long–range efforts was the fact that individual 
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elements can be modified when such need occurred. The external geometry of 
the stadium’s envelope was carried out by architects, while the engineers 
designed the structural system to support the envelope. Such solution allowed 
the manipulation of the design geometry while the structural geometry and 
corresponding structural analysis were triggered automatically. A graphical 
control system based on control curves was constructed to easily manipulate the 
overall geometry of the model (Fig.2.9). 

The design team provided several advantages of using parametric modeling 
in terms of cooperation between the designers of different branches: 
 make changes into the model by one user is immediately visible to other 

users; all the architectural and parametric models were created on the same 
basic configuration parameters and rules, which running the model; such an 
approach makes it easy to generate alternative solutions, 

 

 
 

Fig. 2.9. Set of curves that controlled the envelope 
1 – grid file, 2 – outer–edge setout, 3 – inner–edge setout, 4 – section geometry, 5 – sectional 

height graph, 6 – structural definition, 7 – form definition, 8 – mullions definition 
[www.grasshopper3d.com] 



62 

 reduce feedback cycles; using one model makes it easier to carry out the 
analysis of the bearing capacity of the structure, reduces the time of this 
analysis, and shortening the feedback cycles; in addition, in order to facilitate 
this process application developed by engineers of Buro Happold and 
integrated with Generative Components (GC) was created, 

 streamline the creation and configuration of alternative solutions for cladding 
system; it has been created a dynamic link between the Excel’s worksheet 
and the GC to create complex system for creating complex louver opening 
patterns; such patterns had to have a strong aesthetic appeal and satisfy air 
handling unit (AHU) ventilation requirements, 

 improving the cooperation between the curtain wall team and roof 
construction contractors thanks to generated schedules from 3D parametric 
model. 
Buro Happold has taken the task aimed at creating computational model for 

structural analysis. One of the biggest challenge has been to integrate 
engineering analysis with this parametric workflow. For that purpose a custom 
application was developed in–house to support the integration between the 
parametric model and structural analysis software. This custom application was 
able to transfer information from the GC parametric model directly into Robot 
Millennium (Fig. 2.10), a structural analysis package. The automation was 
achieved to such extent that the file created in Robot Millennium was ready for 
analysis without manual preprocessing of loading data. The program 
automatically specified sectional dimensions to each structural element in the 
model, such as truss chords, lacing members, or bracing. 
 

 
 

Fig. 2.10. Structural model created in Robot Millennium 
 (www.arc239parametricism.wordpress.com) 
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The initial estimation process was based on engineering assessment of 
loading condition and spans, which were then gradually refined during further 
analysis iterations. The result of the work carried out in Buro Happold was 
creation of a fully parametric system that was able to create a comprehensive 
structural model of the stadium’s roof using the assumptions and initial 
architectural dependencies developed by a team of architects. Developed the 
system automatically created data files ready for analysis without the need to 
modify them manually. 

Another benefit of the application of the parametric models (both of 
architectural and structural) was the support provided for the processes of 
detailing, fabrication, and erection of the stadium’s envelope – both the facade 
cladding and the roof’s structure. The main output in both cases were updated 
center–line models that represented a simplified geometry of the design, along 
with spreadsheet files containing further descriptions of section types and 
dimensions for linear elements. These models and their linked spreadsheet files 
were used by the cladding and roofing subcontractors to achieve the final results. 
One of the objectives during the execution of the project was the execution of 
continuous, without any jumps or kinks, the connection of the roof with the 
exterior of the stadium. In this connection, close cooperation was required 
between the façade team and roof structure contractor. This has been achieved 
through the use of the same center–line, construction model created by the team 
of engineers. In addition, the very detail has been mapped individual process 
steps. 

The subcontractor chosen to mount and erection of the roof structure was the 
Italian company Cimolai, which specializes in carrying out very large steel 
structures. The Cimolai team used German BOCAD fabrication and CAD/CAM 
application to generate all necessary information about mounting and assembly 
directly from center–lines DWG model developed by Buro Happold. In addition, 
in this model, the technical specification of individual sections was organized 
layer by layer, which greatly accelerated the generation of details using tailored 
to these needs BOCAD macros. BOCAD system also supports some critical 
tasks related with performance such as: management of materials, part lists 
processing, parts nesting, generating NC files to automatic laser cutting 
machines, mounting planning. 

The process of erection of the object is consisted of multiple offsite and 
onsite methods. The main point was the assembly of prefabricated 25–meter–
long truss segments that compose the primary horseshoe truss. The truss 
segments were made of welded cylindrical members that have been delivered to 
the construction site and raised by cranes. Temporary supporting structures have 
been set under the segment links to support truss segments and connections were 
bolted (Fig. 2.11). 
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Fig. 2.11. Horseshoe truss construction process 
 [www.grasshopper3d.com] 

 
The roof horseshoe truss has been set to the position at the time when all the 

segments of the main truss had already been positioned and connected to each 
other. Due to the size and nature of the truss itself, the entire structure will be 
subjected to thermal effects. This cause thermal expansion of the whole structure 
during the whole lifetime. Thus the ends of the primary horseshoe truss rested on 
bearing plates and each spur truss resided onto directional slip bearings on the 
back of the bowl allowing the whole system to expand and contract in place. 

The design of the cladding consists of an array of polycarbonate louver 
panels that follow the curvature of the stadium envelope. The initial modeling of 
the cladding was made in Generative Components by parametric propagation of 
the panel’s components along the boundary–layer surface. They were generated 
by fixed–width but of different lengths. In this way alignment and dimensioning 
of each panel was automatically adjusted by the software to fit curvature 
variations on the envelope’s geometry. 

The penalization pattern and opening layout require high precision in 
optimizing the panels and their connections. Due to the large size of the model 
that contains the design of cladding and a large number of items, it was 
impossible to execute one parametric model for the entire envelope. Instead of 
dividing the entire model into smaller parts with a curtain wall consultant was 
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talked. The proposed solution was to stripping–down the entire envelope’s 
parametric model for smaller „children” models defined by the structural bays 
within tertiary trusses that were four panels wide. Control point information 
from the master model was then extracted through a scripted function and 
exported to Excel spreadsheets. Each individual smaller model was created by 
other scripted intricate functions that read in the spreadsheet data and rebuilt 
each individual bay into GC separated files. In this way, the problem of difficult 
management of one large model was solved by dividing it into smaller, 
manageable models. At a later stage of the work on the individual elements’ 
project it was sent to the facade specialists as DWG files in order to further 
optimize and detailing. A consultant from the façade was Swiss company Clad 
Engineering. Their main task was optimization already executed project of 
stadium’s cladding in terms of fastest and cheapest execution 

Most of the information needed to fabricate of polycarbonate cladding panels 
was contained in Excel’s spreadsheets extracted directly from the parametric 
model. Main fabricator was Williaam Cox, who all the time of the project 
realization has worked closely with Clad Engineering. This cooperation has led 
to the creation of custom cladding façade system was made of four main 
components: the polycarbonate louver panels, the aluminum frame for the 
panels, the aluminum rotational brackets, and the curved aluminum mullions 
(Fig. 2.12). In order to support work related to the implementation of the façade 
SolidWorks’s models of individual elements were made. 

To comply with aluminum panel frames and brackets was used the traditional 
method of aluminum die–casting process. To this end, the main fabricator has 
hired two local contractors, who were able to make such items using the above 
method and using the information contained in the SolidWorks model. 

To perform polycarbonate cladding panels most of the necessary information 
was contained in the Excel spreadsheets, which were directly extracted from a 
parametric model. The information identified each panel within a bay, along 
with its specific length, orientation, and opening angle. Panel cross–sections 
were constant and were achieved by cold–folding polycarbonate sheets. 

The most complicated process was to execute curved mullion segments with 
all the predrilled holes needed to connect with the rest of the mullion segments 
and the brackets. For this purpose was used a specially developed by Clad 
Engineering rigging table. Information about each hole – its position and 
diameter has been obtained automatically from a three–dimensional 
SolidWork’s model. All drills were made by hand, but with the use of laser 
pointing devices and rigging table. Finally each mullion was identified with a 
bar code depicting individual bay and specific position within bays. 
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Fig. 2.12.  Design–to–manufacturing process of custom cladding façade’s components 
 [Eastman et al. (2011)] 

 
The basis of BIM models is parametric model. The architecture–engineering 

partnership created for the Aviva Stadium is an excellent example of how this 
technology was used to support a highly collaborative design process to generate 
innovative outcomes. The most obvious advantage was the flexibility of the 
parametric model that was used by both design and manufacturing companies. 
This allowed for quick and easy changes in the model at the same time at each 
level. In addition, the success of such an approach could be thanks to the 
excellent cooperation between architects and engineers. In order to modify the 
model had to have highly specialized skills – that was the disadvantage of such 
an approach, since such skills have only a few members of the team. Even 
though it is not necessary that all subcontractors have skills in parametric 
modeling, their domain expertise should be considered and incorporated into the 
formalized rules to define new custom capabilities. 

The benefits of using BIM technology during implementation of the Aviva 
Stadium in Dublin: 
 support for project scoping, 
 support for project cost estimation, 
 scenario planning, 



67 

 early and accurate visualizations, 
 automatic maintenance of consistency in design, 
 enhanced building performance and quality, 
 accurate and consistent drawing sets, 
 synchronize design and construction planning, 
 drive fabrication and greater use of prefabricated components. 

This case study has been drawn up on the basis of the Eastman et al. (2011), 
Hudson et al. (2011) and Mccormick and Geoff (2011). 

2.4.2. 100 11TH Avenue, New York City 
This case describes an innovative approach in implementing building 

information modeling, with particular regard to the way in which BIM facilitates 
design, communication, and analysis for curtain wall design. The building is a 
21–story residential condominium, located in Manhattan near the Westside 
Highway and 19th Street (Fig. 2.13). 

This building provides a river view of the downtown financial district and the 
New Jersey shore. The curtain wall is an innovative and unique in design. The 
main assumption was based on the fact that the curtain wall was not a bearing 
structure, only that each segment were hung to the structure of the building. 
There are also technical and environmental issues relevant to a glass curtain 
wall, such as water impermeability and insulation, which constrain the 
morphology of its surface. Another important aspect is the faceted surface, 
which consists of a series of planes tilted along multiple angles and axis. 

The team taking part in the construction investment process: 
 ownership group – Cape Advisors and Alf Naman Real Estate, 
 design architect – Ateliers Jean Nouvel, 
 architect of record – Beyer Blinder Belle, 
 construction manager and general contractor – Gotham Construction, 
 façade consultant – Front Inc., 
 structural engineer –  DeSimone Consulting Engineers, 
 acoustic consultant – Cerami & Associates, 
 curtain wall fabrication team – CCAFT, SGT, KGE. 
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Fig. 2.13. 100 11th Avenue (left), hidden line view of curtain wall (right) 
 [www.architravel.com, www.wirednewyork.com] 

 
Front Inc. was involved into the project at an early stage of conceptual design 

in order to deliver an opinion to the owner on the feasibility of two design 
solutions prepared by the architect. The proposed solution for the outer surface 
consisted of two systems. Energy code provision of the New York State says 
that a maximum of 50% of the surface of the façade of the building can be 
glazed. In the case of 100 11th Avenue at the stage of design assumed that the 
40% of elevation will be glazed, and the remaining 60% will be represented with 
a black lining brick with random window openings, in which each window will 
be located at some angle. The curtain wall system changes at street level to a 
hybrid system of a faceted curtain wall and a series of cavities with large 
planters that affect the loading system. 

Average cost of the façade was counted on the basis of the weighted average 
depending on the topology of the system and the surface occupied by the type of 
cladding. And as for the glass surface adopted a calculation factor equal to 2.5 – 
compared to a standard curtain wall. For brick and window facade established 
calculation factor to 1.0. Knowing the aspect ratio (40% – glass, 60% – rest) 
calculated the total average cost of elevation, which amounted to 1.6 of standard 
cost of the curtain wall. 

For developers of residential buildings it was far too large cost of elevation. 
Construction accounted for approximately 25% of the cost of all the hard 
construction cost of the entire building. The average for this type of buildings 
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this coefficient ranges from about 12 to 15%. Despite these 25% it was still 
cheaper solution, because the design of cladding system developed by architects 
Gehry Partners, Asymptote, Sejima, Nisihizawa & Associates included in the 
range of 25 to 40% of the total construction costs for the entire building.It is 
clear that for specific projects, special façade systems have generated cultural, 
environmental, marketing, and other values. 

AEC community adopted building’s information modeling systems as a 
powerful tool. Their many features include a robust parametric modeler, analysis 
tools, spreadsheet functionality, API, and file export functionality. In the case of 
Front Inc.’s (façade consultant) use of Digital Project (DP) for this building. A 
particular achievement was to implement BIM model’s tools at an early stage of 
the design process. They were able to store and update information about the 
design of the curtain wall, and allow fast and efficient data exchange between 
participants of the project. 
 

 
Fig. 2.14. Direction of rotation map 

 (www.arqa.com) 
 

The challenge in the parametric modeling phase of the project was to identify 
rational ways to systematize the design without compromising the aesthetic 
value of the design concept. In the matter of the material for the framing system 
steel was used instead of aluminum due to the ability to perform complex and 
less visible connections between the different components. Ateliers Jean Nouvel 
provided a breakdown of façade’s system as a composition of glass panels with 
four directions of rotation (tilting left, right, up and down – Fig. 2.14), four glass 
variations, and angles of rotation varying through 0, 2, 3, 4, and 5 degrees of 
vertical. 
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In order to organize mentioned above parameters Front Inc. created an 
Excel’s spreadsheet. The Excel’s file would be referenced as a design table in 
Digital Project to associate all parametric variations. 

Façade’s system mostly is made of steel with a regular grid of mega –panels 
and a randomized subdivision of glass panes held in aluminum cassettes. Design 
table that was created in Digital Project organizes the variations of the 1,351 
individual glass panels that make up the façade, sorting them according to the 
configuration, dimension, and location in the grid. 

Visual mock–up (4.5m x 12.8m) was fabricated by SGT and reviewed in 
Shenzen with the ownership and architects in January 2007. The mock–up 
consisted two flat mega–panels and two curved corner ones, as shown in Fig. 
2.15. In Digital Project a 3D solid model was generated which consisted steel, 
aluminum, glass, and the design table information driving the associative 
parametric subassemblies in the wire–frame armature. Using this 3D model 
geometry, a technical and assembly drawings were extracted and viewed, and 
interrogated the model, which was fully correct in engineering aspect.At a time 
when visual mock–up was produced, the extruded aluminum profiles were not 
yet available for production. While the SGT was able to make a fully parametric 
geometry model for the implementation of CNC files necessary to cutting 
machines for aluminum. At this stage, however, it was very important to have a 
very detailed model of the curtain wall. Visual mock–up had to be made very 
carefully and in accordance with the actual sections of the façade, which later 
will be made on an assembly line. After review of the mock–up, production and 
delivery of the mega–panels was planned, in sequence according to the 
construction schedule. The first installation on site was scheduled for January 
2008. 

The main feature of the BIM is the management and storage of information 
about the project and the communication, and exchange of information between 
the participants of the task at the design and construction stage. Referring to the 
above information Front Inc. was responsible for engineering the design of the 
steel and overall system’s geometry. The glass gasket, aluminum, and silicone 
were not their task. The model included high–level detail, such as the location of 
air–filled cavities and the meeting points of rain gaskets, to provide absolute 
continuity. The model was also included information on the thickness of the 
glass, edge bevels, and the thickness of the PVB (Polyvinylbutyral) interlayer 
laminated between the glass panes. Model created by Front Inc.’s was major 
data repository for the entire curtain wall system. 
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Fig. 2.15. Visual mock–up located in Shenzhen, China 
 [Eastman et al. (2011)] 

 
Several different programs were used such as: Rhino, AutoCad, SolidWorks 

and Catia. The last one and Digital Project has additional parametric capabilities, 
as compared to other BIM’s software. Main and specific design was done using 
Digital Project – geometry and other information, but structural analysis was 
performed by Robot and Strand. For instance, the mega–panel’s wire frame was 
exported from DP in an IGES format and brought into the Robot to test 
deflection, as shown in Fig. 2.16. 

The cross sections of the framework elements have been developed in 
AutoCAD. Then so drawn cross sections in two–dimensional space have been 
imported into the Digital Project. The use of 2D drawings was necessary because 
of a lack of commitment to the project a sufficient number of people who had 
high support skills in Digital Project. The rendered model has been generated in 
the Flamingo and Viz. 

At the start of the project, Front Inc. received a 3D model with a single 
polygon representation of tilted glass panels produced in Rhino from Ateliers 
Jean Nouvel. The exchange of information continued during when the 
visualization of cladding system of curtain wall was generated. All information 
obtained from Ateliers Jean Nouvel are systematically placed into the Digital 
Project. Ultimately, the model developed in the DP by the contractor was an 
expression of that what was designed by the architect in Rhino. 
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The architect Beyer, Blinder, Belle (BBB) and the façade contractor were 
responsible for the coordination of the façade with the building itself. That team 
produced the construction documents for entire building. For the façade, the 
approach was design–build, so Front Inc. and BBB shared shop–drawing 
information. A great deal of coordination with many iteration cycles was needed. 
The PDF files were created and passed from Front Inc. to the BBB. They 
checked and verified the coordination of the technical documents and sent 
information back to Front Inc. such as for slab edge profiles in AutoCAD. Front 
Inc. had fabricator in China who has access to 3D model of final geometry. All 
other product’s model information were stored in a Catia file format. That file 
was basis to extract all of the drawings necessary for fabrication of the façade’s 
components. 
 

 
 

Fig. 2.16. Mega–panel tested in Robot 
 [Eastman et al. (2011)] 
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The most valuable result of the use of a 3D building’s model was the ability 
to use parameters associated with a spreadsheet and predicate rules in the 
production of feature templates that could be reused. The parametric model was 
used to generate and check correctness of multiple solutions for various 
environmental conditions. By using this model, Front Inc. could produce a 
curtain wall system that was very different from the design proposal provided by 
Jean Nouvel but using the same parametric assembly. Front Inc. had hoped that 
developed the parametric components directory will bring many benefits in 
future projects. Marc Simmons was convinced that the use of BIM technology in 
this project and in the future will allow to fully integrate the planning process, 
the design with the production of components and later with their assembly on 
site. 

Dassault Systemes’ CATIA is an integrated tool designed for companies in 
aerospace engineering, where the person responsible for design is also 
responsible for engineering, sales, and marketing. The application of Digital 
Project as a product of consortium of CATIA and Gehry Technologies may also 
have similar meaning in construction and architecture. As a result of the 
experience gained in the way of the implementation of this project the Front Inc. 
broaden their activities by consulting services for architects, engineers and 
contractors. This resulted in working with an architect Point B Design in the 
implementation of the façade of the shopping mall in Philadelphia. 

In the 100 11th Avenue a complex aesthetic concept for façade’s system was 
considered and implemented using BIM’s model with a set of regulating lines in 
order to structure a hierarchical nesting of parameters bound to design tables. In 
fact, the regular grid, designation a distribution of mega–panels on the wall has 
been hidden, because of the complexity of the system’s subdivision. Therefore 
the legibility of the vertical and horizontal lines is reduced, and the variegated 
texture of the façade is emphasized. 

Building information modeling introduces a new quality in the way in which 
architects and designers construct buildings. The BIM’s model was the central 
database information, which was exchanged between the participants of the 
project. More efficient have become issues such as the analysis of design ideas 
and building performance, cost estimation, and construction scheduling. By 
using the same model, architects, engineers, contractors, and manufacturers can 
communicate and implement changes to the design quickly. But there are two 
issues connected with the communication process. Firstly not of all participants 
of the project may be using the same or compatible software, therefore 
information is lost in the exchange of model files. In addition, for BIM’s tools to 
be used to their full capability, additional expertise and skills are required from 
architects and designers, beyond the limits of commonly accepted skills. 
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The benefits of using BIM technology during implementation of the 100 11th 
Avenue in New York City: 
 early and accurate visualizations, 
 automatic maintenance of consistency in design, 
 enhanced building performance and quality, 
 accurate and consistent drawing sets, 
 earlier collaboration of multiple design disciplines, 
 synchronize design and construction planning, 
 drive fabrication and greater use of prefabricated, 
 coordinate/synchronize procurement 

This case study has been developed on the basis of the Eastman et al. (2011). 

2.4.3. One Island East, Hong Kong 
This case study shows the implementation of BIM’s technology to manage 

the financial and functional relationships between design, construction, and 
facility management on a large, complex project by an owner–developer. The 
owner of the complex discovered in the BIM high potential in terms of the 
system that manages information more effectively and saves time and money 
over the project’s lifecycle. In the beginning of the project owner used 2D 
design tools. A study shows the adaptation of existing technical documentation 
of the project to the BIM’s system in terms of technology, construction and 
management. 

The OIE (Fig. 2.17) is project made by Swire Properties, which is one of the 
leading developer and industrial leader in the construction industry in Hong 
Kong. The One Island East is a large commercial office building with 70 floors 
built in 2008. 

Basic data about the project and the participants of the construction 
investment process: 
 location – Hong Kong, China, 
 project name – One Island East (OIE), 
 contract type – competitive tendering, 
 construction cost – $300 million (approximately), 
 project scale – 70 floors with 2 basement levels, 
 total floor area – 141,000 m2, 
 typical floor area – 2,270 m2, 
 period of construction – 24 months, 
 expected completion – March 2008, 
 current stage – under construction as of January 2007, 
 owner – Swire Properties Limited, 
 architect – Wong & Ouyang (HK) Limited, 
 quantity surveyor – Levett & Bailey Quantity Surveyor Limited, 
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 contractor – Gammon Construction Limited, 
 BIM consultant – Gehry Technologies, 
 functions – office and commercial facilities, 
 structure – reinforced concrete, 
 exterior – aluminum curtain wall. 
 

   
 

Fig. 2.17. One Island East located in Hong Kong (left) and rendered model (right) 
 [www.rlb.com, www.forum.skyscraperpage.com] 

 
As an owner, Swire’s organization is responsible for managing the design 

and construction, and the leasing, and operations of the facility. In addition 
Swire manages hundreds of facilities and projects at any given time. When the 
quantity of tasks that need to be in control of Swire, they began looking for 
better tools that would allow them to coordinate both design and engineering 
works, preferably while managing their facility management systems. 

Swire was looking for tools to manage the construction, which will be able to 
manage very large projects or several projects with possibility of exchange and 
merge of design information, costs, estimates, construction process management, 
quality assurance, and facilities management. As a result of these explorations 
Swire saw potential in BIM technology, but not only at the stage of the design 
and erection of the building, but also at the stage of building management during 
its use. 
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Fig. 2.18. Integration of BIM within the participants of the project 
 [Eastman et al. (2011)] 

 
The OIE project was in schematic design phase when Swire was researching 

BIM’s systems. Their choice fell on the Digital Project. DP fits perfectly to 
manage such a big, complex project and manage relationships to various 
information sources such as cost, construction, and facility management. In the 
course of DP adaptation to the OIE project’s team simultaneously was 
performing traditional blueprints as 2D drawings. Initially, four companies 
showed in Fig. 2.18 communicated with each other using 2D drawings but 
subsequently developed a full 3D process using DP’s BIM software. In order to 
speed up this process, GT provided training with BIM for the other project 
participants. Initially the BIM model was executed in the Gehry Technologies, 
on which the consultants conducted training for members of the project team. 
The actual modeling team consisted of architects, structural engineers, MEP 
engineers, and quantity surveyors. At a time when working knowledge of Digital 
Project already was sufficient for the implementation of the project, project 
consultant took control over the process of BIM and completed building model. 
GT and the design consultant team cooperated closely in this effort. 

All coordination activities were performed by using BIM. The OIE design 
team, BIM consultant and the project manager during the first year were 
working in one room. While the whole design team consisted of four GT BIM 
consultants, one MEP project manager, one project manager, two quantity 
surveyors, six MEP engineers, four structural engineers and four architects. 
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The design team worked either directly or indirectly on coordinating the 
input of information into the building’s model. Swire Properties maintained a 
portal site, by which the project’s team members communicated with each other. 
That site became the main communication platform for the BIM’s process. The 
information that was not contained directly in the BIM were transferred and 
shared through the portal. The BIM’s implementation team met weekly for the 
first year to identify and resolve errors, clashes, and other design problems using 
the BIM. Using building information systems over 2000 clashes and errors were 
found prior to tendering and construction. This translates directly to big savings 
of money, in comparison to the traditional 2D process. Fig. 2.19 shows how 
easily the clashes between elements of different disciplines could be identified in 
the 3D model. 

Clash detection was performed mostly using the features available in the 
Digital Project, which similar as Tekla Structures is able to identify geometric 
clashes and present them in the form of a list. Double clicking on the clash in the 
list automatically shows the clash on the screen and you can exactly, from each 
side see the place of occurrence of the error. The structure is then corrected by 
members of the project team in such a way that the clash must be eliminated. In 
addition, in the case when two elements must be really close to each other, the 
user of the software may enter the clash tolerance and set as the default value in 
the software. 

Using the traditional methods of two–dimensional drawing clashes are sought 
at the drawings on the drafting table. This is a very hard job, because the 
designer with the naked eye a lot of key clashes can accidentally omit. In the 
past, very often, such errors were only identified in the time of building erection 
and live corrected by constructors. 
 

 
 

Fig. 2.19. Automated clash detection in OIE BIM’s model, using Digital Project 
[www.hkifm.org.hk] 
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A common building’s information model can consist of hundreds (sometimes 
thousands) of parts, which can be a column, wall, an escalator, or an HVAC run. 
In OIE to organize these parts within a hierarchical structure the type of file 
called Product Structure was used. Such solution brings a lot of benefits: 
 one user can open a whole building model or one of its branches; e.g. floor of 

the building, or one system – drainage, HVAC, 
 large teams can work simultaneously on the same DP master–model, since 

each model file is fully autonomous; the person operating the model can use 
Concurrent Versioning System (CVS) tool to manage the access protocol for 
individuals responsible for specific branches, 

 it is possible to load other parts from the Product Structure; for example you 
can load the schema of floor by floor and the function schema, 

 you can add dependencies between individual parts of the files in such a way 
as to change the geometry of one part affect the other. 
A standard BIM model is built just like the main building. Each of the main 

building is divided into floors and to sectors that are not typical floors just 
contain the individual branches. Examples of the latter are the branches for the 
main driver files, lift cars, and section drawing files. Driver files include 
information on building’s details such as the position of the beams, columns, 
projections of individual floors, etc. The advantage of using a parameterized 
model in Digital Project is the fact that by introducing a change on one floor it 
also acts on all related parameters. 

In building each main part is organized by floor and also contains branches 
for parts that are not floor–specific. In such division each floor contained five 
sub–branches: 1 – a branch with floor–specific drawing files, such as 
plans/sections; 2 – a branch containing driver’s files called DRV; 3 – a branch 
with architectural elements (walls, finishes, balustrades, escalators, lifts, 
sanitary, landscape elements); 4 – a branch containing structural elements 
(columns, core walls, beams, slabs, ramps and stairs); 5 – a branch for MEP 
elements (HVAC systems, drainage pipes, and the like). 

The BIM model of One Island East exceeds the size of the five gigabytes. 
You can easily open it on a laptop and there is no loss of efficiency in the course 
of the model management. All the information are well organized and only 
material that is opened at the moment is shown in full detail. Items surrounding 
the item being worked on are shown grayed out and in less detail using 
Computer Graphic Representation (CGR). This reduces data size but can still 
provide clash detection and measurement information. 

Every one element which is modeled via BIM’s process has own attributes, 
such as size, weight, area, volume, and so forth. Such quantitative information 
was tabulated automatically and imported into the Excel’s spreadsheet as shown 
in Fig. 2.20. This approach saved a lot of effort and time when compared to 
material summary made in the traditional way – manually. In addition, the 
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quantity relations are associated with the BIM model. Therefore, any change in 
the model is automatically reflected in the change in the quantity of materials. 
The information contained in the spreadsheet were used in the tendering process. 
BIM model was available to all the tenderers who could directly under it create 
their own listings. This process makes very easy to create a tender 
documentation and results in the reduction of costs and reduced risk. 
 

 
 

Fig. 2.20. Spreadsheet in Excel generated automatically, which contains quantitative 
information about modeled elements needed in tendering process 

 [www.wanda–gh.com] 
 

After the tender, the contractor’s BIM model was updated by Gammon 
Construction Limited. There were made additional information regarding 
temporary formwork and constructions. All the time it was in accord with the 
model shared for the purposes of the tender. 

By using the BIM’s elements developed by the design consultant and 
contractor’s project teams, advanced construction modeling process was also 
carried out to further verify the construction methodology. Gammon 
Construction Limited commissioned the execution of the expertise to the Hong 
Kong Polytechnic University’s Construction Virtual Prototyping Laboratory, led 
by Professor Heng Li, to produce detailed visualizations of the construction 
sequencing. Between DP’s BIM elements and the detailed Gammon Primavera 
construction schedule links were created, which were basis for creation of 
visualization of a construction sequence. That visualization (Fig. 2.21) was 
helpful tool for the contractor and it was called 4D Cad. Gammon analyzed 
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various scenarios primarily aimed at ensuring the possibility of execution  
of scheduled works in accordance with the timetable, e.g. construction of four 
floors per day. The construction methodology for the difficult outrigger floors 
was carefully examined to ensure safety and practicality. Such solution of 
examination saved time and money in the field. 

The biggest challenge in the project was to transform existing 2D project in 
fully parametric 3D BIM’s model. Swire Properties mitigated potential cultural 
issues by requiring the use of 3D and the DP system on the project. 
 

 
 

Fig. 2.21. Virtual construction process simulation of OIE 
 [Eastman et al. (2011)] 

 
Another important feature was to select a BIM’s application and system 

appropriate for the type of projects and business goals of organization. At the 
beginning of the implementation of BIM to the OIE design Swire recruited 
Gehry Technologies as a consultant who provided the appropriate training and 
support during the first year of the BIM’s effort. Software selection process went 
very cautiously because the Swire had to be assured that the system will meet 
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their long term needs. In the future, Swire Properties hopes to achieve even 
greater value when the BIM’s technology and working methods are 
implemented from the very beginning of the process. 

The next critical point was choosing the right software which works 
according to BIM standard in such a way as to fully meet the needs and business 
goals of investor. To this end, Swire very carefully analyzed the different 
variants of the software. Swire finally builds a very complex structures, which is 
why Digital Project turned out to be the best choice. This choice has provided a 
seamless project management. 

It is also worth noting that was saved a very large amounts of money as a 
result of the conduct of clash detection. The analysis carried out by Professor 
Heng Li's group helped confirm that you can achieve fast and secure process of 
the building erection. 

The benefits of using BIM technology during implementation of the One 
Island East in Hong Kong: 
 automatic maintenance of consistency in design, 
 enhanced building performance and quality, 
 accurate and consistent drawing sets, 
 synchronize design and construction planning, 
 discover errors before construction (clash detection). 

This case study has been developed on the basis of the Eastman et al. (2011) 
and Riese (2008). 

2.4.4. Helsinki Music Center, Helsinki 
The construction of the Helsinki Music Center (Fig.2.22. left) was to create 

special and unique in terms of the acoustic space in capital city of Finland, along 
with other facilities enhancing the musical experiences for people of all ages. 
Helsinki Music Center is located in the downtown just in front of the Houses of 
Parliament. The main users of the building will be the Helsinki Philharmonic, 
the Sibelius Academy, and the Finnish Radio Symphony Orchestra. In addition, 
it aims to serve as a place to learn music. 

The team members, who participate in the construction investment process: 
 owners – State of Finland, Senate Properties, City of Helsinki, YLE national 

public broadcasting company, 
 lead developer – Senate Properties, 
 construction manager – ISS, 
 architect – LPR–arkkitehdit Oy, 
 acoustical engineer – Nagata Acoustics Inc./Yasuhisa Toyota, 
 structural engineer – Mikko Vahanen Oy, 
 HVAC engineer – Olof Granlund Oy, 
 electrical engineer – Lausamo Oy, 
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 construction company – SRV, 
 structural steel – Peikko Group, 
 curtain wall panels – Normek Oy. 

Outside the main hall there is a light–filled foyer with glass walls. The 
capacity of the main hall is estimated at 1,700 (Fig.2.22. right). In addition, the 
building houses the 5 smaller auditoriums, each of them having seating for 140 
to 400 people for listeners from jazz to electronic music. Under the same roof, 
there are also cafes and restaurant. The building’s total floor space is 36,000 
square meters. In order to design a music hall the competition in 2000 was 
organized, which won the LPR Architects company, their contract included an 
agreement to design the spaces in cooperation with Japanese consultants Nagata 
Acoustics. 
 

 
Fig. 2.22. Helsinki Music Center by night (up), the main hall scheme (down) 

 [www.plus.google.com, www.hel.fi] 
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In a corner of the building, near the train station is the concert hall model on 
a scale of 1:10. In this model, there are miniature models of people with clothes 
and hairs, in such a way as to simulate the presence of a real audience. This 
model was very useful when performing an analysis of the propagation of sound 
waves inside the concert hall. On this basis, plans have been drawn up and 
seating terraces, and the dramatic shape of the ceiling. Using this model, filled 
with nitrogen, with mounted sound sensors have been drawn up a precise reports 
on the location of the individual sections of the concert hall. Yasuhisa Toyota 
has developed these reports and presented them to Nagata Acoustics, which was 
an adviser in several acoustic projects around the world. 

The competition work was done in the traditional way, using drafting 
techniques, renderings, and physical models. The preliminary design was 
submitted for review and the cost estimate exceeded significantly founded pre–
budget and the project was stopped. The project was significantly revised, but 
still the main criterion remain – the total cost. The architect took the test again, 
this time using a BIM’s system. During the schematic phase of design the 
resulting 2D drawings intended for entries have been transferred in parametric 
3D model using at that time (in 2004) the latest software – AutoCAD 
Architecture. The model was enhanced and refined by the architects working 
directly in 3D with modeling continuing through the detailed design phase. The 
model (Fig. 2.23) will also be used later for facility management. This case 
study is focused especially on the environmental analyses that were applied to 
refine the design. 

In Finland has developed very fast the trend of implementation of BIM 
technology in the construction industry. Senate Properties as Finland's largest 
property asset manager has developed BIM guidelines in order to stimulate 
sustainable development. Great importance for Senate Properties has the 
environmental aspect of construction industry. Their goal is to reduce energy 
consumption by buildings already existing and to minimize the energy 
consumption of buildings emerging. Since 2001, Senate Properties worked on 
several projects, expanding its knowledge about building information modeling. 
On the basis of these experiences they considered that the implementation of 
BIM is essential in order to meet the requirements of sustainable development in 
construction industry. At the same time they began to require from contractors 
new projects, which meet the IFC standard. The main purpose of the modeling 
using BIM software is to ensure that the scope, cost, and practicality of the 
project matched with the objectives. To this end, they have tested many 
applications and models for high comfort of people and energy efficiency. 
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Fig. 2.23. 3D computer model of Helsinki Music Center building 

 [www.pinterest.com] 
 

In a way the scheme of project organization was unique because firstly 
acoustic consultant was selected, and then an architects were chosen by 
competition. The subcontracts were received through an open–bid process from 
a wide set of EU–based companies. In U.S. terms, the project was design–bid–
build. 

One of the owners – Senate Properties, has been motivating the participants 
of the project on the use of BIM’s system. The main purpose behind BIM’s 
adoption was the integration of the processes and workflows of all the team’s 
members, across all phases of the project. On the Fig. 2.24. the energy and 
sustainability tools used in this project and the model’s flow process were 
showed. 

During the project preparation it was repeatedly modified so as to meet all 
the users’ requirements and comply with the objectives of the owner. Architects 
used the BIM model to calculate the floor area usage and development of area 
distribution report for major user groups. It was also important to develop the 
exact models and drawings needed for energy simulation. Sometimes small 
change in a model significantly affect energy assessment of the entire structure. 
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Fig. 2.24. The use of BIM’s applications and their models 
[Eastman et al. (2011)] 

 
The same concert hall was designed separately by Nagata Acoustics. 

Acoustic engineers check the correctness of the solutions applied by the 
architects. Initially all acoustic analyses were performed on the basis of the 
computer simulations. However, very often happened that the capacity of the 
computer simulations were limited and could not obtain data about propagation 
of sound waves of different frequencies. In order to carry out such measurements 
it was just built a model of the concert hall on a scale of 1:10. Acoustic engineer 
also was in contact with interior design team and control if applied ceiling 
construction solutions, the shape of the ceilings, the distribution of seats did not 
adversely affect the performance acoustic performance. 

In addition, the physical model allowed to test many design solutions. For 
example, an acoustic engineer recommended implementation tiled and faceted 
wall instead of a straight partition wall, which was initially designed by the 
architects. In this way, even more improved acoustic comfort of concert hall. 

Lifecycle simulations are usually very extensive, and they are undertaken by 
specialized engineers or research group at the final stage of design, in order to 
validate previous decisions or to fulfill legal mandates. Performing advanced 
energy simulation during the design phase allows for a better understanding of 
the problems related to the loss of energy, air quality, indoor thermal comfort, 
visual environment, and acoustical performance. But the multiple actors and 
complex datasets of current practice almost prohibit use of such analyses to 
provide design feedback. 
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Energy simulation gives the opportunity to compare several technical 
solutions and have a look at the decision–making process from the point of view 
of energy consumption. The energy criterion can be many factors, e.g. the 
amount of energy needed for heating, ventilation, air conditioning, electricity, 
water consumption, and the like. In Helsinki Music Center energy simulation has 
been performed at the early design stage and offered feedback to the architects, 
especially in the selection of most efficient glazing type for curtain walls. 
Mentioned above simulation was performed in Riuska software and results are 
presented in Fig. 2.25. In addition the energy cost comparison results shows that 
glazing Type Two reduces that factor, which is equally important for the final 
decision–making. 
 

 
 

Fig. 2.25. Energy consumption and cost comparison 
[Eastman et al. (2011)] 

 
Lifecycle assessment (LCA) is a powerful method to analyze, evaluate, and 

compare design alternatives from a broad ecological perspective. In most 
analysis LCA require the use of 2D drawings and manual data entry on 
building’s materials. To carry out the analysis of such methods is very time–
consuming, and is usually performed at the time when the building is already 
built. BIM provides designers and engineers with data that can more readily 
integrate with LCA tools during design. BSLCA (Building Services Life Cycle 
Analysis) is such a highly integrated software package. Using a 3D model of the 
building are connected layout and material’s data, system’s data from the 
building services design database, piping and ducting data from commercial 
HVAC–CAD tools, and energy consumption data from the building’s energy 
simulation. The design team used BSLCA to compare different technical 
solutions that affect the power consumption during operation of the building. 
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In the Helsinki Music Center, CFD was used to assess the HVAC system 
design. Results obtained by LCA and CFD analysis were entered into 
MagiCAD’s model for MEP’s system design usage. The IFC file was used to 
transfer energy and comfort simulations. MagiCAD is the system based on 
AutoCAD’s application which is used for building service design including 
piping, plumbing, HVAC (Fig. 2.26), sprinkler and electrical systems. It is a full 
2D and 3D application with integrated calculation functions for sizing, 
balancing, flow route examination, sound calculation, and bill of materials’ 
organization. The basic type file to MagiCAD is the IFC, so there is no obstacles 
to import and export the design model with complete technical and geometrical 
data. 
 

 
 

Fig. 2.26. HVAC design model from MagiCAD 
 [www.magicad.com] 

 
The clash detection was performed using Tekla’s structural models. Very 

helpful was the fact that HVAC and electrical engineers worked both in 
MagiCAD, they could cross–check collisions occurring between the ventilation, 
piping, and electrical installations of any time. MagiCAD can define void 
objects and pass them back to a structural model, in this case Tekla, to create 
openings in the structural model. At run time, the advanced and differentiated 
analysis on the different phases of design building, the biggest problem is the 
manual data entry, notably with regard to the geometry. However, the continuing 
development of the IFC standard creates new possibilities to achieve 
interoperability for design software. In this project, IFC was used as the data 
repository for open data transfer. 
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The Helsinki Music Center shows a lot of application of BIM’s technologies. 
The Riuska software was used to make energy analysis that can support the 
design phase. It transfers the geometry data from architectural software to a 
thermal simulation geometry model, providing consistency between the two 
models. The two glazing types for curtain walls were evaluated. 

Lifecycle analysis was used to compare different technological solutions and 
their impact to the environment. LCA is an important type of analysis that will 
be playing an increasingly important role in design decision–making. From the 
building’s model materials and energy used was extracted, which was crucial for 
LCA analysis. Computational fluid dynamics simulation famous for the fact that 
these are very complex, complicated and time–consuming simulations that 
require involvement in the design of additional specialists in this field. BIM cut 
the amount of work to a large extent and makes CFD simulation accessible to 
general designers. By doing CFD simulation, HVAC system loads of the foyer 
were reduced by over 20 percent. 

Using BIM’s technology MEP’s engineers used all results (energy 
simulation, LCA, CFD) to support their own work, which also was a big 
advantage. 

The benefits of using BIM technology during implementation of the Helsinki 
Music Center in Finland: 
 scenario planning, 
 early and accurate visualizations, 
 automatic maintenance of consistency in design, 
 enhanced building performance and quality, 
 checks against design intent, 
 accurate and consistent drawing sets, 
 earlier collaboration of multiple design disciplines, 
 synchronize design and construction planning, 
 discover errors before construction (clash checking), 
 lifecycle benefits regarding operating costs. 

This case study has been developed on the basis of the Eastman et al. (2011), 
Jiang and Lei (2014) and Wachi (2012). 

2.4.5. Crossrail, London 
The largest on going construction project in Europe, with a value of approx. 

14.8 billion pounds is the expansion of the transport system, including the 
subway in London – Crossrail– three–year design period and an eight–year 
implementation period, which began in 2009 (Fig.2.27, Fig.2.28). 
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Fig. 2.27. Utility corridor to be created beneath Liverpool Street ticket hall 
[www.crossrail.co.uk] 

 
The project includes implementation of 21 km of new dual hollow tunnels, 9 

new underground station in the area of the London’s center, the renovation of 28 
existing terrestrial stations and 90 km of ground traction. 

Construction will generate a minimum of 14 thousand of new jobs, and upon 
completion will provide urban transport up to 200 million passengers per year. 
The main benefits that are already measurable, primarily to minimize wastage as 
a result of a virtual analysis of possible collisions in the area of geometry of the 
structure, designed and existing installations. 
 

 
Fig. 2.28. Tottenham Court Road Station – western ticket hall structural design 

 [www.crossrail.co.uk] 
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Another very important element was and is to improve the effectiveness of 
cooperation by speeding up decision–making in the area of the entire project and 
all designers, contractors and future users. Improved investment by the 
visualization of all processes of implementation and better planning of 
construction organization. 

So far, already generated, among others, 1.75 million CAD documents and 
830 thousand documents in digital form. All are managed more than 8 thousand 
members of all documents and 650 user, which generate drawing 
documentation. The whole process is carried out by 61 contracts involving 
contractors, suppliers, including 25 contracts with general contractors and 30 
agreements with major design companies. 

The benefits, which expects investor is 42 billion pounds, but above all, 
streamlining the network, reduced travel time and reducing congestion around 
the London transport system. As a result of this work investor will build, in 
addition to routes, 8 major centers of interchange, which will in future be 
managed by two operators, or just Crossrail. 

This case study has been developed on the basis of information contained in 
http://www.crossrail.co.uk. 
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3. Practical use of BIM technology – workshop 

3.1. Introduction to the Tekla Structures 
Tekla is a program based on the 3D model for the management of the 

materials’ databases used in construction (steel, concrete, wood, etc.). It is 
mainly intended for designers and manufacturers of materials but also for 
contractors and investors. The main feature of the program is interactive 
modeling, structural analysis, design, detailed modelling of the smallest 
elements (such as connection nodes) and automatic creation of drawings, and 
reports relating to each modeled it any time. Drawings and reports are updated at 
the time of the changes in the model. Tekla contains a wide range of standard 
templates, drawings and reports. It is also possible to create user defined 
templates. 

The program enables, facilitates and pursues teamwork. Designers working 
on the same project can simultaneously work on the same model, at the same 
time and in different places. Each team member sees the changes and updates 
that was introduced someone from designers. 
 

 
 
Fig. 3.1. The choice of the working environment, the role and configuration before user start 

working with the program (Tekla Structures*) 

*All figures in Chapter 2 come from Tekla Structures software (own elaboration) 
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After start of the program, user must choose the working environment 
(settings and information dependent on region), and role, e.g. complete 
modeling, construction – for each role user interface is customized (Fig. 3.1). 
Complete modeling is a combination of all the roles. The designer of the 
structures of the various materials combines the roles of prefabricated 
construction’s designer and designer of steel structures. 

The Tekla Structures program can be used in single user mode (single–user) 
or multi–user mode (multi–user). 

When over the model will work one user at the same time, the Tekla 
Software should be running in single–user mode. Then only one user can work 
on any model at the same time. 

When over the model will work several users at the same time, the Tekla 
Structures should be running in multi–user mode. Then any user can work on 
any model at the same time. To run the program in multi–user mode, one 
computer in the network must be set up as a server with running the server 
program of Tekla Structures. 
 
The main features of the program 
 Tekla Structures is a professional BIM environment that has the following 
features: 
 easy modeling the basic elements e.g. columns, beams, plates, 
 the possibility of drawing of 3D meshes and workspaces, which making 

easier to draw a model, 
 a wide range catalogs of profiles, class and bolts, 
 tools for modeling complex structures, 
 catalog of smart components, such as angle bracket, to create automatically 

elements’ connection, 
 catalog of user’s components, which user can use to create or edit own 

parametric connections, components and parts, 
 data transfer connection between Tekla and other software, 
 the program is available in many languages and is adapted to local standards 

and requirements. 
 
Toolbars 

Toolbars can be called from the menu Tools > Toolbars. Toolbars contain 
buttons to help user to access the most frequently performed operations in the 
program. They can be built along the edge of the software window or arranged 
freely on the screen through their offset (Fig. 3.2). 
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Fig. 3.2. The basic toolbars loaded default in the software 
 
Changing the language of the user’s interface 

In the program at any time, user can change the language of the user’s 
interface. There are languages that were selected during the installation of the 
program. To change the language:  
 click Tools > Change Language, 
 choose the needed language from the Language drop–down list, 
 click OK, 
 restart the Tekla Structures to make the change of language. 
 
Collaborate with other users on one model 

The program is adopted to one of the main determinants of BIM techniques – 
collaborate on a single project. The user working on the model can invite other 
users to cooperate according to the following instructions: 
 click File > Sharing > Start sharing, 
 when start sharing window open invite users option shows, by which you 

can add users who will be working on the same model (Fig. 3.3), 
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Fig. 3.3. Start sharing window 
 
Importing files from other application to Tekla Structures 

In the program there is a possibility of opening files from other applications 
with other extensions, such as: dwg/dfx, ascii, FEM, CIMSteel, CAD and others. 
This operation can be done by importing according to the following instructions 
– click File> Import> dwg/dfx etc. 
 
Exporting files from Tekla Structures to other applications 

In the program there is also the possibility of exporting models into other 
applications such as: IFC, 3D DWG/DXF, 3D DGN, Ascii, FEM, CIMSteel 
(Analysis Model or Design/manufacturing Model), CAD, Drawings, SketchUP. 
This operation can be performed according to the following instructions – click 
File > Export > IFC etc. 

 
Cooperation with other Tekla software 

In Tekla Structures is the ability to import files or sending to other Tekla 
software such as Tekla BIMsight – it is a professional tool for construction 
project collaboration. The entire construction workflow can combine their 
models, check for conflicts and share information using the same easy to use 
BIM environment. It enables project participants to identify and solve issues 
already in the design phase before construction [www.teklabimsight.com]. 

Main usage of Tekla BIMsight is the following: 
 one platform for all project members for live collaboration, 
 combine models from different disciplines into a single project model, 
 avoid conflicts on–site by running automated clash detection, 
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 share and communicate issues and other valuable information instantly. 
Tekla BIMsight is a construction collaboration tool that can be used in the 

office or on the construction site. Depending on your needs you can choose to 
use the full version of Tekla BIMsight or the Tekla BIMsight Note app for iOS 
or Android devices. 

This application has a well–designed user interface for Windows 7 and 
Windows 8 tablet computers. With mobile tablets and the touch user interface 
the full version of Tekla BIMsight can also be used at construction sites and on 
the move. 

BIM–based collaboration is available where you need it when you use Tekla 
BIMsight on a tablet computer. Tekla BIMsight helps crews on–site to interpret 
issues found during construction.  

You can also take part in BIM communication with your iPad, iPhone or 
Android device using Tekla BIMsight Note. It is a purpose–built tool for instant 
communication anywhere. You can receive and reply to notes created in Tekla 
BIMsight. Download the application from Apple App Store or Google Play for 
seamless BIM communication with your colleagues. 

It is possible to exchange data with the Tekla BIMsight software according to 
the following instructions (Fig. 3.4) – click File > Tekla BIMsight > Import 
from Tekla BIMsight… or Publish to Tekla BIMsight… 
 

 
 

Fig. 3.4. Interoperability with Tekla BIMsight 
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Fig. 3.5. Interoperability with Tekla Structural Designer 
 

Tekla Structural Designer – fully automated and packed with many unique 
features for optimized concrete and steel design, Tekla Structural Designer helps 
engineering businesses to win more work and maximize profits. From the quick 
comparison of alternative design schemes through to cost–effective change 
management and seamless BIM collaboration, Tekla Structural Designer can 
transform your business [www.tekla.com]. 

From scheme design all the way through to detailed design, one single model 
will cover all your structural analysis and design requirements, encompassing 
both gravity and lateral systems. 

With Tekla Structural Designer user can create physical, information-rich 
models that contain all the intelligence needed to fully automate the design and 
manage project changes. Achieve faster design times and maximize profitability. 
Full building wind loads are automatically calculated and applied to your model, 
saving your time on this task. And there is no need to worry about all the other 
lateral loading required by the design code because Tekla Structural Designer 
takes care of these. 
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Program automatically generates an underlying and highly sophisticated 
analytical model from the physical model, allowing you to concentrate on the 
design. 

The software incorporates a highly powerful Finite Element (FE) engine. 
Whether you are considering an irregular concrete flat plate with openings, or a 
complex core wall system, you can take advantage of fully automated FE 
meshing tools and fast analysis to explore their behavior. 

One software package covers seismic analysis and design. Response 
Spectrum Analysis (RSA) is fully automated, saving you time on this task. 

The software will instantly achieve an optimized design for all rebar within 
the beams, columns, slabs, flat plates and walls. Once designed, detailed 
reinforcement drawings and accurate material quantities are automatically 
generated for the whole building, meaning you can provide cost options early in 
the design process. 

The software will design all the steelwork automatically, based on the 
engineer’s specific requirements. This includes the detailed design and 
optimization of composite beams, columns, US joists, trusses, braces and plated 
sections. 

It is possible to exchange data with the Tekla Structural Designer software 
according to the following instructions (Fig. 3.5) – click File > Tekla Structural 
Designer> Import from… or Export to… 

3.2. Grids and views 
In Tekla Structures the grids are shown in a plane by using dashed lines. 

They serve as an aid in locating objects. In one model, user can create more than 
one mesh. 
Creating a grid 

After creation a new model, the program automatically generates a mesh and 
view. However, user can also create a grid manually by doing the following 
steps: 
 in the menu bar, choose Modeling > Create Grid; in this way Grid window 

appears on the screen (Fig. 3.6), 
 user can specify the coordinates of the beginning of the grid; default are set 

as X0, Y0, Z0 (0,0,0) 
 select X, Y, Z coordinates by putting spaces between axis e.g. in the X 

direction create 3 axis at equal intervals (0 3000 3000 or 0 2*3000), 
 introduce the grid labels (designation of individual axis are depicted in 

views), 
 to bind objects to gridlines, select the check box for Magnetic grid plane; this 

makes the objects on the grid lines will move along with the movement of the 
grid lines, 

 if necessary, user can modify the other properties of the grid, 
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 to approve the changes, click Create and then Close to exit the window’s 
view; a grid was created (Fig. 3.7). 

 
 

 
 

Fig. 3.6. Grid window 
 
Modification of generated grid 
 Each grid created can be freely modified by the designer: 
 to modify the grid, select Select grid switch in the bottom selection bar, 
 to enter in the Grid window in order to modify the properties of the grid, 

double-click any gridline or right–click and select Properties, 
 after entering changes they must be approved by clicking Modify. 
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Fig. 3.7. The XY view (left) and XZ view (right). 
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Modify and delete of a single grid line 
 Each grid line created can be modified individually: 
 to modify a single line select Select grid line switch in the bottom selection 

bar, 
 to enter in the Grid Line window (Fig. 3.8) in order to modify the properties 

of a selected line, double–click the grid line or right–click to select 
Properties, 

 after entering changes they must be approved by clicking Modify, 
 to remove a single line of the grid, user must select it, then click the right 

mouse button and choose Delete from the pop–up menu, 
 in Tekla Structures each view is displayed in a separate window; the view is a 

projection of a model created from the specified location. 
 

 
 

Fig. 3.8. Grid Line Properties window 
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Planes of the view 
Every view has a plane, on which grids are visible and the points presented 

are as yellow crosses. Points outside of a plane are marked in red. 
In basic views two axis always determine a plane of a view and make up its 
name, e.g. the XY plane. The third axis is perpendicular to the plane. In views of 
the planes, the model is shown from the direction of the third axis. 
 
Creating a basic view of a model 

When user create the model in addition to the 3D view (Fig. 3.9), user can 
switch the view between different view’s planes – XY, XZ (Fig. 3.10) and YZ, 
to go to each of the planes follow the steps listed below: 
 from the View menu select the Create View of Model and then Basic View, 
 from list the specific plane must be selected (Fig. 3.11), 
 user can enter the level of a plane (Coordinate); this value specifies the 

distance from the origin of the global coordinate system, 
 activities carried out should be approved by clicking Create. 
 

 
 

Fig. 3.9. 3D model view 
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Fig. 3.10. The XY plane (left) and XZ plane (right). 
 

 
 

Fig. 3.11. Creating a basic view of a model 
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View properties 
 The view properties can be modified by performing the following steps: 
 to open View Properties window (Fig. 3.12) double–click left mouse button 

anywhere on the view (apart from the elements) or right–click and select 
Properties, 

 after the modification of the specific properties the change must be approved 
by clicking OK or Modify. 

 
Switching between opened views 

When several views of a model are opened, it is possible to switch views in a 
three ways: 
 shortcut Ctrl+Tab, 
 in the Window menu, select the corresponding view, 
 click the right mouse buttonin the field of a view and list, then select Next 

Window. 
  
 

 
Fig. 3.12. View Properties window 
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3.3. Creating and basic operations on objects 
In Tekla Structures each produced item has properties that define it, e.g., 

material, profile and location. Each item is a separate "piece". They form 
a physical model. 
 
Selecting objects 
 There are several ways to select an object: 
 to select single object, click on it using left mouse button; to open its pop–up 

menu click right mouse button, 
 to select multiple objects at the same time, hold down the left mouse button 

and drag the mouse from left to right so that the objects were completely 
inside the rectangular area of selection; mouse can be also dragged from right 
to left – then the object may be only partially within the selection area, 

 if user select Tools > Options >Crossing selection, then all the objects even 
partially located within the rectangular selection area will be selected 
regardless of the direction of mouse dragging. 

 
Handles of items 

By using handles the direction of the element is indicated. To select the 
handles user must first select the item, and then select it again by dragging the 
mouse from left to right while holding down the Alt key. In Fig. 3.13 handles 
were shown. Handle of first point is marked in yellow, and the other in pink. 
 

 
 

Fig. 3.13. a) selected item, b) selected handles 
 
Modification of the object 

To modify an object, these steps should be followed: 
 select object, 
 modification is made through the properties window that can be showed by: 

double–click left mouse button on the object or right–click on object and 
select the Properties command from the pop–up menu, 
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 to change default parameters of element e.g. beam, column, even before 
drawing, it can be done by double–clicking on the toolbar, e.g. beam , 

 when changes are implemented, click Modify and exit from properties 
window. 

 
Deleting an object 

To delete an object follow the steps: 
 select the object that need to be removed, 
 to remove the object, do one of the following: Edit >Delete; right–click 

mouse button and select Delete from pop–up menu; press the Delete key. 
 
Moving an object 
 To move an object use procedure described below: 
 select object to be moved, 
 to move the selected object, user must perform one of the following: Edit 

>Move; Ctrl+M; right mouse button > select Move from pop–up menu, 
 select a reference point on the object, relative to which the offset occurs 

(Fig. 3.14a), 
 select the destination point in which the selected object will be moved 

(Fig. 3.14b), 
 after made actions program will move the selected objects. 
 

 
 

Fig. 3.14. Moving objects: a) the selected object to be moved with a reference point, b) 
specified destination point 

Copying an object 
To copy an object, these steps should be followed: 

 select object to be copied, 
 to copy the selected object, user must perform one of the following: Edit 

>Copy; Ctrl+C; right mouse button > select Copy from pop–up menu, 
 select a reference point on the object, relative to which the copying occurs 

(Fig. 3.15a), 
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 select one or more destination points in which the selected objects will be 
copied (Fig. 3.15b), 

 after made actions program will copy the selected objects. 
 

 
 

Fig. 3.15. Copying objects: a) the selected object to be copied with a reference point, b) 
copied object with indicated destination point 

 

 
 

Fig. 3.16. Linear moving of objects: object selected to move with the offset coordinate (left); 
designated target point to move the object (right) 
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To undo the last copy operation, click Edit > Undo, or shortcut Ctr+Z, to 
stop copying click Edit > Interrupt, or press Esc. User can also abort copying by 
clicking right mouse button and choose Interrupt from pop–up menu. 
 
Linear copying or moving an object 
 Copying or moving an object can be done in a linear way: 
 select object to be copied or moved, 
 to linear move or copy the selected objects, user must perform one of the 

following: Edit > Copy Special > Linear or Edit > Move Special > Linear; 
right mouse button >Copy Special > Linear or Move Special > Linear from 
pop–up menu, 

 then linear copy or move window opens, 
 select two points in the model, which will create copying vector or enter 

coordinates into the linear copy window in fields dX, dY and dZ, 
 then enter the number of object copies, 
 after entering data, click Copy, 
 described procedure is shown in Fig. 3.16.  
 
Rotating an object 

In the program it is possible to copy or move an object with rotation around 
the line on working plane or in the Z direction of the plane. A positive turn is 
compatible in the direction of clockwise, looking from the beginning of the 
rotation axis. 
 
Rotating an object on the line 
 Objects can be rotated on the line. To do this follow the steps: 
 select object to be copied or moved, 
 to copy and rotate objects, click Edit > Copy Special > Rotate, 
 to move and rotate objects, click Edit > Move Special > Rotate, 
 copy or move with rotation window opens, 
 from the Around drop–down list select Line, 
 select a start and end point of rotation line or enter their coordinates, 
 in the case of copy, type the number of object copies, 
 enter a rotation angle, 
 after entering data click Copy or Move, 
 after these commands, the program will copy or move selected objects, 
 described procedure is shown in Fig. 3.17. 
 
Rotating an object in the Z direction 
 Objects can be rotated in the Z direction using the procedure: 
 proceed as in the case of rotating on the line but from the Around list select Z, 
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 select a point in which will be a rotation axis, 
 next steps are the same as in the case of rotating on the line, 
 described procedure is shown in Fig. 3.18. 
 

 
 

Fig. 3.17. Rotating an object on the line: object selected to copy with the rotation line (left); 
object copied to the specified angle (right) 

 

 
 

Fig. 3.18. Rotating an object in the Z direction: object selected to copy with the point of 
rotation axis (left); object copied to the specified angle (right) 
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3.4. Creating steel elements 
Among the steel elements, can be created: 

 column, 
 beam, 
 polybeam, 
 curved beam, 
 contour plate, 
 twin profile. 

These elements can be created by clicking: Modeling > Create SteelPart or 
select an icon from the toolbar – shown in Fig. 3.19. 
 

 
 

Fig. 3.19. Creation of steel elements –choose the type of the element by using the toolbar and 
menu commands 

 
Steel column 
 To create a steel column follow the steps: 
 Modeling > Create Steel Part > Column or click , 
 specify the insertion point on the screen, 
 to change the properties of the column double–click on element – Fig. 3.20. 
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Steel beam 
 To create a steel beam use the instructions below: 
 Modeling > Create Steel Part > Beam or click , 
 select two points on the screen; the program creates steel beam between these 

points, 
 to change the properties of the beam double–click on element – Fig. 3.21. 
 

 
 

Fig. 3.20. Steel column and its properties window 
 

 
 

Fig. 3.21. Steel beam and its properties window 
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Steel polybeam 
To create a steel polybeam follow the steps: 

 Modeling > Create Steel Part > Polybeam or click , 
 select points through which the element will run, 
 to complete the selection, click the middle mouse button; the program creates 

polybeam between the selected points, 
 to change the properties of the polybeam double–click on element – 

Fig. 3.22, 
 to create a curved segments of the polybeam its corners must be chamfered – 

to do this, select the element, double–click the handle of any polybeam’s 
corner, and then in the Chamfer Properties window change the chamfer’s 
properties (shape and size of chamfer) – Fig. 3.23. 

 

 
 

Fig. 3.22. Steel polybeam and its properties window 
 
Steel curved beam 

To create a steel curved beam use the instructions below: 
 Modeling > Create Steel Part > Curved beam or click , 
 select start point (1), 
 select point on the curve (2), 
 select end point (3), 
 program creates curved beam between the selected points, 
 to change the properties of the curved beam double–click on element – 

Fig. 3.24. 
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Fig. 3.23. Chamfering of steel polybeam’s corner 
 

 
 

Fig. 3.24. Steel curved beam and its properties window 
 
Steel contour plate 
 A steel contour plate can be done as a result of the procedure described: 
 Modeling > Create Steel Part > Contour plate or click , 
 select corner points; to end the selection, click the middle mouse button, 
 program will create the contour plate between the selected points, 
 to change the properties of the contour plate double–click on element – 

Fig. 3.25. 
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Fig. 3.25. Steel contour plate and its properties window 
 
Steel twin profile 

Twin profile consists of two identical beams. User must specify the positions 
of the two beams by choosing the profile type and set the space between those 
beams in both directions. To do this follow the steps: 
 Modeling > Create Steel Part > Twin profile, 
 select two points; program will create twin beam between two selected 

points, 
 to change the properties of the twin profile double–click on element – 

Fig. 3.26. 
 

 
 

Fig. 3.26. Steel twin profile and its properties window 
Steel connections from components 
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A convenient way to make steel connections in Tekla Structures is the use of 
the components’ library. One of the collections is a catalog of connections for 
steel elements. Each connection type is editable – the program allows to 
adjusting selected connection to the specifics of assembled items. To open the 
catalog of steel components click Detailing > Component > Component Catalog 
(Ctrl+F). The following are described the most commonly used components to 
create a steel connections, welded and longitudinal connections. 
 
Connections by angles and screws 

Fig. 3.27 shows the components of steel connections’ window and selected 
type of connection – the connection by angles. There are 16 ways to connect two 
or more steel parts by angles and by screws in a single node. 
 

 
 

Fig. 3.27. Catalog of components to create a steel connections by angles 
Clip angle (116) 

The Clip angle component connects a beam to a beam or a column with 
a clip angle and can be performed using procedure described: 
 open Component catalog (Ctrl+F), 
 select by one–click Clip angle (116) component, 
 select two connected elements in the model; in the first place – main element 

(1), then the element that will be connected (2) – usually smaller of two 
elements (Fig. 3.28), 

 program after selection of these elements automatically generates the selected 
connection, which can by edited by clicking on it twice. 
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Fig. 3.28. Clip angle connection of two HEB–beams (left) and two Z–beams (right) 
 

Use the Picture tab (Fig. 3.29) to control the clip angle’s dimensions and the 
clip angle’s position in the Clip angle (116) connection. Number 1 marked on 
Fig. 3.29 edits the dimensions of created connection. The following dimensions 
can be edited: 
 the cut length for the secondary part, 
 the clip angle upper edge distance from the top of the secondary beam, 
 the clip angle lower edge distance from the bottom of the secondary beam, 
 the gap between the main part and the clip angle, 
 the height of the clip angle. 

Number 2 marked on Fig. 3.29 defines the position of the clip angle. One of 
the following can be selected: 
 near and far side clip angles are created, 
 near side clip angle is created, 
 far side clip angle is created. 
 

Use the Bolts tab (Fig. 3.30) to control the bolt properties in the Clip angle 
(116) connection. The vertical position of bolts in the main part must be aligned 
with the vertical position of bolts in the secondary part. Vertical bolts cannot be 
staggered. Number 1 marked on Fig. 3.30 edits the dimensions of the bolt 
groups. The following dimensions or values can be edited: 
 the dimension for vertical bolt group position, 
 the bolt edge distance; edge distance is the distance from the center of a bolt 

to the edge of the part, 
 the number of bolts, 
 the bolt spacing; use a space to separate bolt’s spacing values; enter a value 

for each space between bolts; e.g. if there are 3 bolts, enter 2 values. 
The schema marked as 2 is used to select the locations of the bolts’ group 

(Fig. 3.30). The schema marked as 3 edits the deployment of a bolts’ group in 
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a perpendicular direction to those in schema marked as 1. It is possible to edit 
the following dimensions or values: 
 the bolt’s edge distance, 
 the location where the bolts should be attached, 
 the number of bolts, 
 the bolt’s spacing; use a space to separate bolt’s spacing values; enter a value 

for each space between bolts; e.g. if there are 3 bolts, enter 2 values. 
The schema marked as 4a is used to select the components that will be used 

to mount bolts (pads, bolts, caps). If you want to create a hole only, clear all the 
check boxes. The schema marked as 4b defines the length of the bolts 
(Fig. 3.30). 
 

 
 

Fig. 3.29. Clip angle properties window – Picture tab 
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Fig. 3.30. Clip angle properties window –Bolts tab 
 
Welded connections 

Fig. 3.31 shows the components of steel connections’ window and selected 
type of connection – the connection by angles. There are 10 ways to connect two 
or more steel parts by welds. 
 

 
 

Fig. 3.31. Catalog of components to create welded connections 
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Weld preparation (44) 
It connects two beams of I–profile with welds. User can shape the secondary 

beam end with rat holes and other weld preparations. The only allowed beam 
profile is I–profile. In order to execute the connection do the following steps: 
 perform two beams and determine which of them is main and secondary, 
 call the components directory window by shortcut Ctrl+F, 
 select by one click Weld preparation (44) component, 
 select two connected elements in the model; in the first place – main element 

(1), then the element that will be connected (2) – usually smaller of two 
components(Fig. 3.32 left), 

 program after selection of these elements automatically generates the selected 
connection, which can by edited by clicking on in twice. 
Use Picture tab to define the geometry of Weld preparation (44) 

connection (Fig. 3.32 right). 
 
Longitudinal connections 

Fig. 3.33 shows the components of steel connections’ window and selected 
type of connection – the longitudinal connections. There are 14 ways to connect 
two steel parts in longitudinal direction by angles, flat bars and screws. 
 
Splice Type 1 (56) 
 To create a Splice Type 1 follow the steps: 
 perform two beams, which will be connected, 
 call the components directory window by shortcut Ctrl+F, 
 select by one click Splice Type I (56) component, 
 select two connected elements in the model, 
 program after selection of these elements automatically generates the selected 

connection, which can by edited by clicking on in twice (Fig. 3.34). 
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Fig. 3.32. Weld preparation component sample (left); Weld preparation properties window –
Picture tab (right) 

 

 
 

Fig. 3.33. Catalog of components to create a longitudinal connections. 
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Fig. 3.34. Longitudinal connection of two beams – Splice Type 1 (56) component 
 

 
 

Fig. 3.35. Splice Type I properties window – Picture tab 
 
After double–click on a connection, the connection properties window opens, 

in which by tabs its geometry and other data can be edited. Use Picture tab to 
define the geometry of Splice Type 1 (56) connection (Fig. 3.35). In this tab the 
distance between connected elements can be edited.  

In order to determine the exact number of bolts and their deployment on the 
side of the first of the connected elements user must select the Bolts tab (Fig. 
3.36 left), while edition of connection on the second element can be made by 
Sbolts tab (Fig. 3.36 right). 
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Fig. 3.36. Splice Type I properties window – Bolts and SBolts tabs 

3.5. Manual creating steel connections 
Creation of bolts 

To create a group of bolts follow the instruction: 
 click Detailing > Bolts>Create Bolts, 
 select the main element in which the secondary elements will be bolted 

(Fig. 3.37a – 1), 
 select secondary elements (Fig. 3.37a –2), 
 click the middle mouse button to finish selecting elements, 
 select the start point of bolts’ group and the second point in order to 

determine the X direction of bolts’ group (Fig. 3.37a – 3), 
 program after completing above steps automatically create a connection 

(Fig. 3.37b). 
By double–clicking on a bolts, the bolts properties’ window shows  

(Fig. 3.38). In this window it is possible to determine the location of bolts  
(Fig. 3.38 – 1) as well as the amount of rows and columns of the bolts and the 
distance between them (Fig. 2.38 – 4). The shape of the bolt also can be chosen 
(Fig. 3.38 – 3). 

To create a single bolt follow the instructions: 
 click Detailing>Properties>Bolts to open bolts properties window 

(Fig. 3.38), 
 in Bolt Group section select Array from Shape drop–down menu  

(Fig. 3.38 – 3), 
 in fields Bolt dist X and Bolt dist Y type 0 (Fig. 3.38 – 4), 
 click Apply to save changes, 
 follow by instructions of bolts group creation. 
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Fig. 3.37. Connection of two elements by manually created bolts’ group: a) the order of 
selection; b) made connection 

 
Creation of holes 

To create a round hole follow the instructions: 
 click Detailing>Properties>Bolts to open bolts properties’ window, 
 uncheck the check boxes contained in Bolt group (in case if user do not want 

to create any bolts – Fig. 3.38 – 2), 
 optional: change the properties of hole in Hole (Fig. 3.38 – 6);this field is 

editable only when fields in Parts with slotted holes are checked  
(Fig. 3.38 – 5), 

 click Apply to save changes, 
 follow by instructions of bolts group creation to create a hole. 
 



123 

 
 

Fig. 3.38. Bolt Properties window 
 

To create oversized hole follow the instructions: 
 click Detailing>Properties>Bolts, to open bolts properties’ window, 
 select the appropriate check boxes in Parts with slotted holes to determine 

which connection layers will have the oversized holes, 
 uncheck the check boxes contained in Bolt group (in case if user do not want 

to create any bolts – Fig. 3.38 – 2), 
 in Hole Type drop–down menu select Oversized (Fig. 3.39), 
 type surplus for oversized hole in Oversize field; values can be also negative, 

which would create smaller holes, 
 click Apply to save changes, 
 follow by instructions of bolts’ group creation to create a hole. 
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Fig. 3.39. Data edition related to oversized holes (bolts properties window) 
 

 
 

Fig. 3.40. Data edition related to slotted holes (bolts properties’ window) 
 

To create slotted hole follow the instructions: 
 click Detailing > Properties > Bolts, to open bolts properties window, 
 to determine which elements have to be longitudinal, select desired check 

boxes in Parts with slotted holes (Fig. 3.40), 
 uncheck the check boxes contained in Bolt group (in case if user do not want 

to create any bolts), 
 in Hole Type drop–down menu select Slotted, 
 type surplus for slotted hole in X and Y directions using Slotted hole X and 

Slotted hole Y fields, 
 in Rotate Slots drop–down menu select Odd or Even to rotate alternate holes 

by 90 degrees, 
 click Apply to save changes, 
 follow by instructions of bolts’ group creation to create a hole. 
 
Creation of welded connections 

To set the visibility and appearance of the welds follow the instructions: 
 open View Properties window by double–click on plane, 
 click Display to open Display window (Fig. 3.41), 
 make sure that Welds field is checked, 
 choose the option of welds’ presentation: Fast (Fig. 3.42a) – option allows to 

show only a weld symbol; Exact (Fig. 3.42b) – option allows to show a solid 
weld; make sure that the plane is selected and click Modify to save changes. 
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To weld together the elements follow by instruction: 
 click Detailing>Welds>Create Welds between parts, 
 select the element for welding – in case of workshop welding it is the main 

element of the assembly, marked as 1 in Fig. 3.43 – left, 
 select the element for welding – in case of workshop welding it is the 

secondary element of the assembly, marked as 2 in Fig. 3.43 – left, 
 the program automatically creates the weld after performing the steps above. 
 

 
 

Fig. 3.41. Window enabling to set the visibility of various object types – in this case welds 
visibility 

 

 
 

Fig. 3.42. Weld’s visibility: a) Fast b) Exact 
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To weld the elements using the polygon weld follow the instructions: 
 click Detailing>Welds>Create Polygon Welds, 
 select the element for welding – in case of workshop welding it is the main 

element of the assembly, marked as 1 in Fig. 3.43 – right, 
 select the element for welding – in case of workshop welding it is the 

secondary element of the assembly, marked as 2 in Fig. 3.43 – right, 
 select a start and end point or alternatively select points through which the 

weld will be moved, 
 click the middle mouse button to create the weld. 

 
To create weld to part follow the instructions: 

 click Detailing>Welds>Create Welds to Parts, 
 select the element to weld (Fig. 3.44a), 
 select a start and end point or alternatively select points through which the 

weld will be moved, 
 click the middle mouse button to create the weld (Fig. 3.44b). 
 
Preparation of weld 

After completing the elements for welding, their edges must be prepared – 
cut suitably to create a place to weld. The angle of a cut can be specified. It is 
possible in the program to manual prepare the element for welding by cutting in 
it polygon shape. Working plane should be placed in cutting plane. To manual 
prepare the element for welding follow the instructions: 
 click Detailing>Welds>Prepare Part for Welding > With Polygon, 
 select the element that will be cut, marked as 1 (Fig. 3.45a), 
 select position to draw a polygon used to cut; polygon should be extended to 

the outside of the element to select the edge to be cut off; cutting line in the 
form of point–dashed line marked as 2 (Fig. 3.45b), 

 click the middle mouse button to close the polygon and cut the element. 
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Fig. 3.43. The weld between components (left) and polygon weld (right) 
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Fig. 3.44. Weld to part: a) SPD profile (pipe sections); b) welded stitch in the SPD profile 
 

 
 

Fig. 3.45. Preparation of the element for welding using the polygon: a) before cut b) after 
polygon cut 

 
It is possible in the program to manual preparation of element for welding by 

cutting shape in it using another element. Cutting element will be removed. 
Before preparing an element for welding the cutting element must be created and 
put it to cut the main element. To manually prepare the element for welding 
follow the instructions: 
 click Detailing>Welds>Prepare Part for Welding > With Another Part, 
 select the element that will be cut, 
 select cutting element (Fig. 3.46a –1), 
 the program automatically creates a cut after performing the steps above 

(Fig. 3.46b –2). 
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After making the weld it is possible to edit geometry and other visual 
parameters in Weld Properties window (Fig. 3.47). To open that window 
double–click on the selected weld. The other way is to click Detailing > 
Properties > Weld. In the window user can choose type of weld and size of it on 
both sides of connected steel elements. 
 

 
 

Fig. 3.46. Preparation of the element for welding with other element: a) inserted cutting 
element (1); cut made by cutting element (2) 

 
It is possible in the program to manual preparation of element for welding by 

cutting shape in it using another element. Cutting element will be removed. 
Before preparing an element for welding the cutting element must be created and 
put it to cut the main element. To manually prepare the element for welding 
follow the instructions: 
 click Detailing>Welds>Prepare Part for Welding > With Another Part, 
 select the element that will be cut, 
 select cutting element (Fig. 3.46a –1), 
 the program automatically creates a cut after performing the steps above 

(Fig. 3.46b –2). 
After making the weld it is possible to edit geometry and other visual 

parameters in Weld Properties window (Fig. 3.47). To open that window 
double–click on the selected weld. The other way is to click Detailing > 
Properties > Weld. In the window user can choose type of weld and size of it on 
both sides of connected steel elements. 
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Fig. 3.47. Weld Properties window 
 

3.6. Creating concrete elements 
Among the concrete elements, can be created: 

 pad footing, 
 strip footing, 
 column, 
 beam, 
 polybeam, 
 slab, 
 panel. 

These elements can be created by clicking: Modeling > Create Concrete Part 
or select an icon from the toolbar – shown in Fig. 3.48. 
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Fig. 3.48. The creation of concrete elements –choose the type of the element by using the tool 
pane and menu commands 

 
Pad footing 
 To create a pad footing follow the steps: 
 click Modeling > Create Concrete Part > Pad Footing or click , 
 specify the insertion point on the screen, 
 to change the properties of the pad footing double–click on element – 

Fig. 3.49, 
 

 
 

Fig. 3.49. Pad footing and its properties window 
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Strip footing 
To create a strip footing follow the instructions: 

 click Modeling > Create Concrete Part > Strip footing or click , 
 specify on screen points through which strip footing will pass, in order to 

complete points determination click the middle mouse button, 
 to change the properties of the strip footing double–click on element – 

Fig. 3.50, 
 to create a curved segments of the strip footing its corners must be chamfered 

– to do this, select the element, double–click the handle of any strip footing 
corner, and then in the Chamfer Properties window change the chamfer’s 
properties (shape and size of chamfer) – Fig. 3.51. 

 

 
 

Fig. 3.50. Strip footing and its properties window 
 

     
 

Fig. 3.51. Chamfering of strip footing’s corner 
 
Concrete column 

To create a concrete column follow the steps: 
 click Modeling > Create Concrete Part > Column or click , 
 specify the insertion point on the screen, 
 to change the properties of the column double–click on element – Fig. 3.52. 
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Fig. 3.52. Concrete column and its properties window 
 
Concrete beam 

To create a concrete beam follow the instructions: 
 click Modeling > Create Concrete Part > Beam or click , 
 specify on screen start and end point of a beam, 
 to change the properties of the beam double–click on element – Fig. 3.53. 
 

 
 

Fig. 3.53. Concrete beam and its properties window 
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Concrete polybeam 
To create a concrete polybeam follow the steps: 

 click Modeling > Create Concrete Part > Polybeam or click , 
 specify on screen points through which polybeam will pass, in order to 

complete points determination click the middle mouse button, 
 to create a curved segments of the polybeam its corners must be chamfered in 

the same way as for strip footing, 
 to change the properties of the polybeam double–click on element – 

Fig. 3.54. 
 

 
 

Fig. 3.54. Polybeam with chamfered corner and its properties window 
 
Concrete slab 

To create a concrete slab follow the instructions: 
 click Modeling > Create Concrete Part > Slab or click , 
 specify on screen corner points of the slab, 
 to change the properties of the slab double–click on element, 
 in order to create a rounded slab, firstly square slab must be created and then 

all its corners must be chamfered by using a circular shape and chamfer 
radius accepted as equal to half the length of a square side – Fig. 3.55. 

 

 
  

Fig. 3.55. Square and rounded concrete slab and its properties window 
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Concrete panel 
To create a concrete panel follow the steps: 

 click Modeling > Create Concrete Part > Panel or click , 
 specify on screen points through which panel/wall will pass, in order to 

complete points determination click the middle mouse button, 
 to create a curved segments of the panel its corners must be chamfered in the 

same way as for strip footing, 
 to change the properties of the panel double–click on element – Fig. 3.56. 

The Properties window for all of the above elements contains similar 
properties, which can be edited, the following are the main ones: 
 Name – user–defined element name, Tekla Structures uses this name in the 

reports, drawings, and to identify elements of the same type, 
 Profile – dimensions, the cross section of the designed element (there is 

a catalog of profiles, with which you can create e.g. t–beam), 
 Material – the material from which the element is made, 
 Finish – the type of surface finish, describes in what way the element surface 

was finished, e.g. paint, fire resistant coating, waterproof cover, etc., 
 Class – used to group items, they can be displayed in different colors 

depending on the class, 
 User–defined attributes – provide additional information about the item, 

these attributes can contain numbers, text, 
 Position – specifies the rotation of the element relative to its axis on the 

plane, vertical and horizontal position – dependent on the handlers of 
element, 

 Levels – specifies the position of the upper and lower surface of the element 
in a global z axis, 

 Prefix and Start number – specifies a series of element formwork, 
 Cast unit type – specifies whether the item is prefabricated or cast in place. 
 

 
 

Fig. 3.56. Concrete panel/wall and its properties window 



136 

3.7. Creating reinforcement 
The most comfortable way to make reinforcement in concrete elements is by 

using the built in Tekla components. Predefined components are fully editable, 
and allow for the creation of reinforcement in any concrete element. To open the 
reinforcement components’ catalog (Fig. 3.57) click Detailing > Component > 
Component Catalog (Ctrl+F). The following are described the most commonly 
used components to create a reinforcement in reinforced concrete elements. 

 

 
 

Fig. 3.57. Catalog of components to create a reinforcement 
 
Pilecap reinforcement (76) 
 Component is used to create reinforcement in pilecap, however, it can be 
successfully used for pad footing. Created are: bars in two directions for the top 
and bottom surfaces of the pile cap, lacer bars. In the various properties tabs 
(Fig. 3.58) attributes can be edited: 
 Picture – concrete cover thickness, primary bar direction, 
 Primary top bars/Secondary top bars/Primary bottom bars/Secondary bottom 

bars – grade, size, hooks, bend lengths, distribution (by number or spacing), 
and arrangement/location of the top and bottom bars in two directions, 

 Lacer bars – option to create lacer bars, grade, size, number, spacing, 
location, type, orientation, and laps of lacer bars, 

 Attributes – numbering properties, name, and class of the top, bottom, and 
lacer bars. 
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Fig. 3.58. Properties window of pilecap reinforcement component 
 

Before using component pad footing must be already made. In order to 
proper execution of component, firstly pad footing must be selected, then 
adjacent piles to it or column (if any) and to approve click the middle mouse 
button. 
 
Beam reinforcement (63) 

Component is used to create reinforcement in square concrete beams, L–
shaped beams (RCL profiles), RCX profiles, inverted T–beams (RCDL profiles). 
Created are: longitudinal main bars, corner and side bars, main stirrups, stirrups 
for one or two ledges. In the various properties tabs (Fig. 3.59) attributes can be 
edited: 
 Parameters – concrete cover thickness, number, size, and location of bars, 

stirrup size, option to place main bars only inside the main stirrups or 
distributed to the ledges, 

 Stirrup spacing – distances from the part ends to the first stirrups, number of 
spaces and spacing of main and ledge stirrups in five zones along the length 
of the part, option to create different stirrups in two ledges, ledge stirrup 
spacing method, 

 Advanced – grade, name, class, and numbering properties of the bottom, top, 
and side bars, and main and ledge stirrups. 
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Fig. 3.59. Properties window of beam reinforcement component 
 

Before using component concrete beam must be already made, at any shape. 
In order to proper execution of component concrete beam must be selected. 
 
Rectangular column reinforcement (83) 
 Component is used to create reinforcement in square or rectangle concrete 
column. Similarly, reinforcement of column with circular cross–section can be 
created – Round column reinforcement (82). Created are: longitudinal main bars 
(corner and side bars), stirrups, intermediate links, column end reinforcement. In 
the various properties tabs (Fig. 3.60) attributes can be edited: 
 Main bars – concrete cover thickness, corner bar properties (the symmetry 

options, rotation, size, grade), 
 Bar ends – length of the vertical and horizontal extensions for the corner and 

side bars at the top and bottom of the column, cranking options, 
 Side bars – number of side bars, their spacing and placing, symmetry options, 

side bar properties (grade, size, class, bending radius, name, prefix, start 
number), 

 Stirrups – stirrup dimensions, bar lapping at stirrup corners, other properties 
(similar like in beam reinforcement), 

 Intermediate links – main properties, spacing, link type, link pattern, hook 
orientation, zone; used in case when rectangular columns have very large 
cross sections, the side bars may be a far from the corners of the stirrups; you 
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will need to create intermediate links to tie all side bars, and to prevent them 
from buckling when they are in compression, 

 Top/Bottom – top and bottom reinforcement thickness of concrete cover, 
number of bars and their spacing, rotation. 
Before using component square or rectangular concrete column must be 

already made. In order to proper execution of component concrete column must 
be selected. 
 

 
 

Fig. 3.60. Properties window of rectangular column reinforcement component 
 
Slab bars (18) 

Component is used to create reinforcement in concrete slab, at any shape. 
Created are: primary slab bars, crossing slab bars. Alternatively the Mesh Bars 
and the Mesh Bars by Area components can be used to create reinforcement in 
concrete slab walls or panels. In the various properties tabs (Fig. 3.61) attributes 
can be edited: 
 Picture – concrete cover thickness, which bars to create (bottom/top/both), 

primary bar direction, which sides are regarded as top and bottom sides, 
 Bottom bars/Top bars – grade, size, spacing, and generation type of bottom 

bars, concrete cover thickness on slab sides, crossing bar location in relation 
to primary bars, end hooks and bend lengths, 

 Attributes – numbering properties, name, and class of bars 
Before using component concrete slab must be already made. In order to 

proper execution of component concrete slab must be selected. 
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 Fig. 3.61. Properties window of slab bars component 
 
Hole reinforcement for slabs and walls (84) 

Component is used to create holes in concrete walls/slabs and the 
concomitant reinforcement of these holes. Created are: straight bars along hole 
edges, diagonal bars close to hole corners, u–shaped edge bars. In the various 
properties tabs (Fig. 3.62) attributes can be edited: 
 Picture – shape of the hole (rectangular or round), hole dimensions, bar 

dimensions and location, concrete cover thickness, rotation angle of the hole, 
 Horizontal and vertical bars – which bars are closest to the surface of the 

concrete (vertical or horizontal), number, grade, size, numbering properties, 
name, and class of each bar group along the sides of the hole, 

 Edge bars – spacing, grade, size, numbering properties, name, and class of 
bar group on each side, 

 Diagonal bars – number, grade, size, numbering properties, name, and class 
of bar group at each corner of the hole. 
Before using component concrete slab or wall panel must be already made. In 

order to proper execution of component the center of the hole must be selected, 
then concrete slab or wall. 

 
 

Fig. 3.62. Properties window of hole reinforcement for slabs and walls component 
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Edge and corner (62) 
Component is used to create reinforcement on edges and corners of concrete 

wall panels and slabs. You can reinforce solid or sandwich precast concrete 
panels, or vertical and horizontal lcast–in–situ slabs. This component do not 
create the main bars. In the various properties tabs (Fig. 3.63) attributes can be 
edited: 
 Picture – control the edge and corner reinforcement, the cutouts, and the 

corner cutouts, 
 Edge/Diag bars – control the edge and diagonal bar properties, reinforcing 

bar overlapping, concrete cover thickness, 
 Horizontal/Vertical U bars – control the U bar leg length, concrete cover 

thickness and reinforcing bar properties, spacing. 
Before using component concrete slab or wall panel must be already made. In 

order to proper execution of component the concrete slab or wall panel must be 
selected.  
 
Manual creation of reinforcement 

Reinforcement of concrete elements may also be performed manually. Bars 
can be created by clicking Detailing > Create Reinforcement > Reinforcing Bar 

/Reinforcing Bar Group /Reinforcement Mesh  (Fig. 3.64). 
To create the reinforcing bar the concrete element must be selected, in which 

the bar will be created. Then select on the screen (preferably on the edges of the 
beam) the shape of the reinforcing bar. Next – select the range, in which the bar 
or bar group will be created and approve by clicking the middle mouse button. In 
the various properties tabs (Fig. 3.65) attributes can be edited: 
 General – information about reinforcing bar (prefix, name, size, grade, 

bending ratio, class), hook dimensions and shape, concrete cover thickness, 
 Group – creation method (equal distribution by number of reinforcing bars, 

equal distribution by target spacing value, by exact spacing value with 
flexible first space, by exact spacing value with flexible last space, by exact 
spacing value with flexible middle space, by exact spacing value with 
flexible first and last space, by exact spacing). 
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Fig. 3.63. Properties window of edge and corner component 
 

 
 

Fig. 3.64. Manual creation of reinforcing bars – choose the proper command by using the 
tool pane and menu commands 
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Fig. 3.65. Properties window of reinforcing bar created manually 
 

3.8. Model control 
Model control is an activity aimed at the analysis of the model for the 

presence of collisions and errors in it. The analysis can be made by using several 
tools, described below. 
 
Object properties 

The Properties window of any object opens by selecting from the menu bar: 
Tools > Inquire > Object. When the user selects an interesting object a separate 
window properties in the form of a report displays (Fig. 3.66). Reports are 
created from the default templates included in the program, user can also create 
own reports. 
 
Custom inquiry 

Tool custom inquiry starts by selecting from the menu bar: Tools > Inquiry > 
Custom Inquiry. After selecting a default window appears with the data 
concerning the area, weight and length of the selected item. However, it is 
possible to define individual properties of the object that should be displayed. To 
do this in the Custom Inquiry window click on Manage contents. In the new 
window on the Attributes list all the available attributes are shown. To change 
the default attributes the user must edit the Inquiry Tool. config file in Tekla 
Structures main directory. Editing of the new attributes can be obtained by 
clicking the Add button, change of the already calculated attributes through the 
Edit button. Inquire Tool file is used to manually edit the default properties of 
the attributes to display in the Custom Inquiry in a text file. 
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Fig. 3.66. Inquire Object window 
 
Measuring objects 

Measuring function includes a number of commands that can be used to 
measure: 
 Distance – command used to measure the distance in the horizontal, vertical 

direction and distance defined by the user, 
 Angle – by selecting central, start and end point of angle, which user select on 

the model, 
 Arc – in this case user must select start, middle and end point of arc, 
 Bolt spacing – a tool used to measure the distance between the bolts in the 

bolts’ group, in addition it is possible to display the distance between the 
bolts and edge, e.g. plate. 
Mentioned above commands start by selecting from the menu bar: Tools > 

Measure > Distance/Angle/Arc/Bolt spacing – depending on the required 
function. 
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Clash control 
Clash Check Manager utility is used to locate the conflicts between the 

different elements, objects and connectors. If two items come into contact with 
each other but are not permanently linked, they are not covered by the procedure 
of clash finding. To check the model in order to find a clashes do following 
steps: 
 Click Tools>Clash Check Manager, 
 select on the model elements that have to be inspected – after inspection 

window with a list of found clashes appears, 
 by selecting the appropriate row in the window, user can specify exactly what 

elements are present in a clash; after modifications and changes Clash Check 
Manager runs again in order to verify the presence of further possible 
collisions. 

 
Mark Signification Descritpion 
(none) Active The default state – clashes are not new, modified, 

resolved, missing 

 

New All found clashes are marked with this mark when they are 
found for the first time 

 

Modified If the object has been modified (for example, if the profile 
has been changed), the state changes to modified when 
you re – run the clash check. 
Only certain object properties affect this flag. To see 
which properties have an effect, right–click one of the 
column headings. Both visible and hidden properties affect 
the flag. 

 

Resolved If the objects no longer clash, the state changes to resolved 
when you re–run the clash check. 

 

Missing If one or both of the clashing objects have been removed 
from the model, the state changes to missing when you re–
run the clash check. 

 
Tab. 3.1. Description of the flags used in Clash Check Manager [Tekla Structures – Manual] 
 

Management of clashes control’s outcomes includes: 
 interpretation of the symbols (Tab. 3.1) contained in the Clash Check 

Manager – manage a list of clashes – changing the sort order of the results of 
the checks, select several rows in the list, show or hide columns, 

 searching for a clash, 
 change the status of a clash – function used to change the status of a conflict 

in the model, 
 change the priority of a clash, 
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 grouping clashes – a number of features used to organize the collisions, 
selecting priorities, combination and separation of clashes, 

 view the details of the clash,  
 adding comments – function used to save notes and references concern the 

clash or their group, 
 the history of the clashes – a tool used to check where clashes appeared and 

which user solve conflict, 
 printing clash list – clash list could be printed in form of additional report to 

the entire project; templates allow to specify which information should be 
placed in a print, 

 opening and saving clash check sessions. 
 
Diagnosis and repair of the model 

This is a very useful function used to model diagnosis and its repair in case of 
errors, irregularities, removing unnecessary elements, empty units, unused 
references and objects, setting the specified hierarchy of elements. It is a tool 
which use is recommended as one of the primary methods of the model control. 
It is run by clicking Tools > Diagnose & Repair Model. If the program finds an 
irregularity, report is displayed with a list of errors. Part of the errors may 
require to be manually removed from the model. 
 
Comparing elements or assemblies 

Comparison of two or more elements (in the model or assembly) in terms of 
the correctness. Select compared elements and use Tools > Compare. The results 
of the analysis are displayed in the status bar. 
 
Finding a distant objects 

The tool is very helpful if user is working on a large model, in which there 
are difficulties in finding elements. To find an object use a command Tools > 
Diagnose & Repair Model > Find Distant Objects. Object list appears with the 
ID numbers. An interesting object should be selected, by clicking right mouse 
button and using the appropriate command to find the object. 

3.9. Model numbering 
The numbering of the model is one of the most important features in Tekla 

Structures. This is a necessary in the case of making drawings, reports, and 
statements. The program assigns the special characters to each element and the 
object in a model. Each character contains specific information about the 
element i.e. the prefix of the element or assembly, the number of the item, the 
name of the profile, genre of material. Numbering template must be done before 
making the model, in order to save time in the later stages of its development. 
Assigning numbers makes it much easier to work – through appropriate 
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indications can be easier to find a particular element in the model. The program 
makes model’s numbering not only dependent from the type of the element, or 
the material, but also from the orientation of the element, the type of 
reinforcement for reinforced concrete elements, surface finish, trademarks or 
other user–defined attributes. The identical numbering program gives to 
elements with the same geometry (including the dimension’s tolerance), the 
number series, profile, material or finish. Elements of the same class have the 
same number. 
 
Numbering series 

Numbering series can be selected as the default program’s settings or defined 
by the user. Each series consists of a prefix and initial number. The program by 
comparing the elements in the series gives them the same or separate numbers. 
In order to facilitate the work with the model user can predefine his own 
determination (e.g. by means of a table) and create from them template to work 
for subsequent models. 

The elements’ numbering is performed by command Drawings & Reports > 
Numbering, by selecting needed position (the numbering of the series, elements, 
control numbers, change and remove numbers, welds numbering). 
 
Own numbering 

To define own elements’ numbering double–click left mouse button and enter 
a new determination under element/assembly. Assemblies’ numbering is carried 
out in the same way, remembering that in the bottom menu select assemblies 
must be selected. 
 
Reinforcement of reinforced concrete elements 

Reinforcing bars are numbered based on their geometry, number series, size, 
steel grade and the radius of bends, for which in the file rebar_config.inp, user 
can define tolerance and the accuracy of rods’ rounding. The numbering of 
reinforcing bars has an impact on subsequent framework numbering. In the 
Numbering Settings tab in the Compare list, it is possible to select Reinforcing 
bars position – this feature is useful when user want to give different numbers to 
the same elements of different reinforcement. 
 
Numbering of the welds 

Numbering of the welds can be run by clicking Drawing & Reports > 
Numbering > Number Welds. The numbers that will be visible in the drawings 
and reports can be modified in the settings. 
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Operations carried out on numbers 
In Tekla Structures user can perform following operations while model is 

numbered: 
 saving the initial numbering – the initial numbers are defined by the user and 

are used to save the elements number: select elements > Drawings & Reports 
> Numbering > Save Preliminary numbers, 

 change of numbers – in the program it is possible to replace the existing, 
default defined by the program numbers on own, defined by user, without 
influence to the applicable number series; to change numbers click Drawings 
& Reports > Numbering > Change Number > choose option and then select 
element in the model >Get and in properties window, assign a new number 
>Modify when user make sure that everything is in order, 

 cleaning of numbers – by clicking Drawings & Reports > Numbering > 
Clear Numbers user can delete previously granted numbers by the program in 
order to define new numbering; new numbers are defined independently from 
the numbers that have been removed, 

 check the numbering – labels with numbering series can be enabled using the 
command: double–click left mouse button> View Properties > Visibility of 
object types > Display > Advanced > Part label and select from the list 
which parameters want to be displayed; in a similar way framework is 
numbering; it is also possible to change in the Numbering Settings the sort 
order and information display (Fig. 3.67), 

 fix number bugs – checking numbers is used for elimination of numbering 
errors; this is recommended before creation of reports and drawings; the 
number repair can be performed in Number Settings tab by comparing the 
numbers of new elements with the old ones; the second way is to use the 
Tools > Diagnose & Repair Model > All or Series of Selected Objects if user 
want to repair only the selected elements, not the entire model, 

 renumbering the model – option used when numbering of the model must be 
carried out from the beginning; old numbers positions during renumber 
process are deleted and replaced with new ones, deleted are also drawings 
which relates to the old numbering; this option is run by clicking Drawings & 
Reports > Numbering > Numbering Settings > Renumber All > Ok or Apply. 
Next Drawings & Reports > Numbering > Number Modified Objects. 
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Fig. 3.67. Numbering labels with parts and assemblies’ numbers 
 

 
 

Fig. 3.68. Menu of model numbering 
 
 control numbers – these are additional elements numbers, which facilitate 

their correct location in the model, e.g. numbers of parts or assemblies; these 
numbers are added by clicking Drawings & Reports > Numbering > Assign 
Control Numbers, then select the elements for which control numbers must 
be defined; additionally, in the properties window the numbering parameters 
can be changed, e.g. creating control numbers taking into account numbering 
series, changing the order of numbering, numbering using the determinations 
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made by the user; Apply button saves the control numbers, Create button 
creates new numbering; control numbers shall be subject to the same 
operations as ordinary numbers, i.e. changing the sort order, display these 
numbers in the model, removing the control numbers, closing and opening; 
Fig. 3.68 shows a basic menu to manage the model numbers. 

3.10. Introduction to drawings 
Drawings are an integral part of each construction project. In the BIM’s 

methodology each drawing is directly related to the generated model. Changes 
introduced into the model are automatically included on all drawings, which 
essentially reduces time of their preparation and reduces the risk of errors that 
may appear on the stage of performing an object. Only in some cases, the 
changes made in the model require to create drawings from beginning. Fig. 3.69. 
shows module to working with drawings. 

Tekla Structures enables creation of: 
 general arrangement drawings, 
 single part, assembly, formwork drawings, etc., 
 cast unit drawings, 
 planes, 
 cross sections, 
 construction details. 

 
In the drawings two types of elements can be distinguished: 

 planes – these are determined by the user views of individual objects, 
assemblies, many elements, sections from the specified direction (up, down, 
front, rear), 

 template – elements specifying the size of the drawings, the types of the 
tables with lists, records of observations and additional descriptions; the 
program has a series of ready to use templates, user can also define own 
settings. 
A drawing created in Tekla Structures is a series of 2D planes based on the 

3D model. Can be highlighted following objects in it: 
 building objects – building elements, fasteners (bolts, rivets, welds), 

reinforcement, finishing elements, facade, installations, individual system 
solutions, 

 associative annotation objects – dimension lines, comments, descriptions, 
special characters (defined by the user), 

 independent annotation objects – objects that are not permanently connected 
with the model: text, text files, symbols, links, DWG files, reference models, 
spreadsheets, 

 additional drawing objects – special shapes i.e. clouds, lines, rectangles. 
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Fig. 3.69. Interface to support editing of drawings 
 

For each drawing, the program can automatically generate summary tables 
and worksheets. It is also possible to place additional, descriptions and 
dimensions in the drawings’ edit window not occurring in the model. Drawings 
can also be exported to other programs and printed in PDF format. Filtering 
tools allow a precise definition of these elements in the drawing, which will be 
visible, while the rest is hidden and invisible. The update of drawings is 
automatic or must be performed manually, in case when the program will inform 
user, when geometry of elements will change, material data, the object has been 
deleted or given, and when the number of elements is changed. The program 
uses the automatically changes when user use the numbering of drawings. While 
changing the model program selects those drawings that are out of date and 
informs the user about the need to update them. Except in this case are general 
arrangement drawings, which are always up to date, even in the absence of their 
numbers. 

Objects that are updated automatically are marked using the association 
symbols (Fig. 3.70), which are visible when user select some object in the 
drawing. If the symbol is displayed with a question mark, it means that the 
program calls for the introduction of additional information on a given object. 
Association symbols do not appear on printouts. The association symbols can be 
disabled using the Shift + A shortcut. 
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Fig. 3.70. Association symbols 
 

Drawing properties can be modified on three levels: drawing, plane, and the 
level of the object, which is reflected by the emerging special properties 
windows: 
 modification on the drawing level by Drawing Properties window (Fig. 3.71) 

allows to modification of properties of the model objects, characters, 
reference lines, dimension lines, planes at the same time; changes can be 
made before execution of a drawing or in the course of its development and 
they are subjected to all planes, with the exception of the newly created, in 
which changes should be entered again, 

 modification on the object level allows to changes in View Properties 
(Fig. 3.72) window, but the changes are made only in a selected planes and 
appearing on them objects, 

 modification of the object level consists of individual changes to individual 
objects in their properties windows (Fig. 3.73); put in this way, the changes 
apply only to the specific objects; object properties can be applied at the level 
of the drawing and the view to define own drawings templates; it is 
recommended that changes in the course of editing drawings make beginning 
from the highest level i.e. from the drawing to the lowest level – the object. 
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Fig. 3.71. Drawing properties window 

 
 

Fig. 3.72. View properties window 
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Fig. 3.73. Object properties window 
 

Drawings in the Tekla Structures can be created by: 
 main menu, 
 toolbars, 
 pop–up menu commands, 
 Master Drawing Catalog. 

3.11. Creating drawings 
General arrangement drawings are projections showing the model from the 

specified direction, e.g. from top in case of planes, from the right in the case of 
façade. Creates on the need to provide a few planes on one drawing, the entire 
model, plan or views of individual store. 
 
Execution drawings 

Before performing any drawing in Tekla Structures several criteria must be 
met [Tekla Structures – Podręcznik Podstawowy]: 
 all model’s elements should be numbered (in general arrangement drawings it 

is not necessary, however, indicated if the markings on the drawings be the 
same as in the model); the numbering shall be carried out in order to link 
specific elements to specific drawings (this is necessary in the case of 
drawings, assemblies, individual components, formwork, etc.), 
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 details of which can be found in the model should be carefully drawn into 
and correctly described, 

 user should have chosen drawing template (default or custom), which places 
a particular view of the model. 
Before creating general arrangement drawings user must generate the 

relevant model’s views containing these views of the model that actually an user 
have on drawing/drawings. To generate the general arrangement drawings 
follow the steps described below: 
 create model’s views (Ctrl + P shortcut automatically calls the model’s view 

from the top), 
 click Drawings & Reports > Drawing Settings > General Arrangement 

Drawing and in properties window (Fig. 3.74) choose the needed settings, at 
the end click Load button, then OK or Apply, 

 click Drawings & Reports > Create General Arrangement Drawing or click 
 on toolbar; alternatively click right mouse button on background of the 

view, then select Create General Arrangement Drawing, 
 choose from the list views, which will be shown in the drawings (for this 

purpose user can use Shift and Ctrl keys), 
 in the Options list, select whether views has to be single or all on one 

drawing; in this moment there is also possibility to select Empty – empty 
template of the drawing will be generated, on which view can be added later, 

 to open the drawing immediately, select in addition Open drawing option, 
 click Create. 
 

Made drawings are automatically saved in the list of the drawings, which are 
tagged as GA. In the case of manufacture of a few drawings on the same view, 
successive versions of the drawing are overwritten and receive a separate 
determination. Example of general arrangement drawing of the steel structure is 
shown in Fig. 3.75. 
 
Single unit and assembly drawing 

Drawings of a single element and assembly are manufacturing drawings 
containing the details used in the manufacture of single items or their assemblies 
(Fig.3.76 and 3.77). 
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Fig. 3.74. General arrangement drawing properties window 

 
 

Fig. 3.75. General arrangement drawing of steel structure 
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Fig. 3.76. The gusset plate drawing 

 
To create a drawing of a single element of assembly follow the steps 

described below: 
 click Drawings & Reports > Drawing Settings > Single–Part 

Drawing/Assembly Drawing, 
 in the properties window select needed settings of the drawing’s template and 

click OK, 
 click Drawings & Reports > Create Single–Part Drawing/Create Assembly 

Drawing or click  on toolbar (in this case from the list select the 
appropriate type of drawing); 

 select the objects in the model for which drawings want to be made, drawings 
will be generated (while choosing elements must be remembered to select the 
appropriate option in the selection menu – selecting assemblies). 
The fastest, although not the most accurate way to create a drawing of 

a single part or assembly (because of the impossibility of drawing properties’ 
settings) is selecting the object, right–click mouse button and select from the 
pop–up menu Create Drawings > Single–Part Drawing/Assembly Drawing. In 
this case, the new drawing will be immediately opened in the drawings’ panel of 
Tekla Structures. 
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Fig. 3.77. Assembly drawing of girder beam 
 
Drawings of multiple objects 

In Tekla Structures it is possible to perform multi–drawings containing more 
than one item. Multi–drawings can also be generated as a statement of several 
views of separate drawings. By application of the relevant templates can be 
moved not only planes, but also a statements, summary tables, and reports. Prior 
to the formation of such a drawing, user must make sure that the individual 
drawings, that want to be combined into one are made correctly – this makes it 
possible to save time if necessary, correct them. To perform drawing of multiple 
objects with a couple of views by using principles of copying and linking follow 
the steps described below: 
 click Drawings & Reports > Create Multi–Drawing > Empty Drawing, 
 open empty drawing from Drawing list, 
 from the list of drawings user should choose these views to be placed on a 

single, general drawing, 
 click View > Add Views from Other Drawing > Copy/Copy with 

Layout/Link/Link with Layout – the program places a previously generated 
drawings at a one multi–drawing; in the case of updates and changes in the 
model, drawings of many elements are also updated. 
 
To create drawing of multiple elements from the selected drawings follow the 

steps described below: 
 select from Drawing list these drawings to be found on the multi–drawing, 
 click Drawings & Reports > Create Multi–Drawing > Selected Drawings. 
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Fig. 3.78. The menu to generate multi–drawings 
 

The drawing created in this way, the drawing does not have separate 
templates for tables and descriptions for each view. To add templates, instead of 
Selected Drawings, choose Selected Drawings with Layout. To create drawings 
of selected elements, select one of the available options (Fig. 3.78): 
 New Single – Part Drawings of Selected Parts option enables to create 

drawings of individual elements and their placement in drawings of many 
elements, 

 New Single – Part Drawings of Selected Parts with Layout option enables to 
create drawings of individual elements with their layout and place them in 
multi–drawing, 

 New Assembly Drawings of Selected Parts option gives the ability to create 
drawings of assembly elements and their placement in drawings of many 
elements, 

 option New Assembly Drawings of Selected Parts with Layout – to drawings 
of assembly elements shall be added the templates and layout of their 
distribution. 

3.12. Master Drawing Catalog 
The Master Drawing Catalog is a powerful tool for generating and managing 

all the drawings of the model. The main advantage of this feature is the presence 
of all the commands and settings for drawings, templates in one place. In this 
case the basis for the creation of individual model’s views is master drawing i.e., 
drawing, or a collection of settings that on further phase of the work on the 
model are used to generate new drawings, which in terms of template settings 
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for tables, descriptions, schedules and reports are the same as the master 
drawing. View of Master Drawing Catalog is shown in Fig. 3.79. In Master 
Drawing Catalog drawings are grouped on the basis of their designations: 
 W – single–part drawing, 
 A – assembly drawing, 
 CU – cast unit drawing, 
 GA – general arrangement drawing, 
 R – multi–drawing. 

One of the basic tools for creating new drawings are cloning templates i.e. set 
of table templates, descriptions, reports, dimension lines and designations. In 
Master Drawing Catalog user can select the appropriate template from the list, 
or join a new one, defined by the user. Each drawing template in Tekla 
Structures has saved settings that can be edited and changed by using properties 
windows. 

Another very helpful tool are rule sets, i.e., sets of rules to create drawings. 
These are respectively selected combinations of object’s groups based on the 
model selection’s filters that specify which elements want to be found on the 
drawings. As in the case of cloning templates, it is possible to use existing 
settings in the program as well as the introduction of new rules and principles. 

Drawing wizard is a file based on a few or a dozen sets of commands relating 
to drawings, all depicted on them elements and selection filters (e.g. parts, 
assemblies, etc.). It is important in this case, the order of the applied settings. 
The program, in accordance with the default saved settings always creates only 
one drawing of the element. Unlike the saved settings and rule sets, the user 
cannot define new drawing wizards, can, however, change their settings. 

By using the Master Drawing Catalog, it is possible to create the same kinds 
of drawings, as in the case of individually chosen commands. The procedure for 
the formation of the drawings is faster, as long as user rely on the default 
settings and does not introduce new principles and rules by editing their 
properties. 
 
Setting the object’s level in the saved settings 

Setting the object’s level, i.e., sets of rules of their posting, designation, 
presentation and describe on drawing can be attributed to the Master Drawing 
Catalog. Thanks to this user gain the ability to use the same settings for many 
drawings. To change the initial settings (also applies to changes of the drawings 
created by commands in the Drawings & Reports) follow the steps described 
below: 
 open Master Drawing Catalog using  button, 
 double–click left mouse button on selected setting, 
 in properties window (Fig. 3.80) select Edit drawing properties. 
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Fig. 3.79. Master Drawing Catalog 
 

 

 
 

Fig. 3.80. Master Drawing Properties window 
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 by select or deselect option choose the appropriate settings that are to be used 
in the drawing (Fig. 3.81), 

 it is possible to edit changes, change the colors of dimension lines, layers, 
selection of designations, change the settings for the presentation of 
connectors in the drawing, welds, elements, change the selection filters, 

 by OK and Save button confirm the selected properties, 
 click OK in order to close Master Drawing Catalog. 
 

 
 

Fig. 3.81. General arrangement drawing properties window 
 

By Master Drawing Catalog it is possible to execute following procedures: 
 creating general arrangement, single–part, assemblies, cast units, multi 

drawings, bolts schema drawings, 
 creating drawings (single and drawing sheets) using rule sets and wizards, 
 customize Master Drawing Catalog to user needs: adding drawings and 

templates, saved settings, rule sets, cloning templates, edit and modify their 
properties. 
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3.13. Editing drawings 
Generate drawing is not the final stage of its formation. In the interface to 

operate and edit drawings, there is a number of additional features, through 
which it is possible to change and further treatment of previously adopted 
settings. The most frequently used operations are: 
 
Cloning drawings 

The cloning operation is useful in a situation where in the model, there are a 
few similar elements, assemblies, which have other series numbers, and for this 
reason they should be on separate drawings. In the properties windows it is 
possible to select and properties parameterization thus obtained drawings. 
Cloning of drawings is also useful in situation when is requiring a significant 
range of manual drawings edition. Cloning of drawings can be done in two 
ways: 
1. Cloning by template of Master Drawing Catalog – procedure: 

 in a model click Drawings & Reports > Create Drawings, 
 double–click left mouse button in order to view drawing properties 

window, which you want to use (is useful in this case, knowledge of 
drawings designations), 

 in Create Drawings tab specify the way in which dimensions and 
characters will be cloned – there are options: ignore the characters and 
dimensions, clone or recreate them, 

 select what types of objects to be cloned, 
 to create drawings of specific elements, select them in the model (in this 

case, the selection filters are helpful), 
 click Create Drawings (Alt + C) or Create Drawings for all parts (Alt + 

A), 
 in case when model numbering is necessary (warning window), it should 

be carried out, 
 check the new drawings and their possible amendments. 
Cloned drawings in the list of drawings are marked as Cloned in the Change 

tab, this allows for their faster location, where the number of created drawings is 
significant. 
2. Cloning drawings by drawing list – procedure: 

 select in the model, which of its elements want to be placed on the cloned 
drawing – in the case of cloning single–part, assembly or cast unit 
drawing, these elements must be selected separately in the model; if the 
general arrangement drawing has to be cloned, select the model view, 

 click Drawings & Reports > Drawing List, 
 from the drawing list select the drawing, which will be used as a template 

for cloning, 
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 click Clone, 
 in properties window (Fig. 3.82) select the parts and positions that have 

been cloned, 
 in order to end procedure click Clone selected. 

 

 
 

Fig. 3.82. Properties window of Clone Drawing 

3.14. Drawings operations  
As „editing of the drawings” must be understood all the operations performed 

on the drawings, the aim of which is to introduce the settings affecting the 
accuracy and usefulness of a drawing as a vital element of the design 
documentation. Basic operations useful to effective work with drawings are 
described below. 
 
Changing the name and adding the drawing title 
 open Drawing List> click right mouse button on a drawing > select 

Properties,  
 uncheck all the checkboxes, 



165 

 select the checkbox next to the Name field (if you want to change the name) 
or title (if you want to add a drawing title), type the name or title, 

 click Apply. 
 
Drawing views 

Drawing views are drawings containing elements and 3D model’s objects, 
which can be added to an open, existing drawing. By Editing views it is possible 
to create a drawing from any direction of the model view. Drawing views can be 
created automatically using the appropriate tools or manually, if e.g. more 
accurate detail of element is required. To an already created drawing can be 
added: 
 view of entire model, 
 view of selected area in model, e.g. view of floor, 
 views of single parts in assembly, 
 views of 3D parts, 
 section view, 
 detail view, 
 parts reinforcement. 
 
Detail view 
 To create a detail view follow the instructions: 
 open a drawing, 
 click Annotating > Properties >Detail mark, 
 enter the name of a detail and modify properties, limits and range, 
 hold down Shift and click View > Create Drawing View > Detail View (it is 

possible to change the view’s parameters), click OK or Apply, 
 select the area of the detail – circle or rectangle, 
 select position for a detail mark – the detail view will be created. 
 
Section view 

To create a section view follow the instructions: 
 open a drawing, 
 click Annotating > Properties > Section mark, 
 in the properties window change the initial settings of the cutting line, 

section’s mark and view’s label, 
 click OK or Apply, 
 hold down Shift and click View > Create Drawing View > Section View (it is 

possible to change the view’s parameters), click OK or Apply, 
 select two points in order to determine the position of section, then two points 

to determine the cutting area and section depth, 
 select position for a section view – the section view will be created. 
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View of part in drawing 
To create a view of part in drawing follow the instructions: 

 open a drawing, 
 click View > Create Drawing View > Of Parts in Drawing, 
 from the properties window select one of the options: front, rear, top, bottom, 

3D – the drawing will be generated, 
 double–click left mouse button on the frame of the drawing, a dialog box will 

open in which it is possible to change the view’s properties contained in the 
drawing. 
Views of single parts can be added to assembly drawings or general 

arrangement drawings. It is possible to move, copy or link the views between the 
drawings. While modifying drawing’s views include: 
 changing the drawing view’s borders, 
 aligning views, 
 rotation, 
 organizing views around the drawing, e.g. on a large format paper, 
 modification of properties of detail, section, each part on the view. 
 
Rebar mesh view 

This is very useful function in case of creating reinforcement drawings and 
statements – in the case of reinforced concrete structures. To make 
a reinforcement view follow the steps described below: 
 open a drawing, 
 select meshes in the drawing, for which the view must be created (in case of 

views of all reinforcement meshes there is no need to select them), 
 click Tools > Macros, 
 from list select Rebar Mesh View Creator and click Run, 
 select one of the options: Create mesh view for all meshes in the 

drawing/Create view for selected meshes, 
 in order to add dimension lines and descriptions select the option Create 

annotations for selected meshes, in window it is possible to select the 
dimension and descriptions of rebar style, 

 in order to create view click Create. 
 
Adding dimension lines 

Each drawing generated in Tekla Structures has assigned the default 
dimension template, which in more or less accurate way informs a user about 
e.g. dimensions of a view or part. However, it is possible to manually add own 
dimension lines to the final drawings – this is one of the most important feature 
during drawings editing. To add a dimension manually follow the steps 
described below: 
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 hold down Shift and click Dimensioning – select one of the commands, 
depending on what type of dimension you want to add, 

 change the dimension’s format if necessary, add items in the dimension 
marks by changing their properties, 

 in Labels tab dimension’s labels should be added, 
 click OK or Apply, 
 create a dimension by the status bar commands, 
 place the dimension at the specified position. 
 
Types of manual dimensions 
 User can define manual dimensions on drawings, to ho this follow the steps: 
 parallel and perpendicular dimension (Fig.3.83a), 
 dimension of curved lines with orthogonal reference lines (Fig.3.83b), 
 curved dimension with radial reference lines (Fig.3.83c), 
 angular dimension (Fig.3.83d). 

In an open drawing user can edit the drawing’s dimensions by adding the tag 
to the dimension, e.g. rebar’s description. To add label follow the steps 
described below: 
 double–click left mouse button on dimension, 
 go to the Tags tab, dimension’s properties window will appear (Fig. 3.84) – 

in the appropriate fields, in accordance with designations it is possible to 
enter values or information, which want to be added to the drawing and edit 
the properties (color, rotation, font, height). 
Newly added dimensions, in addition to editing and changing the labels, they 

can be modified in ways, which are known for CAD programs, i.e. moving, 
merging, points changing, adding new points. They are also available functions 
related to the specific types of drawings, e.g. adding the dimension points to 
views of anchoring elements. The ability to add dimensions and their changes is 
very handy and useful tool, that allows for the introduction of new, often 
necessary changes, which are about the completeness of the drawing. 
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Fig. 3.83. Types of dimensions added manually 
 

 
 

Fig. 3.84. Dimension Properties window 
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Moving the dimension line 
The newly created dimensions you can edit and change their position. These 

operations can be very well known to users of CAD’s programs, because they 
are based on the same principles. To move the dimension line follow the steps 
described below: 
 in the drawing edition window click Dimension on the drawing – on the 

screen will appear the handles of dimension line editing, 
 select and drag the handle to the target position (while dragging, you can hold 

the Alt button), 
 along with moving dimension the value recorded on the label of the 

dimension will change. 
 
To drag a dimension mark follow the steps described below: 

 select a specific dimension line – in the case when dimension line will not be 
selected then entire dimension will be dragged, not only dimension mark – 
while selecting line besides dimension handles will appear also handles of 
dimension mark, 

 select the handle and hold down left mouse button, and drag the mark in the 
required target position. 
 
To connect the dimension lines (by manual connecting of individual 

dimensions or their groups, which are parallel to each other in one direction) 
follow the steps described below: 
 while holding the Ctrl button on your keyboard, select these dimensions, 

which want to be connected, 
 click Dimensioning > Edit Dimensions >Combine Dimension Lines. 
 

To connect to perpendicular dimension lines – a function of connecting of 
two or more mutually perpendicular dimensions – follow the steps described 
below: 
 while holding the Ctrl button, select two perpendicular dimension lines, 
 click Dimensioning > Edit Dimensions > Link Dimension Lines, 
 there is also the possibility of dividing the dimension lines – for this purpose 

select the connected earlier dimension line and click Dimensioning > Edit 
Dimensions > Unlink Dimension Lines. 

 
To add the dimension points follow the steps described below: 

 select the dimension line to which you want to add points – please note that 
points can be added only to one dimension line during the one operation, 

 click Dimensioning > Edit Dimensions > Add Dimension Point, 
 click the position on an element (in the drawing), on which new dimension 

point (or points) should be found, 
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 another option is to remove the already added point by clicking 
Dimensioning > Edit Dimensions > Remove Dimension Points and selecting 
the point that is to be removed. 

 
To add closing dimensions – these are dimensions that are used of example: 

in the case of drawing with dimension bars to close the dimension to the edge of 
the reinforced element – follow the steps described below: 
 open a formwork drawing (reinforcement of beam, plate, etc.), 
 select the line of bars group, 
 click Dimensioning > Edit Dimensions > Add Dimension Point, 
 select the points, in which the end dimensions should be placed, 
 the end dimension will be created. 
 

To set a new starting point of dimension follow the steps described below: 
 select an existing dimension in a drawing, 
 click Dimensioning > Edit Dimensions > Set Dimension Start Point, 
 select the new start point – the dimension will be updated automatically. 
 

To place the dimension text outside the dimension – in the case of setting the 
short text of dimension line outside the dimension lines (this setting is changed 
in General > Dimension Properties > Short Dimensions > External) there is 
possible to choose on which side of the line extension the text will be placed; to 
do this follow the steps described below: 
 click Dimensioning > Edit Dimensions > Flip Outside Dimension, 
 select the dimension, which text localization will be subjected to change – the 

text will be placed on the outside provided that the amount of space available 
in the drawing will be sufficient. 

 
To modify the dimension properties follow the steps described below 

(modification of properties in an open drawing): 
 double–click left mouse button on the dimension line, 
 unselect ale the check boxes in the dialog box, 
 select the check boxes for the properties to be modified, 
 in the General tab modify the properties such as: the dimension type, format, 

the placement of dimension in a drawing (in this case it is possible to select 
Free Dimension – then the program determines the localization and direction 
of a dimension; or Fixed Dimension – in this case user determines the 
location of dimension at any chosen point, 

 in the Appearance tab can be modified the text settings, lines and arrows 
(type, size, length of auxiliary and reference line), 
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 in the Marks tab can be modified the content of the dimension mark and 
zoom settings (scale), 

 in the Marks tab it is also possible to add elements to the dimension marks 
and change their appearance by clicking … near the Prefix and Suffix button, 

 in the Labels tab the dimension labels and their rotation can be added, 
 in order to apply all the changes click the Change button. 
 
Adding descriptions, comments, labels 

Descriptions and comments are right next to the dimensions the second 
characters’ family, using which it is possible to refine the drawings and their 
complement of necessary information. Part of the descriptions are entered at the 
stage of model creating during model numbering, however Tekla Structures, 
through extensive drawings editing interface, introduces additional functions of 
describing the drawings. This kind of additional information are called 
Annotation objects. These objects are subjected to update in case making 
changes into the model and drawings. 
 
Part’s marks 

Part’s marks can be added to all parts in a drawing, or only selected ones. To 
add labels to all parts, click Annotating > Add Part Marks > For All Parts. To 
add the labels only for selected parts, you must first select (using Ctrl) individual 
parts, and then click Annotating > Add Part Marks > For Selected Parts. 
Example of part’s marks are shown in Fig. 3.85. 
 

 
Fig. 3.85. The part marks 

 
Level marks 

Level marks (Fig. 3.86) are most commonly used in drawings of views and 
sections of construction. They are used to denote the height of the element, a 
level in relation to initially accepted 0.00 level. To add level marks follow the 
steps described below: 
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 open a drawing, 
 hold down Shift and click Annotating > Add Level Mark – dialog box will 

open, in which it is possible to make changes of the appearance and content 
of the level mark, 

 click Apply or Ok, 
 select a start point for the link and the position of the mark. 
 

 
 

Fig. 3.86. Level mark 
 
Associative Notes 

This is one of the most useful and powerful features available in the drawings 
editor. It allows to put in the drawing additional comments and descriptions, e.g. 
describing the conditions of assembly or concreting, finishing parts. Associative 
notes should be added by following the steps described below: 
 open a drawing, 
 hold down Shift and click Annotating > Add Associative Note; note can be 

added with leader line, if e.g. concerns an individual part; without leader line 
– if concerns a whole building; or along line, 

 by Content list select the object type to which you want to assign note, 
 in properties window select the type of label, 
 click Apply or OK, 
 select the parts that you want to assign. 

Fig. 3.87 shows an example of the comment’s label relating to the description 
of the concrete class and reinforcement of reinforced concrete beam. 
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Fig. 3.87. An example of associative note for reinforced concrete beam 

 
Objects of annotation are subjected to all rules of parametrization, which are 

available in Tekla Structures. By double–click left mouse button properties 
window of description or label will open, in which the display parameters can be 
changed – color, font size and information that should be displayed – for e.g. 
length, type of material, class or element position. These notes can be also 
updated in the case of applying changes in the model and the drawing, by using 
Annotating > Update Marks > All Part Marks/Selected Part Marks. 

Change the annotation objects properties concerns the changes made to the 
comments, welds designation, bolts, connectors, elements, reinforcement in an 
open drawing – to make changes follow the steps described below: 
 double–click left mouse button on the selected comment or mark, 
 uncheck all check boxes, 
 select the check boxes for the items, which have to be changed, in Content 

tab add the missing elements to the mark and change the properties of the 
element, 

 adjust the settings of the mark frame and line (color, thickness, transparency, 
visibility), 

 in order to place the mark in directly selected position click Place and from 
the displayed list select Fixed position, 

 having open dialog box, select at the drawing all the marks, for which 
changes shall be introduced according to the adopted schema of settings, 

 in order to approve all made changes click Apply. 
 

To update the annotation objects follow the steps described below: 
 in order to update all the elements marks click Annotating > Update Marks > 

All Part Marks, 
 in order to update the selected annotation marks, first select those marks that 

you want to update and then click Annotating > Update Mark> Selected Part 
Marks, 

 in order to update all the weld marks click Annotating > Update Marks > All 
Weld Marks. 
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Symbol of changes 
The symbols of changes are marks of the changes in the model presented in 

the drawings using special clouds. Offset of dimension points shall be identified 
(Fig. 3.88). 

By using the symbols of changes user can control the correctness of the 
adopted labels. After checking, in order to delete symbols of changes, click 
Dimensioning > Review Dimensions > Remove Dimension Change Symbol > 
Single/All. 
 

 
 

Fig. 3.88. Symbol of changes – reinforcement of concrete beam 
 

If the number of existing marks and symbol in the drawing is large, it is 
possible of their connection. To do this, click: Annotating > Properties > 
Merged Reinforcement Marks, then select the marks to be merged and click right 
mouse button in order to choose Combine option, which results in a combination 
of marks. It is also possible their separation through Separate Marks function. 
 
Independent annotation objects 

The term "independent annotation objects" should be understood as such 
objects that are not linked and connected with the model. These objects include 
text files, spreadsheets, drawings in DWG/DWF, special symbols, review signs, 
links and hyperlinks. 
 
Add text in drawings 

The ability to add external comments into the drawings, allows for a detailed 
description of all of the additional information from the designers and 
contractors.  To add text to a drawing follow the steps described below: 
 while holding down Shift button click Annotating > Add Text and then select 

the settings, 
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 enter text in the Text field, 
 modify the color of the text, its height, font type, angle and alignment, 
 select the type of reference line and size, and color of the text frame, 
 select the type and size of the arrow in the reference line, 
 put the text in the exactly chosen position by clicking the Put tab and 

selecting Fixed option on a Placing list, 
 click OK or Apply, 
 add the text. 
 
Top index in the text 

Top index can be used in all kinds of entering comments and additional 
information, dimensions and symbols. To place a top index follow the steps 
described below: 
 open the object’s dialog box, which contains text, e.g. frame, 
 use one of the available options – for the text objects you must enter the text 

in the Text field; for marks and comments associated with the drawing open 
the dialog box Mark content – text by double–clicking on text on Available 
elements list, and then type the text, 

 to put text in the top index, it should be placed in (^), 
 in order to apply and save changes click Change. 
 
Adding links to the text files 

You can add the text inside the frame in a drawing by a connection to a text 
file. Changes you make to the file are automatically transferred into the drawing. 
To add a link to a text file follow the steps described below: 
 open the drawing to which the text should be added, 
 click Annotating > Add Text > From Text File, 
 select color, font and height of the text, 
 select line type and color of the frame, 
 select text scaling option, 
 specify a text file that is to be bound to a drawing, 
 select the two points in the drawing for which the text frame will be 

specified, 
 click OK or Apply. 

In order to edit of placed text double–click left mouse button inside the text 
frame, while double–clicking on the text frame you can modify the properties of 
a text file. 
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Fig. 3.89. Link of drawings’ connection 
 
Adding links to other drawings 

Links allow to link drawings and creating a large database. To add link to 
another drawing follow the steps described below: 
 open a drawing, 
 click Annotating > Add Link > To Other Drawing, 
 in properties window it is possible to define the appearance and the way of 

link display, 
 by Scale customize tool the scale of the new object can be determined (link) – 

Fig. 3.89, 
 on the drawing list select the drawing/drawings to connect, 
 select the link localization and click Apply or OK to complete the procedure. 
 
Weld marks 

Besides to weld marks defined automatically, there is an option to mark them 
on the drawings (Fig. 3.90). The information that are contained in the weld 
description can be made both at the stage of creating a model and after drawing 
generation. To do this, click Annotating > Add Weld Mark. In dialog box 
(Fig. 3.91), which in case of welds provides many parameters to adjust, in 
standard way a specific type of presentation and display of mark is selected. 
 

 
 

Fig. 3.90. An example of description of fillet weld 
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Fig. 3.91. Weld Properties window 
 
Adding hyperlinks 

To add hyperlinks to websites follow the steps described below: 
 open the drawing that you want to add a hyperlink, 
 click Annotating > Add Link > Hyperlink, 
 modify color, size and type of font, 
 modify the type and color of the frame, 
 select the optional connection scaling, 
 in the text field put a file or URL, enter the URL or name and path of the file, 
 in order to introduce the text display function instead of a hyperlink, you 

must enter it in a Text field, 
 click OK or Apply in order to end the procedure, 
 choose by one or two points the location of the frame. 
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Adding links to DWG/DXF files 
In Tekla Structures it is possible to add links to drawing files created in CAD 

programs. To add such links follow the steps described below: 
 open the drawing that you want to add a link, 
 click View > Add DWG/DXF file, 
 select the scaling option, 
 select the type and color of the frame and thickness of the line, 
 in the Name tab select from the disk the file with the drawing, to which link 

will be referred, 
 select one or two points in order to determine the location of the frame, 
 click OK or Apply in order to approve changes, 
 when you add a link, in the case of a change in the target DWG/DXF drawing 

they will be included automatically in the drawing. 
 
Adding revision marks 

The revision marks are the marks added into the model or the drawing, 
containing information about the entered change by any user and the author of 
the model. To add revision marks follow the steps described below: 
 open the drawing that you want to make changes, 
 click Annotating > Add Revision Mark, 
 enter mark, date and information about made changes, 
 to put a revision mark in a specific place in the drawing click Put button and 

select Fixed from Placing list, 
 go to the Appearance tab in order to select color, height, font, type of frame 

and also line type, and arrow type, 
 click OK or Apply in order to introduce all the defined settings. 
 
Modification of the properties of independent annotation objects 

To change the previously entered properties of independent annotation 
objects follow the steps described below: 
 double–click left mouse button on modified object, 
 uncheck all check boxes, 
 select the check boxes for these object properties, which are to be subjected 

to changes,  
 modify the properties, 
 click OK or Apply in order to introduce all the defined settings. 
 
Additional drawing’s objects 

Additional drawing’s objects are objects in the form of clouds, lines, circles, 
arcs, broken lines, curves, which can be put in a drawing to add additional 
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information to the model. In order to generate such objects follow the steps 
described below: 
 while holding down Shift button click Shapes tab, 
 modify the properties of a defined shape – color, line thickness, appearance, 

etc., 
 click OK or Apply, 
 through proper execution of commands from the status bar specify the shape 

of the object, its location and scope. 
 
Colors in drawings 

The use of colors in many cases makes it easier to work with the model and 
the drawings. In Tekla Structures there are 3 basic color modes: black–white, 
shades of gray and color. In the primary pallet there are 12 basic colors, one 
special color and the invisible color. Each of the colors is available in the shades 
of gray as a degree of line saturation. 

The Tekla Structures operates on the following basic colors: black, red, 
green, blue, cyan, yellow, magenta, brown, dark green, dark blue, orange, grey. 

In the program it is possible to change colors depending on the needs and 
preferences of the user. To change the color follow the steps described below: 
 open the drawing, 
 click Tools > Options > Drawing Color Mode and select one of three 

options.  
Faster way to switch modes is using the "B" button on the keyboard of your 

computer. In grayscale mode the colors with the numbers 1–7 are shown as 
black, but colors in 8–14 in various shades of gray. 

It is also possible to set special color – the color, which on print is not shown 
as black, but depending on which mode is selected – be printed in color or in a 
suitable shade of gray. To set the special color follow the steps described below: 
 click Tools > Options > Advanced Options > Hatching, 
 define color using advanced options, 
 click OK or Apply, 
 open a drawing, 
 double–click on object in order to show the properties window, 
 select the type of fill, 
 select the fill color as special, 
 in order to approve made changes click Change. 
 
Working with drawings 

The ability to properly manage and manipulate the drawings enables much 
easier work on their development. In Tekla Structures these acts are performed 
by using the many tools that largely perform all these steps automatically. 
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Updating the drawings after changing the model 
Automatic updating of drawings after changing the model is one of the most 

important objectives of all BIM’s programs. To the upgrade shall be subjected 
parts’ drawings with changes made during the last model saving. The need to 
update is determined in software by using flags at a given position on the 
drawing list. Only the general arrangement drawings do not require updating – in 
this case, updates are always automatically made. In situation of renumbering of 
model’s objects, the drawings also should be updated. 

In the event of a change in the model – introduction of new marks, drawing 
new parts, changes in existing objects’ locations, changes in their geometry and 
the connections between them – the following steps should be performed, in 
order to make sure what updates in the drawings were made: 
 in Drawings & Reports > Numbering > Numbering Settings > Compare to 

old, the correctness of numbering should be checked, 
 in Drawings & Reports > Numbering > Number Series of Selected Objects 

the numbering should be given to elements with the same series number, or 
in Drawings & Reports > Numbering > Number Modified Objects, numbers 
of new elements should be added, 

 check on the drawing list positions designated by flags, 
 to locate the objects, which have been changed, click left mouse button on 

the flagged drawing and select Part selection – in Tools > Numbering 
history, it is possible to open a source file, in which the numbering history for 
parts and assemblies is contained; by reading the following entries it is 
possible to locate the changed positions, 

 on the drawing list, positions with flags must be updated by clicking Update, 
 in addition to the new elements in the model, new drawings must be 

executed. 
 
Closing and opening drawings 

These two functions are used to protect the drawings against accidental, 
unwanted modifications, updates, cloning or deleting in case when user want to 
keep the model’s views from the period before the introduced changes. To open 
or close a drawing follow the steps described below: 
 select on the drawing list positions to close/open, 
 click Lock > On/Off. 
 
„Freezing” of the drawings 

The freezing of the drawings is a function similar to its locking with the 
difference, that it is possible to introduce the geometry modifications of parts in 
a drawing in accordance with the changes made in the model, while still 
retaining the existing comments, descriptions, symbols, dimensions and links. 
Freezing does not delete the association, does not also affects the process  
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of drawing cloning. To freeze/unfreeze a drawing (depending on the type – 
general arrangement, single–part, assembly, cast unit drawing) steps described 
below should be followed: 
 save the model at the particular stage of its execution, 
 open the drawing list, 
 select the drawings to freeze, then click Freeze > On/Off. 
 
Deleting drawings 

To remove a drawing from the list, select in the drawing list positions 
intended to delete, then click Delete and confirm the ongoing operation by 
clicking Yes. 
 

 
 

Fig. 3.92. Revision handling window 
 
Drawings revision 

Revision of the drawings is a series of commands and functions enabling to 
add information about changes made during all stages of model’s development 
and the accompanying drawings. Revisions are marked with Revision number or 
mark, they can be shown on the drawing list or in reports. In the drawings, user 
can also add revision tables. To create revision follow the steps described below: 
 select on the drawing list positions to review, 
 click Revision – a dialog box will appear for handle revision (Fig. 3.92), 
 make up the information to be displayed as the information about the 

revision: mark, created by, date, checked by, approved by, additional 
information, description, 

 complete by clicking the Create button. 
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Tables 
The „table” term in Tekla Structures applies to all elements in the drawing, 

i.e. tables, lists, statements, title blocks (with drawing signature), comments, 
plans and reference drawings, lists and DWG/DXF files. For a specific layout or 
a drawing’s template the separate types of tables are assigned. Creating a new 
drawing’s template, the user must select and decide which tables will be 
included in the drawing, and what information they may contain. The 
arrangement of the tables in a drawing affects its content, because it determines 
the size of the area on which the view is placed. The size of the drawing may 
also decide about types and layout of the tables. To create a new layout of the 
tables follow the steps described below: 
 click Drawings & Reports > Drawing Settings > Drawing Layout 

(Fig. 3.93), 
 select one of the available commands: enter a name for a new layout and 

click Add – in this way the user introduces a new layout, which will be 
defined from the beginning; select one of the available templates, enter a 
name and click Add – in this way a new layout will be created on the basis of 
the existing one, 

 define a new layout by clicking Table layout, Fixed sizes, Calculated sizes, 
 close dialog box, 
 click OK to close dialog box. 

Created in this way a table’s template can be used in further work with 
drawings. The layout of the table concerns the adoption of a specific way of 
distribution and presentation of tables. Fixed sizes refers to the size of the 
format, in which the drawing will be placed. While calculated sizes determines 
the rules, on which software automatically adjusts the size of the drawing and 
the elements. To create a new table layout follow the steps described below: 
 click Drawings & Reports > Drawing Settings > Drawing Layout, 
 select the layout (default or created from beginning) from Layouts list, 
 click Table Layouts – a dialog box will appear, 
 enter a name of a new table layout, 
 click Tables – in the dialog box (Fig. 3.94), from Available tables list select 

position, according to which in the table a specific information will be 
written, 

 set the size of the margins and the distance between frames of the views, and 
the edges of the drawing format, 

 for new tables determine the position and transparency, 
 when you add a new table, remember to click on the Update button, 
 click OK or Apply to end new table layout creation. 
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Fig. 3.93. Dialog box of new table layout 
 

To add a map, which means a reference drawing showing the location of the 
element in the model follow the steps described below: 
 click Drawings & Reports > Drawing Settings > Drawing Layout, 
 select the layout that you want to modify (or create it from scratch according 

to the procedure mentioned above) and click Tables Layout, 
 select a table layout (or define from scratch) and click Tables, 
 from Available tables list select one and double–click left mouse button on 

Key Plan – on the screen a list of drawings will appear, 
 select a drawings, which ultimately has to serve as indicative plan – click 

OK, 
 from Chosen tables list select Situation Plan and modify its properties, 
 click Update and OK. 

 
Having defined a new table layout, it can be entered to use when generating 

new drawings: 
 click Drawings & Reports > Drawing Settings > Type of Drawing, 
 load the file of drawing properties and click OK, 
 click Layout and choose new layout from the list, then click OK, 
 click OK to approve new changes – new drawings will be created in 

accordance with newly defined table layout. 
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Fig. 3.94. Table Layouts window 
 
Size and drawing scale 

In Tekla Structures there are a number of combinations related to the size of 
the drawing itself (format), as well as to the scale of objects on them. The type 
of the scale and the size of the drawing may depend on, e.g. the type and size of 
objects contained on it, as well as the type of drawing. Through the auto–format 
function the software is able to choose the appropriate format, with a constant 
scale for all drawings. Autoscaling enables to the use of the same formats for 
multiple drawings while at the same time, the automatic selection of the scale. In 
addition, the software can define and change the size of the tables, depending on 
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the changes taking place in views, e.g. change in their number or size. To set the 
exact scale and automatic’s size follow the steps described below: 
 click Drawings & Reports > Drawing Settings > Type of Drawing, 
 in Layout it is possible to change the drawing size (standard or custom) and 

table layouts, 
 set the drawing size on Autosize, 
 in Autosize select: Calculated sizes – rules according to which the software 

will adjust the size of the drawing; Fixed sizes – when software has to choose 
specific sizes, e.g. A3, A4, A0; Calculated/Fixed sizes – choosing the 
smallest of matching sizes, 

 in Scale tab set appropriate scale, Autoscale – select No – the software is 
advised to use the exact scale for all views, 

 click OK or Apply, 
 click View or Sections and in Attributes set the desired scale, 
 click OK or Apply to end the procedure. 
 

To set the exact size (format) of a drawing and autoscaling follow the steps 
described below: 
 click Drawings & Reports > Drawing Settings > Type of Drawing, 
 in Layout set the drawing size on Specified size – enter the size of desired 

format, 
 in Scale tab set Autoscale – select Yes, 
 set the scales of views and sections – this involves the introduction 

denominators of scales, e.g. 1/50 scale corresponds to the introduction of 50; 
1:10 – 10, 

 select Scale change mode, 
 click OK or Apply, 
 click View > Attributes (or Section > Attributes) and enter selected scale, 
 click OK or Apply to end procedure. 
 

To set the dual function of autoscaling and automatic drawing’s size follow 
the steps described below: 
 click Drawings & Reports > Drawing Settings > Type of Drawing, 
 click View > Attributes (or Section > Attributes) and enter selected scale, 
 click OK or Apply, 
 click Layout >Scale tab, set Autoscale – select Yes, 
 define alternative scales, 
 select Scale change mode, 
 define Preferred size, 
 in Drawing Size tab set Size Definition Mode on Autosize, 
 click OK or Apply to end procedure. 
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Printing drawings 
Drawings in Tekla Structures can be printed on a paper or to a file, e.g. XPS 

or PDF. Printing drawings can be performed in several ways – it is possible to 
print from the drawing list, pop–up menu, using the icons in the panel of 
drawings edition, or menu commands. Before printing, you should always make 
sure, that the printer you intend to use is fully configured and if you do not need 
additional settings and drivers. 

To print a single–part drawing, e.g. detail (A4 format) follow the instructions: 
 open a drawing, 
 select Drawing File > Print Drawings – print drawings window will appear 

(Fig. 3.95), 
 in window select the printer, paper size, scale, fit to paper, orientation, color, 

type of frame, thickness and color of lines, 
 after selecting all values click Print.  
 

To print a single–part drawing, e.g. detail (A4 format or custom) follow the 
instructions: 
 open in a opened drawing the drawing properties’ window, 
 select Layout > Size > Autosize (if the drawing is to be printed on A3), or 

Specified size (when custom paper size want to be defined), click OK to 
approve made changes, 

 click Drawing File > Print Drawings, 
 click Add/Edit in order to check the print settings, 
 click Update or OK, 
 set the scale, orientation and print area as Whole drawing, 
 end the procedure by clicking Print. 
 

To create PDF files follow the steps described below: 
 open a drawing, 

 click Drawing File > Print Drawings, or , 
 change the settings of PDF printer, print and target file – after printing it is 

possible to open PDF file, 
 click Print. 

In addition, it is also possible to print multiple worksheets at the same time, 
using multiple printers. 
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Fig. 3.95. Properties window of Print Drawings 

3.15. Reports and statements 
Reports and statements are next to the drawings the most important part of 

the design documentation generated in Tekla Structures. It is possible to develop 
estimates, procurements and sales order, demand and consumption of materials. 
To create report in model’s menu select Drawing & Reports > Create Report. In 
the dialog box positions are included, according to which the report/statement is 
created. The basic criteria are the type of material, part, assembly, component 
(along with the components of these objects), connectors (in case of welds and 
bolts). Software allows to create a wide range of statements depending on the 
requirements and needs. An example material report is shown in Fig. 3.96. By 
changing the settings user can choose how the data will be displayed, e.g. in the 
case of further processing of these data in external applications, the format and 
style of table/list can be adopted. Reports, as well as drawings can be generated 
for the entire model as well as for his parts, objects and elements. 
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Fig. 3.96. Report with materials’ statement (steel/concrete) 

3.16. Tekla BIMsight 
Tekla BIMsight is an extensive, specialized application that allows to view 

BIM’s models developed by professionals from various industries. With this 
program it is possible to check the model and collisions, and changes made by 
many users, who are designing the object. The program supports the 
formats:.tbp, .ifc, .ifc,.zip, .ifcxml, .dgn, .dwg, .igs, .iges, .skp, .stp, .step, .xml, 
.xmlzip. It is particularly useful if you are working on the model, in which 
various software of BIM’s environment were used. Enabling the check of model 
to many users at the same time gives a greater chance to find design errors and 
effective model’s optimization. The appearance of the Tekla BIMsight’s 
interface is shown in Fig. 3.97. 
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Fig. 3.97. Window of Tekla BIMsight with view of steel–concrete structure 
 

The program introduces a wide range of tools for viewing the 3D model, 
which include: 
 buttons to rotate, move, zooming the model, 
 hide and show of individual items, 
 ability to highlight the elements by their name or function in the model – list 

on the right side, 
 search and determination of defects, conflicts and clashes into the model, 
 saving the notes and comments. 

4. Summary 
The monograph is devoted to discussing the BIM technology, which is used 

to carry out a construction investment, from conceptual work through design, 
execution, to putting the facility into use. 

In the BIM the most important is the 3D model of the building. This is not a 
normal geometric model dressed in aesthetically pleasing texture and creating 
nice visuals. In the BIM model, each element is a virtual equivalent of the real 
components of a building together with their characteristics. Each of the virtual 
elements is a digital prototype of the physical elements of the building: walls, 
columns, windows, doors, stairs, etc. This allows the BIM model to understand 
the building even before it is built: energy efficiency, control the cost of 
construction and materials, as well as the cost of living throughout the building's 
life cycle at the project stage. On the BIM model, it can be easily performed a 
variety of analyzes, from the elements of clashes detection, structural or energy 
analyzes to a sunshine analysis or an acoustic analysis. The BIM model is so 
useful not only at design time but also at construction time and long after its 
completion. 
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Thanks to the 3D modeling, the architect's building design process is 
analogous to the actual building process. But not only architects can benefit from 
the BIM model. It is an open technology – it allows the cooperation of 
information systems in various design branches and realization of an investment. 
With BIM all building design professionals (designers, installers, etc.) can be 
used. The work is performed on one virtual model, and the changes are made in 
parallel – it appears to all of the people working on the model simultaneously. 
Thanks to the accuracy of the BIM model elements, the prefabricates 
manufacturers are able to use the project to produce their components. The BIM 
model also allows for smooth management of the construction project during its 
implementation. In addition, with the advent of mobile devices, smartphones and 
tablets, BIM models have become available to customers, building owners and 
administrators. 

The BIM model offers a variety of applications because it is versatile and can 
be used in a wider range than traditional, and digital documentation. All 
available design methods, as a final design, provide information in the form of 
various 2D drawings, the "mesh" or 3D solid models, or quantitative data in the 
form of a table. These are often poor data that only contain mappings that do not 
contain any construction parameters, component characteristics, etc. These data 
need to be interpreted. 

While the individual elements of traditional documentation may be 
interrelated and contain the same information presented in different forms (e.g,. 
the size of the window on the plan may be the same as that in the summary of 
window frames), unfortunately this is not a prerequisite. For this reason there are 
the frequent inconsistencies of such documentation. 

All BIM data are stored in one central virtual building model, and the 
documentation that is created from the model, regardless of its form, represents 
the same model. This excludes the appearance of inconsistencies in 
documentation and consequently limits the number of errors. 

The BIM is the future of the construction industry. The detail of the model, 
the ease of information flow between the industries and the fluidity of project 
change, cost simulation and energy balance starting from building through the 
entire life cycle of the building – all of this makes the worldwide use of BIM 
models increase dynamically. BIM is a new paradigm in building design and a 
future global standard. 
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